• Cannot create donwload package list (metalinks)


    I am not able to install antergos on my laptop, using live usb, when trying install error: cannot create donwload package list (metalinks) appears.
    In cnchi log file i see: Can’t find these packages: lib32-mesa-libgl.
    I tried to update mirror lists and running sudo -E cnchi -dv --disable-rank-mirrors, but same error appears

    Can someone help me with this please?

  • Same problem here. I installed Antergos yesterday using the same live usb without any issue.

  • @kaDar

    lib32-mesa-libgl is not aviable in the repos, there was a renaming of the package to: lib32-mesa

    Do you try to install with steam?
    QUESTION GOES @developers too!!!

  • @joekamprad
    No, i tried without any additional selections

  • @kaDar using the latest ISO? 17.3 ?

  • @joekamprad
    Yes, also checked sum

  • Same problem here, yesterday I could install antergos without problem. Today after trying to install Bumblebee (had to format again due to problems) I can not install antergos anymore. Same problem with lib32-mesa-libgl. I need to have antergos installed for work, so any workaround will be very appreciated .

    PD: Tried with and without steam additional. Same problem in both tries. Also tried to update cnchi, no luck.

  • Gnome or different ? i fill a cnchi BUG then

  • Using antergos-17.3-x86_64.iso and trying to install with KDE.

  • can you both pastebin this two logs?

    • Link to /tmp/cnchi.log output.
    • Link to /tmp/postinstall.log.
  • i do a installation in this minute without problem, but inside virtualbox…

  • @joekamprad
    http://pastebin.com/1YGsGSyk for /tmp/cnchi.log
    /tmp/postinstall.log does not exists

    In virutal box it installs without problem for me too, but when i try install on my ssd it shows this error

  • Yeah I’m getting the exact same problem trying to install the base system

  • Now I’m downloading the minimal iso and I will try. As soon as possible I will post the results (and log in case of failure). Also I have to say that the error message shows an error number (don’t remember exactly right now). I will show the number in about 15 min (next try).

    You thing tring to install lib32-mesa before starting cnchi could be a solution? (I tried this option, but I can not install due to an error of not enough space in the live usb, but if you think it could work I can mess a bit more in this direction).

  • I had the same problem with the minimal iso. Here is the error:

    ‘Cannot create download package list (metalinks).’
    Please reference the following number when reporting this error: 514371

    And the logs:
    /tmp/cnchi.log -> http://pastebin.com/grirMQ0U
    /tmp/postinstall.log -> Not existing

    Edit: Forgot to say that this is with antergos-17.3-x86_64.iso. With the minimal it happens the same, the only difference is that the error code is ‘0’ instate of ‘514371’.

  • I could run the installation successfully by patching cnchi.

    find /usr/share/cnchi -type f -print0 | xargs -0 sed -i 's/lib32-mesa-libgl/lib32-mesa/g'

    But I’m now stuck at Installing Bootloader ('Running grub-mkconfig), should be a different issue.
    Edt: Resolved this one too, by detaching the old hard-drive from system during installation.

  • Patching cnchi worked for me!! Thank you!

    PD: All the installation went successfully (I had no problems in installing Bootloader phase)

  • It also worked for me!

metalinks14 donwload1 Posts 22Views 4246
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.