• Bumblebee: nvidia-installer needs a fix


    @karasu Hi there,

    @Nerfherder has recently found two discrepances in Antergos Bumblebee installation tools:

    1. Bumblebee for NVIDIA Optimus article became a bit obsoleted, due to recent changes in mesa stack

    2. nvidia-installer 1.6 doesn’t work well enough

    With @Nerfherder we already found the problem in the article and fixed it. The article is corrected, updated and tested. It works flawlessly again. This problem is closed.

    As for the 2nd issue, with nvidia-installer 1.6, I confirm the problem encountered by @Nerfherder. Once the system is rebooted after the successfull installation, it loads without any error until the message

    [ OK ] Reached target Graphical Interface
    

    is displayed. Then it hangs forever.

    The system may be booted into runlevel 3, but even startx doesn’t succeed in starting X.

    The reason of the error is the fact that nvidia-installer 1.6 creates one new file:

    /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
    

    I know nothing about it and what it serves for, it wasn’t needed some time ago.

    It’s a classic conf file, but its content is malformatted - it doesn’t have NewLine chars. The whole content is written in a single line only. I’ll try to paste it here:

    Section "OutputClass"Identifier "intel"MatchDriver "i915"Driver "modesetting"EndSectionSection "OutputClass"Identifier "nvidia"MatchDriver "nvidia-drm"Driver "nvidia"Option "AllowEmptyInitialConfiguration"Option "PrimaryGPU" "yes"ModulePath "/usr/lib/nvidia/xorg"EndSection
    

    The problem is easily fixed by hand:

    • change the conf qualifier to smth else, e.g., conf-original, so X doesn’t consider the file. Tested and works.

    • delete the file. Tested and works.

    • adjust it by hand to (tested and works):

      Section "OutputClass"
        Identifier  "intel"
        MatchDriver "i915"
        Driver      "modesetting"
      EndSection
      
      Section "OutputClass"
        Identifier  "nvidia"
        MatchDriver "nvidia-drm"
        Driver      "nvidia"
        Option      "AllowEmptyInitialConfiguration"
        Option      "PrimaryGPU" "yes"
        ModulePath  "/usr/lib/nvidia/xorg"
      EndSection
      

    Probably, something needs to be adjusted in the nvidia-installer’s check_nvidia_drm_outputclass_conf() function

    def check_nvidia_drm_outputclass_conf():
        nvidia_drm = [
    ...
    

    Regards

  • I used nvidia-installer today to install bumblebee, after reboot xserver was not able to start.

    I deleted /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and rebooted. everything worked fine.

  • @karasu Just wanted to confirm that \n, added at line #340 in nvidia-installer 1.9, has fixed the problem. Nvidia-drm.conf is written correctly, with EOLs, so the system boots without a problem after Nvidia installation. FTL: Faster Than Light :) !

    @all The issue is fixed in nvidia-installer 1.9. It’s not on the mirrors yet. Until then, the issue may be fixed with one of three tweaks above.

  • Hi,

    I’ve just discovered that the conf file is already installed with the nvidia-utils package, so it’s not really needed.

    I’ll remove it (it does not cause any conflict because nvidia-installer creates it in another folder, but it’s not necessary to have this setup file twice).

    Thanks again @just for all your tests!

  • @InvisibleRasta

    This topic is about nvidia-installer package. It is not about difficulties to install Nvidia on a laptop.

    Thus, the topic has been forked and may be continued here: Cannot install Nvidia.

    Regards

  • nvidia-installer 1.10 has fixed the unbootable GUI issue. Nouveau is correctly removed. Nvidia menu entry is correctly adjusted . Tested and works. The topic is closed.

    Regards

needs5 bumblebee34 Posts 6Views 615
Log in to reply