• No longer login in Gnome after installing GDM


    Hi guys,

    I’ve changed my display manager and change the default one for GDM.
    My problem now is when I try to login in Gnome Session computer freezes after login. On the other hand, I can login in Gnome on Xorg without problems. Any idea to be able to login in Gnome Session again?

    Cheers.

  • choose gnome-Xorg session inside gdm…
    Bild Text

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad Thanks for the answering, I was answering what is the difference between both.

    Cheers

  • Ahoi 😉

    Gnome standard is now wayland session called only Gnome is the Gnome-Wayland session…

    Normal behavior is that if you choose gnome (wayland) GDM try to start a wayland session and if this fails taking Xorg session… but as you see it freeze for you on fail…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad Thanks for the information. Are there any difference in terms of performance, characteristics, etc?

    Cheers.

  • I get wayland working a month ago and it was just better quality on watching video and also better fonts…
    But never get back to starup with wayland under gnome…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • and thank to you reminding me on Wayland i get it back working!

    I can not start wayland session because of conky! After disable conky autostarting i am back to wayland session.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad I have been using conky for a while in other distros but it is not configured in my laptop with Antergos yet. Because of that I suppose that it cannot be the problem. Are you using Gnome as well?

    Cheers

  • gnome here too…
    And you are right i reenable conky and put sleep to 25sec. and i can start wayland and conky under xwayland then…
    But before i disable all autostart programms + shell extensions and reenable one after the other … last one was conky …
    Wayland is not that stable itself then…

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad Maybe the question is effectively disable start up programs and extensions and login into Wayland. After that reenable everything. I have to check out that.

    Cheers.

  • As i can see at my System and Setup nouveau+gnome+wayland is still not working well… i go back to Nvidia Driver and xorg-session because i got Screen flickering with noveau.

    [updates once a week] = [90% less problems]
    my#repo
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    i3-°-xfce

  • @joekamprad Deactivating Startup apps and extensions worked partially. I was able to log into Wayland but some parts of the system worked funny. Some extensions that usually works with Wayland didn´t work. There was no way to make to work plank and other apps. Because of that at the end I left the laptop working in xorg-session.

gnome268 login89 installing79 longer6 Posts 12Views 1151
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.