• Like 0

    XPS 13 (9350) Sound Output - Bluetooth Headphones Option


    Hello Everyone,

    As the subject states, sometimes I cannot switch the sound from my laptop speakers to my bluetooth headphones. I’ve had to manually go into settings and then into sound and switch the output from the laptop speakers to my bluetooth headphones.

    However, it seems the last few times, after I connect and pair my headphones, the option for my bluetooth headphones under Sound is not displayed. AKA the only sound output option is the laptop speakers, even though the bluetooth headphones are paired and connected.

    Is there some additional tweaks I have to do to get bluetooth headphones working properly? Also, it would be a nice bonus if the sound automatically switches to the bluetooth headphones once they are connected (like Windows and MacOS do).

    Thanks,
    Asif

  • Like 0

    Anyone have any ideas? Thanks in advance!

    Thanks,
    Asif

  • Like 0

    bluetooth was allways like this, and will be also …
    You can only tweak it a bit…
    If you have luck Headset+Bluetoothdevice works good together…
    But A2DP is not allways working… and also pushing it on and off causes problems…

    Autoconnection:

    https://wiki.archlinux.org/index.php/Bluetooth_headset#Setting_up_auto_connection

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    Thanks Joe. I followed the wiki instructions, and it looks like the autoconnection works. My headphones pair correctly whenever I power on my bluetooth headphones now.

    So, there is NO solution to fix A2DP? Why would it not be addressed and fixed in the future? I am assuming that is why after I pair successfully, my sound options do not display the bluetooth headphones. I’ve found restarting Arch, turning bluetooth off/on, removing the device and repairing it, etc. does not have any effect.

    It seems to only work at random times, and I have no idea when or why…

    Thanks,
    Asif

  • Like 0

    do you use gdm?
    Prevent systemd from starting Pulseaudio anyway with socket activation :

    sudo -ugdm mkdir -p /var/lib/gdm/.config/systemd/user
    sudo -ugdm ln -s /dev/null /var/lib/gdm/.config/systemd/user/pulseaudio.socket
    

    Together with the autoconnect trick and removing the headset ones from bluetooth reconnect and trust with bluetoothctl i get autoconnect with A2DP mostly.

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad – I am using Gnome (GDM) as my Desktop Environment.

    I’m a bit fuzzy when you said the following:
    “removing the headset ones from bluetooth reconnect and trust with bluetoothctl i get autoconnect with A2DP mostly.”

    Remove the headset from the bluetooth GUI? And then re-add it via bluetoothctl in the command line (terminal) ? Also, I was not clear when to execute the commands you pasted.

    Just wanted to be sure I understood you correctly. Thanks.

  • Like 0

    yes! unpair with gnome-system-setting or bluetoothctl is the same… but you need “trust” the headset and this only is aviable with bluetoothctl from terminal:

    bluetoothctl
    power on
    agent on
    default-agent
    scan on
    pair XX:XX:XX:XX:XX:XX
    trust XX:XX:XX:XX:XX:XX
    connect XX:XX:XX:XX:XX:XX
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    and when do I execute the commands around Preventing systemd from starting Pulseaudio anyway with socket activation? Before the ones you pasted in the previously reply above?

    I have already done the “trust” step as part of the auto-connect instructions. OR are you saying you have to trust EACH time you want to use your bluetooth headset?

  • Like 1

    No trust is set till you unpair the device…
    I just find out how it works in the moment i help you ;)
    Still working here… if i put on my Headset it autoconnect with A2DP audio!
    May i write a WIKI entry to do not forget ;(

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad said in XPS 13 (9350) Sound Output - Bluetooth Headphones Option:

    No trust is set till you unpair the device…
    I just find out how it works in the moment i help you ;)
    Still working here… if i put on my Headset it autoconnect with A2DP audio!
    May i write a WIKI entry to do not forget ;(

    Sure! If you want want to write a wiki post on this, I don’t mind at all! =)

    So, I think I have it working, but which profile should I be using:
    http://imgur.com/a/3Jc2K

    Thanks again for all of your time and help, it is greatly appreciated!

    Thanks,
    Asif

  • Like 0

    @a4orce84 Headset Unit is for Headset mostly it is Mono + microphone enabled,
    A2DB is HIFI STEREO Profile Headphone.

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad - Got it working! Thanks for all your help and for the updates to the wiki! Huzzah, it feels good to get these small things working properly! =)

    Last question - Is there a way to “set” a profile each time the headphones connect? If I want to set it to the HIFI Stereo Profile for example.

  • Like 0

    i think it takes the last choosen profile, for me it does so. {And Gnome is doing it mostly like this}… your device must be able to get connected with a2dp !
    You can take a look:

    pacmd list-sources
    

    will give you something like this:

    index: 3
    	name: <bluez_sink.00_12_3D_00_3D_1C.a2dp_sink.monitor>
    	driver: <module-bluez5-device.c>
    	flags: DECIBEL_VOLUME LATENCY 
    	state: SUSPENDED
    	suspend cause: IDLE 
    	priority: 1030
    	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
    	        balance 0,00
    	base volume: 65536 / 100% / 0,00 dB
    	volume steps: 65537
    	muted: no
    	current latency: 0,00 ms
    	max rewind: 0 KiB
    	sample spec: s16le 2ch 44100Hz
    	channel map: front-left,front-right
    	             Stereo
    	used by: 0
    	linked by: 0
    	fixed latency: 45,32 ms
    	monitor_of: 2
    	card: 2 <bluez_card.00_12_3D_00_3D_1C>
    	module: 28
    	properties:
    		device.description = "Monitor of BH-M30"
    		device.class = "monitor"
    		device.string = "00:12:3D:00:3D:1C"
    		device.api = "bluez"
    		device.bus = "bluetooth"
    		device.form_factor = "headset"
    		bluez.path = "/org/bluez/hci0/dev_00_12_3D_00_3D_1C"
    		bluez.class = "0x240404"
    		bluez.alias = "BH-M30"
    		device.icon_name = "audio-headset-bluetooth"
    		device.intended_roles = "phone"
    
    

    You can see a2dp_sink.monitor for the headphone…
    [card: 2 <bluez_card.00_12_3D_00_3D_1C>]
    With:

    pacmd set-card-profile 2 a2dp_sink
    

    where 2 is my headphone yours can differ…

    you can force to enable a2dp after connect the device also… i do not know how to automate if Gnome-Bluetoothn does not recognize your last settings

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

xps6 sound29 bluetooth17 93504 Posts 14Views 167
Log in to reply