• Linux 4.10.1-1-ARCH - zlib_defalte not found


    Hello,

    I just update my system and had again the troubles with zfs, which I fixed quite easily this time:

    dkms install zfs/0.7.0rc3 -k 4.10.1-1-ARCH
    mkinitcpio -p linux -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    

    But this time I also get:

    ==> ERROR: module not found: `zlib_deflate’

    And I indeed don’t have any file named like that on my system, although core/zlib is installed.

    Any lead?

    Thanks in advance

  • @Geoffroy I’m getting that same error with 4.10 kernels and I’m fully up to date with the git master. The “fix” might be waiting for upstream and using a 4.9 based kernel for the time being. I’ve experienced similar issues as this with when changing from 4.7 to 4.8 and again from 4.8 to 4.9.

    I’ve since made it a point to keep multiple kernels installed just in case the Arch mainline kernel doesn’t work. I’m using, and have been for a while now, the linux-lqx kernel from the AUR. It’s currently 4.9.14-1.

    I keep linux(repo), linux-lqx(aur), linux-zen(repo), and linux-lts(repo) around for ZFS root issues.

    Arch mainline usually updates to newer versions first, so if it fails, I know not to update anything else until it doesn’t fail.

  • Hi again, sorry for late reply.

    Thanks for the tip @skeevy420, but that’s actually not even needed.
    After some googling, I found that zlib_deflate is not part of mkinitcpio and not as an external module, so the error is not supposed to be here, and I can boot without trouble.

    Here is the bug report related to that: https://bugs.archlinux.org/task/53304

4.10.1-1-arch1 zlibdefalte1 Posts 3Views 552
Log in to reply