• Issue with Installing Bumblebee/Optimus


    Hello all.

    I’m trying to install Bumblebee on a fresh Antergos system (using Gnome) as per the instructions given at the “Bumblebee-for-nvidia-optimus” page. (Can’t link it otherwise I can’t post because content is detected as spam.)

    I have gotten to the point where I install “Bumblebee (Current Hardware Drivers).” This is what happens:

    [[email protected] ~]$ sudo pacman -S bumblebee nvidia lib32-nvidia-utils lib32-virtualgl lib32-mesa-libgl nvidia-settings bbswitch
    resolving dependencies…
    looking for conflicting packages…
    :: lib32-mesa-libgl and lib32-mesa are in conflict. Remove lib32-mesa? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: lib32-mesa-libgl: requires lib32-mesa

    It has left me a bit confused. They conflict, yet one requires the other. I’m fairly new and even after a heart-to-heart with Google, I can’t figure out how to get past this. Any advice would be greatly appreciated.

  • Honestly, I have no idea who, when, why has added lib32-mesa-libgl to the list of explicitely installed packages.

    Starting from 2014, I installed Bumblebee, partecipated in various Bmb installers tests, and then wrote the article on native Debian, SolydXK, KWheezy, Tanglu, LMDE, native Fedora, RFRemix, Korora, openSuse, Tumbleweed, Gecko, native Arch, Evo/Lution, Architect, Antergos, Mageia, Rosa (Dew), PCLinuxOS. I may be missing something.

    Since then, I keep all Bmb-relates notes and all articles, published in various Wikies, forums, maillists etc. Nowhere - again, nowhere - I do not suggest to explicitely install lib32-mesa-libgl package.

    I’ll consider the possibility to limit the write access to the article in the future.

    Right now I’m rather busy, but later I’ll repeat all procedures described in AnteWiki, and eventually exclude lib32-mesa-libgl package.

    None of my own current Arch-Bmb installations has lib32-mesa-libgl installed.

    As a quick solution, try to install and run nvidia-installer package. It was extensively and carefully tested recently, and was demonstrated to be a very reliable Nvidia | Bmb installer.

    First, do a dry run with

    nvidia-installer --test --bumblebee
    

    If everything is OK, install Bmb with

    nvidia-installer --bumblebee
    

    Probably, the command must be preceeded with sudo.

    Good luck

  • @just Thanks for your reply. I know I had followed that page a few times in the past, and had been successful.

    I’ll need to be at work shortly, and it will be a while before I can get back to my machine. But I’ll try nvidia-installer and let you know how it works out.

    Again, thanks!

    -Travis.

  • @Nerfherder There’s no hurry. Maybe I’ll find smth about lib32-mesa-libgl by that time.

    Until 2017-01, when @karasu has developed nvidia-installer, I used the article to install Bmb too. It worked always well. I didn’t install it in recent 4-6 months.

    Regards

  • @just Hello again. I just attempted to use nvidia-installer. The test did not indicate any problems, and it appeared to be successful. However, on reboot I could not get past “Reached target graphical system,” or something like that. I am re-installing to get a clean slate for another shot at this; however, I do have the Xorg log file, which I will relay as soon as possible.

    My second attempt will be to follow to instructions on the page I mentioned, but without attempting to install lib32-mesa-libgl. We’ll see what shenanigans that causes. :D

  • @just My second attempt appears to have worked. I followed all instructions on the page, but removed lib32-mesa-libgl from the pacman -S line for installing current drivers. I rebooted and tested using glxspheres (both 32 and 64), and got the expected results. However, I’m not that knowledgeable about this, and believe that the possibility is high that I forgot to test something, so I am reluctant to mark this problem as solved too quickly, unless you agree that this is likely solved. Here are the results of my glxspheres runs:

    glxspheres32
    Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
    Visual ID of window: 0xb5
    Context is Direct
    OpenGL Renderer: Mesa DRI Intel® Haswell Mobile x86/MMX/SSE2
    62.086327 frames/sec - 69.288341 Mpixels/sec
    60.029101 frames/sec - 66.992477 Mpixels/sec
    59.987910 frames/sec - 66.946508 Mpixels/sec
    60.019255 frames/sec - 66.981489 Mpixels/sec

    [[email protected] ~]$ glxspheres64
    Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
    Visual ID of window: 0xb5
    Context is Direct
    OpenGL Renderer: Mesa DRI Intel® Haswell Mobile
    61.336164 frames/sec - 68.451159 Mpixels/sec
    59.999585 frames/sec - 66.959537 Mpixels/sec
    60.028345 frames/sec - 66.991633 Mpixels/sec
    59.957287 frames/sec - 66.912332 Mpixels/sec

    [[email protected] ~]$ optirun glxspheres32
    Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
    Visual ID of window: 0x21
    Context is Direct
    OpenGL Renderer: GeForce GTX 860M/PCIe/SSE2
    288.626363 frames/sec - 322.107021 Mpixels/sec
    291.370272 frames/sec - 325.169223 Mpixels/sec
    295.484963 frames/sec - 329.761219 Mpixels/sec
    299.621186 frames/sec - 334.377244 Mpixels/sec

    [[email protected] ~]$ optirun glxspheres64
    Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
    Visual ID of window: 0x21
    Context is Direct
    OpenGL Renderer: GeForce GTX 860M/PCIe/SSE2
    284.680996 frames/sec - 317.703991 Mpixels/sec
    299.031345 frames/sec - 333.718981 Mpixels/sec
    290.556300 frames/sec - 324.260831 Mpixels/sec
    300.670605 frames/sec - 335.548396 Mpixels/sec

    Also, here is the contents of the Xorg.0.log file after the failed restart after trying nvidia-installer:

    [ 39.585]
    X.Org X Server 1.19.2
    Release Date: 2017-03-02
    [ 39.585] X Protocol Version 11, Revision 0
    [ 39.585] Build Operating System: Linux 4.9.13-1-lts x86_64
    [ 39.585] Current Operating System: Linux Merovingian1 4.10.2-1-ARCH #1 SMP PREEMPT Mon Mar 13 17:13:41 CET 2017 x86_64
    [ 39.585] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=f6e0869e-fb35-4877-b45f-42498a9f8574 rw resume=UUID=786e9daa-1ec0-4ecc-988e-c49ba48629e8
    [ 39.585] Build Date: 03 March 2017 06:00:24PM
    [ 39.585]
    [ 39.585] Current version of pixman: 0.34.0
    [ 39.585] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 39.585] Markers: (–) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 39.585] (==) Log file: “/var/log/Xorg.0.log”, Time: Wed Mar 15 02:25:05 2017
    [ 39.585] (==) Using config directory: “/etc/X11/xorg.conf.d”
    [ 39.585] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
    [ 39.585] Parse error on line 1 of section OutputClass in file /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf
    “EndSectionSection” is not a valid keyword in this section.
    [ 39.585] (EE) Problem parsing the config file
    [ 39.585] (EE) Error parsing the config file
    [ 39.585] (EE)
    Fatal server error:
    [ 39.585] (EE) no screens found(EE)
    [ 39.585] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 39.585] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
    [ 39.585] (EE)
    [ 39.585] (EE) Server terminated with error (1). Closing log file.

    If there is anything more I can do to help clear this up, let me know.

  • @Nerfherder said in Issue with Installing Bumblebee/Optimus:

    @just My second attempt appears to have worked. I followed all instructions on the page, but removed lib32-mesa-libgl…

    Great, thank you very much! You did exactly the test I was going to do. With expected results - Bmb works without lib32-mesa-libgl.

    I’ll repeat the same test again, excluding lib32-mesa-libgl from installation, just to confirm your results. If, as expected, I’ll get the same results as yours, then we’ll remove lib32-mesa-libgl from pacman -S … in the article.

    Your framerates while running glxspheresNN on Intel and Nvidia are perfectly coincide with expected results. Simply speaking, they are good.

    You did a great job, discovering the redundant unneeded package, testing the installation without it, helping to improve the article. Much appreciated.

    I’m worried about insatisfactory results with nvidia-installer. After re-testing the manual installation and adjusting the article, I’ll turn back to test nvidia-installer again.

    Regards

  • @Nerfherder said in Issue with Installing Bumblebee/Optimus:


    If there is anything more I can do to help clear this up, let me know.

    Just one more simple test, when you’ll have a spare time. This one tests that Nvidia GPU is:

    • turned off by default, i.e., after a (re)boot (power-saving mode)
    • turned off again after running a command on Nvidia GPU (returns to power-saving mode)

    Simply reboot, and run three commands in sequence, one after another:

    • optirun --status - checks that Nvidia is Off by default
    • optirun pwd - turns Nvidia On and runs pwd on it
    • optirun --status - checks that Nvidia is switched back to Off

    The expected output looks like:

    ┌──[just]@[alexarp]:~$
    └─> optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    ┌──[just]@[alexarp]:~$
    └─> optirun pwd
    /home/just
    ┌──[just]@[alexarp]:~$
    └─> optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    
    ┌──[just]@[alexarp]:~$
    └─> 
    

    Discrete video card (Nvidia) must be reported always in Off by optirun --status command. If it is true, than Bmb works as it should - by default runs on Intel, saving the power, and automaticaly turns Nvidia power off after executing a command on Nvidia GPU. Thus, turning back to Intel and to power saving mode.

  • @just Just performed the test immediately after rebooting. It seems to have the expected output.

    [[email protected] ~]$ optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

    [[email protected] ~]$ optirun pwd
    /home/travis

    [[email protected] ~]$ optirun --status
    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

  • @Nerfherder Perfect. Thank you. Congratulations - both Bmb features work correctly on your system:

    • graphical acceleration
    • power saving

    Meanwhile, I’ve found where lib32-mesa-libgl comes from. It’s a rather long story, maybe I’ll do a separate post.

    Briefly - it was coming from Steam on older Antergos installations. It was renamed and has a different name now. It is still needed by Steam, under another name. It is not needed by Bumblebee (must check it better though).

    Even more briefly - everything we’ve done so far is very useful and correct.

    I’m making some restores, upgrades, backups for now. Didn’t have time to install Bmb by hand and with nvidia-installer yet.

  • @just Alrighty. Should I go ahead and label this solved then? :)

    Edit: Nevermind, I see that it already is. :D

  • @Nerfherder I finished all checks with Bumblebee installation by hand, strictly following Antergos Wiki Bumblebee article only. My results are exactly the same as yours.

    You’ve found the error in the article. You’ve found a way to fix it. Your results are exposed in clear, logical, easy to read posts. It’s a pleasure to read them and to collaborate with you.

    lib32-mesa-libgl is removed from the list of packages, explicitely installed for Bumblebee. I also added your GeForce GTX 860M to the list of cards on which Bmb was successfully installed.

    Changes made in Antergos Wiki article are usually not visible immediately, but with a 2-3 days delay.

    You helped to correct the article and make it better.

    Thank you

  • @just My pleasure. And thank you for your assistance with this, as well as the learning experience of working through it. Learning more about Linux is one of the reasons why I settled on Antergos (full-on Arch is still WAY out of my league). If there is any way I can help in the future, please let me know.

    Also, fwiw, one further test succeeded … I got Guild Wars 2 running on my system.

    Again, thanks!

pacman68 bumblebee24 conflict7 Posts 13Views 580
Log in to reply