• [Ideas?] Cant installing AMD Catalyst drivers


    Hi all,

    I just finished installing Antergos for… the 4th time. The reason is that while trying to install the AMD Catalyst drivers, for some reason, my OS dies (black screen)

    Im following this guide the catalyst driver installation guide in the Antergos forum , but when I do
    sudo pacman -Rcc lib32-ati-dri ati-dri xf86-video-ati
    the terminal returns:

    error: target not found: lib32-ati-dri
    error: target not found: ati-dri

    So, I said ok, if that is not found, maybe is not installed. So I removed that from the terminal command and just left sudo pacman -Rcc xf86-video-ati. Seemed to work because it asked me if I was sure I wanted to uninstall.

    After that, when I try to sudo pacman -S catalyst-hook catalyst-libgl catalyst-utils acpid qt4 I get all sort of errors

    **warning: acpid-2.0.28-1 is up to date – reinstalling
    ****resolving dependencies…
    warning: cannot resolve “linux<4.7”, a dependency of “catalyst-hook”
    :: The following package cannot be upgraded due to unresolvable dependencies:
    catalyst-hook

    :: Do you want to skip the above package for this upgrade? [y/N] y
    looking for conflicting packages…
    :: catalyst-libgl and libglvnd are in conflict (libgl). Remove libglvnd? [y/N] y
    :: catalyst-libgl and mesa are in conflict (mesa-libgl). Remove mesa? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: catalyst-libgl: requires mesa>=10.1.0-4
    :: cogl: removing mesa breaks dependency ‘mesa’
    :: gtk3: removing mesa breaks dependency ‘mesa’
    :: lib32-libglvnd: removing libglvnd breaks dependency ‘libglvnd’
    :: lib32-mesa: removing mesa breaks dependency ‘mesa’******

    Anyone has an idea? Everytime I tried a possible answer on the internet, I end up screwing my OS and getting a black screen… so…

    Thank you all very much.

    Cristian.

  • @holaz

    What is your graphic card?
    lspci | grep VGA

  • ATI R9 280

  • One other Question, why you dont use amdgpu driver?

    I use it with my HD 7790 without problems. Playing games function too.

  • @Uriel
    I dont know what you mean by amdgpu driver. I just thought that installing catalyst drivers is the normal procedure.

    I guess that after the instalation I had a “generic” driver installed.

  • AMDGPU is the open source driver from AMD: https://wiki.archlinux.org/index.php/AMDGPU

    I think its the better way than catalyst.
    Quote from: https://wiki.archlinux.org/index.php/AMD_Catalyst
    Catalyst packages are no longer offered in the official repositories. It is no longer updated by AMD and does not support the latest Xorg, so installing an old Xorg is required.

  • @Uriel

    Thank you Uriel, I will try installing those drivers. I have to collect some energy to re-install Antergos. Again, black screen at boot time, I guess I fu**ed it again while trying to install catalyst.

  • I have do an new installation yesterday.

    Amdgpu is my default driver after insstalling :+1:

    Good luck

  • BTW: black screen does not mean your system is dead… it only say: X is not running.

    @Uriel as we have only this: https://antergos.com/wiki/tag/amd-catalyst/ in wiki, you may want to write a little WIKI entry for AMDGPU? If you want only you can open a treat on this and others can join to be helpfull.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @Uriel yes please make a wiki about that!!! I’m using mesa drivers and i’m interested if that will improve my pc performance…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I will do my beste but i need help and time :)

    For these ones who need it now.

    Check your hardware:

    lspci | grep VGA

    Than check the following list:

    https://wiki.gentoo.org/wiki/AMDGPU#Feature_support

    If your card in the list is, look if amdgpu is loaded:

    lsmod | grep amdgpu

  • @Uriel can you open a new treat for “how to install amdgpu” or what ever?
    then we can sort everything together for a wiki entry!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @Uriel mine is HD8470D, not listed… but that’s fine :+1:
    at least you’ll be able to help others :+1:

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @joekamprad said in [Ideas?] Cant installing AMD Catalyst drivers:

    @Uriel can you open a new treat for “how to install amdgpu” or what ever?
    then we can sort everything together for a wiki entry!

    I made it, tommorow :)

catalyst8 [ideas]1 amd23 installing58 Posts 14Views 1247
Log in to reply