• Like 0

    Install Firefox Beta


    I just did a fresh install of Antergos Cinnamon and wanted to use Firefox Beta.

    I went to install it in the Package Manager and it gave a warning. Figured i had to remove normal Firefox, so I uninstalled Firefox from the package manager and tried installing the beta but got a new error.

    Saying firefox-beta /usr/share/applications already in file system or something… rebooted and stuff couldn’t get it.

    Currently have normal Firefox installed again.

    How do I remove Firefox and install Firefox Beta?

  • Like 0

    @noobertroon Hi!
    Can you try to uninstall through terminal with sudo pacman -Rns firefox and install you firefox beta again?
    If you get the same error message you’ll need to remove the files which are “already in file system or something”, something like:
    sudo rm /usr/share/applications/firefox AND ALL THE OTHER FILES/PATHS IN THE ERROR MESSAGE

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

  • Like 0

    I have done that but it says not a file or directory. This is the exact error message.

    conflicting files:
    firefox-beta: /usr/share/applications already exists in filesystem

    Nothing else, not about a Firefox folder, but the entire applications folder.

  • Like 0

    @noobertroon try removing firefox inside /usr/share/applications just in case… It can’t be the entire folder conflict… I guess firefox and firefox-beta has the same “firefox.desktop” name, so that’s why the conflict…

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

  • Like 0

    In this case its safe to use the following install command: sudo pacman -S --force firefox-beta

  • Like 0

    Sadly no luck.

    I ran sudo rm /usr/share/applications/firefox

    But it didn’t find anything. I then ran sudo pacman -S --force firefox-beta

    And it provides the same warning

    error: failed to commit transaction (conflicting files)
    unable to --force directory-file conflicts
    firefox-beta: /usr/share/applications exists in filesystem
    Errors occurred, no packages were upgraded.
    
    
  • Like 0

    @lots.0.logs i thought he was trying to install from yaourt, din’t know there is a firefox-beta in official repos…
    OffTopic: Does yaourt has an --force option?

    OBS: i just checked, the firefox-beta really is trying to create a /usr/share/applications, not /usr/share/applications/firefox.desktop like the “standard firefox”

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

  • Like 0

    So you are saying that I’m not the crazy or stupid one then?

    Anything to be done or?

  • Like 0

    @noobertroon Off course not friend… There aren’t stupid persons/questions here :p
    Since the package belongs to Antergos repos, i guess @lots-0-logs or some other devel. is gonna take a look at it as soon as possible…
    Le’ts wait…

    Antergos (default OS) - WIN10 (abandoned)
    MATE desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB

beta2 firefox19 Posts 9Views 105
Log in to reply