• kernel 4.10 and ACPI driver


    Hi

    I’ve just updated to 4.10.1.
    Previously, I had problems trying to update to the 4.9. kernels because it broke my Internet connection and so I kept using 4.8.13. until this morning. Now, Internet is OK but I worry about two error messages that appear in the following attached dmesg
    http://paste2.org/dCvWCkdB

      • at lines 246 and 247. These two lines appear on top of systemd 232 but do not seem to break anything
      • at lines 613 to 620: there are four ACPI warnings which recommend me to use a new ACPI driver (if available) instead of the native driver. I’d like to comply but does not know how to do it.

    The log journalctl is short and uneventful and shows no error.
    Does somebody knows better?
    ??

  • @roger64 said

    Previously, I had problems trying to update to the 4.9. kernels because it broke my Internet connection and so I kept using 4.8.13. until this morning.

    Hi. I cannot really help you out but considering the above, have you tried installing the lts kernel too,and see if it gets any better?
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch I have the same problem, in this post, you said that to change the kernel which I did and worked perfectly until the temperature went down to 44 ° C watching videos or listening to music. But now with the new update happened again the same problem. And that I have installed the Kernel-LTS. For your help, thank you very much.

  • I survived during the 4.9. kernel series by using the 4.8.13 kernel where I have absolutely no problem.

    I will revert to it after one day using the 4.10. because I experience an ACPI-related problem with this 4.101 kernel: most of the time (3 out of four), the computer does not wake up cleanly from sleep and stays blocked. So I have to start it again. After that the Internet connection is OK.

    My computer is a six year old Toshiba Satellite L750-T10N laptop. I will change it this summer … :)

  • Before reverting back to kernel 4.8.13., I’d like to try one thing: to discard driver nouveau and change it since I understand this is suggested by the error report in dmesg (see first message).
    Is there a recommended way to discard driver nouveau?

    Note: I reported a failure for wake on sleep. This happens only after some hours. The computer wakes up normally after a period under one hour (about)…

  • According to Arch Wiki, I did
    #modprobe nvidia
    #rmmod nouveau
    and rebooted but it failed to change anything. I probably miss something

  • do you want to use nidia driver instead of nouveau?
    Then you need to install nvidia driver first:

    use nvidia-installer from Antergos repo is the easy way to do so:

    sudo pacman -S nvidia-installer
    nvidia-installer -h
    

    Or manual:
    find suitable driver:

    lspci -k | grep -A 2 -E "(VGA|3D)"
    

    Will give you: VGA compatible controller: XY
    take a look here: http://www.nvidia.com/object/IO_32667.html
    If your card is not there you can use nvidia latest driver.

    pacman -S nvidia
    

    take a look f xorg is set up right:

    cat /etc/X11/xorg.conf.d/20-nvidia.conf
    

    have to look like this:

    Section "Device"
            Identifier "Nvidia Card"
            Driver "nvidia"
            VendorName "NVIDIA Corporation"
            Option "NoLogo" "true"
            #Option "UseEDID" "false"
            #Option "ConnectedMonitor" "DFP"
            # ...
    EndSection
    

    Make shure to not auto login to session (for stay save)
    reboot and login to your account make shure to choose XORG-Session and not to use wayland session …

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad

    Thanks joe.

    Two installer options failed for a question of dependencies, either bumblebee or even force. As my NVIDIA card was missing from the list, I installed the arch package nvidia and created the xorg.cong paragraph above. This time, Cinnamon crashed all the way.

    so, I switched back to kernel 4.8.13. and will try again with kernel 4.11. hoping that nouveau will have sorted out its problems.

    Thanks again for your help, I learnt something.

  • bumblebee is not yours…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Hi

    As I did for kernels 4.9 and 4.10, I tried again to install 4.11 as soon as it was available with Antergos.

    I met exactly the same problems as with 4.10. Though it appears to cause no trouble, there is a problem to put the computer asleep. After over one hour, it does not come back from its sleep and I need to reboot. This is of course unacceptable and so, I went back to kernel 4.8.

    I went a little further and used the new 17.5 iso just released. I read the same error messages and so did not try to install it…

    I do think there is an incompatibility of some kind with my Toshiba laptop L750-T10N

  • Well this looks solved….

    First, while still on kernel 4.8.13, I switched to nvidia driver. The install went smoothly and I was also updated to 4.11.2.1. but without the linux headers. so, I did install them on rebooting.

    I still get the two warning messages on top of systemd 232 (wdat-wdt, failed to claim resource 4 and another related to ACPI) but practically it seems that they cause now nothing wrong.

    I can resume from sleep. The only noticeable glitch I spotted was that the screen on resume was too dark, but using Cinnamon “luminosité” (lightness?) I gave screen the right level of light.

    and so it is after a six month wait, it’s now OK… :)

    For information, I also tried to download Antergos 17.5 last iso which gives me also the two same warning systemd messages… I did not try further to install it because it provided me nothing new on this regard.

    Furthermore, I suffered from a mysterious bug with VLC which looks totally unrelated: I could not display a video, only sound. Now, the same video can be properly displayed. Don’t ask me why.

acpi6 driver37 4.103 kernel74 Posts 11Views 936
Log in to reply