• Installation failed


    Hey,

    I’m already using Antergos on my desktop computer for several months and I love it.
    Now I have bought a new Notebook (ThinkPad T440s if it is relevant) and there I also wanted to install Antergos, but for some reasons I have several problems here.

    [*:3ab3p8cp]I know there were some problems with UEFI, but as I read here ([url:3ab3p8cp]http://forum.antergos.com/viewtopic.php?f=5&t=1545[/url:3ab3p8cp]) they are already solved. I used the latest testing ISO and flashed it on the USB-stick with dd. I also can see it in the UEFI menu, but when I select it, it cannot boot from it. Do I have something forgotten?[/*:m:3ab3p8cp]
    [*:3ab3p8cp]I booted then in legacy mode and tried to install it in this way. Here it can boot, but the testing.sh script didn’t worked. I get this:

    Previous testing setup detected, skipping downloads  
    Removing existing Cnchi...  
    Getting latest version of Cnchi from testing branch...  
    Cloning into 'cnchi'...  
    remote: Reusing existing pack: 9904, done.  
    remote: Counting objects: 10, done.  
    remote: Compressing objects: 100% (10/10), done.  
    remote: Total 9914 (delta 2), reused 0 (delta 0)  
    Receiving objects: 100% (9914/9914), 15.16 MiB | 1.13 MiB/s, done.  
    Resolving deltas: 100% (6767/6767), done.  
    Checking connectivity... done.  
    Switching to testing branch...  
    error: pathspec 'testing' did not match any file(s) known to git.  
    Starting Cnchi...  
    [[email protected] ~]$ Using GTK v3.10.7  
    [2014-04-12 13:42:03] [cnchi.py] ERROR: No module named 'mako'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/cnchi.py", line 58, in do\_activate  
    import mainwindow  
    File "/usr/share/cnchi/src/mainwindow.py", line 49, in <module\>  
    from installation import automatic as installation\_automatic  
    File "/usr/share/cnchi/src/installation/automatic.py", line 27, in <module\>  
    from installation import process as installation\_process  
    File "/usr/share/cnchi/src/installation/process.py", line 40, in <module\>  
    from mako.template import Template  
    ImportError: No module named 'mako'  
    [2014-04-12 13:42:03] [cnchi.py] ERROR: Can't create Cnchi's main window. Exiting...
    

    [*:3ab3p8cp]So I didn’t updated Cnchi and tried to install it directly, but this also fails. I attached an image.[/*:m:3ab3p8cp][/list:o:3ab3p8cp]

    Maybe you can help me. The best would be a clean install on UEFi beside an Windows installation.
    Thanks,
    Dominik

  • Hey,

    I’m already using Antergos on my desktop computer for several months and I love it.
    Now I have bought a new Notebook (ThinkPad T440s if it is relevant) and there I also wanted to install Antergos, but for some reasons I have several problems here.

    [*:3ab3p8cp]I know there were some problems with UEFI, but as I read here ([url:3ab3p8cp]http://forum.antergos.com/viewtopic.php?f=5&t=1545[/url:3ab3p8cp]) they are already solved. I used the latest testing ISO and flashed it on the USB-stick with dd. I also can see it in the UEFI menu, but when I select it, it cannot boot from it. Do I have something forgotten?[/*:m:3ab3p8cp]
    [*:3ab3p8cp]I booted then in legacy mode and tried to install it in this way. Here it can boot, but the testing.sh script didn’t worked. I get this:

    Previous testing setup detected, skipping downloads  
    Removing existing Cnchi...  
    Getting latest version of Cnchi from testing branch...  
    Cloning into 'cnchi'...  
    remote: Reusing existing pack: 9904, done.  
    remote: Counting objects: 10, done.  
    remote: Compressing objects: 100% (10/10), done.  
    remote: Total 9914 (delta 2), reused 0 (delta 0)  
    Receiving objects: 100% (9914/9914), 15.16 MiB | 1.13 MiB/s, done.  
    Resolving deltas: 100% (6767/6767), done.  
    Checking connectivity... done.  
    Switching to testing branch...  
    error: pathspec 'testing' did not match any file(s) known to git.  
    Starting Cnchi...  
    [[email protected] ~]$ Using GTK v3.10.7  
    [2014-04-12 13:42:03] [cnchi.py] ERROR: No module named 'mako'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/cnchi.py", line 58, in do\_activate  
    import mainwindow  
    File "/usr/share/cnchi/src/mainwindow.py", line 49, in <module\>  
    from installation import automatic as installation\_automatic  
    File "/usr/share/cnchi/src/installation/automatic.py", line 27, in <module\>  
    from installation import process as installation\_process  
    File "/usr/share/cnchi/src/installation/process.py", line 40, in <module\>  
    from mako.template import Template  
    ImportError: No module named 'mako'  
    [2014-04-12 13:42:03] [cnchi.py] ERROR: Can't create Cnchi's main window. Exiting...
    

    [*:3ab3p8cp]So I didn’t updated Cnchi and tried to install it directly, but this also fails. I attached an image.[/*:m:3ab3p8cp][/list:o:3ab3p8cp]

    Maybe you can help me. The best would be a clean install on UEFi beside an Windows installation.
    Thanks,
    Dominik

  • It sounds like you are experiencing the EFISTUB issue that is common with Thinkpads. Try using this ISO and let me know the result: [http://repo.antergos.info/iso/testing/uefi/antergos-2014.03.31-x86_64.iso][0]">[http://repo.antergos.info/iso/testing/u][1] … x86_64.iso

    If Cnchi fails again please post the contents of /tmp/cnchi.log here.

    Btw, I corrected the issue with the testing script

    Cheers!

    [0]: <a href=
    [1]: http://repo.antergos.info/iso/testing/u

  • Thank you for the quick reply. I will test it as soon as possible

  • Now I’m a step forward. I was able to boot from the USB-stick in UEFI mode and came to the screen, where I have to choose between “Antergos x86_64 UEFI CD”, two shells and so on.
    But when I select the first entry, only a black screen is coming.

  • How long do you wait at the blank screen before rebooting? I have heard of it staying on the blank screen for as long as 2-3 minutes before completing the boot successfully. Check to be sure that secure boot is disabled in your uefi firmware. You don’t have to use secure boot in order to use UEFI mode. Also while you are in the firmware menu, if you see “quiet boot” or a similar option, disable it as well. Finally if nothing seems to work you may have to install using Legacy Boot mode.

    Cheers!

  • It seems, that I have to install it in legacy mode. I had already disabled all options, which can produce problems (secure boot, quiet boot, some security settings,…) and waited 10 min and more. Also the LED at the USB-stick didn’t flash, so I don’t think, that something is transferring.
    A strange thing is, that the Arch-ISO has the same problem (I think you are using the same method), but Ubuntu and Windows are no problem.

    Nevertheless a big thank you for your support

  • You’re welcome. We are indeed using the Arch method currently. We will look into the method used by Ubuntu/Suse/Fedora and if it truly has a better success rate then we will implement it. Thanks for your feedback and welcome to Antergos btw

    Best Regards,
    Dustin

  • I think it will be a problem with my notebook, because the most other users have no problem with UEFI + Arch or Antergos.
    Btw: Could it be, that some server are offline at the moment? I cannot install Antergos (in legacy mode). Neither the test build nor the stable build. I always get “could not find database”. I attached the screenshot. And this is no complaint! It is only a hint, if it isn’t discovered yet

  • Looks like a mirror issue. You can select a different mirror in /etc/pacman.d/antergos-mirrorlist by leaving only one server un-commented.

    Cheers!

  • Yes, selecting a different mirror was working. Nevertheless I wasn’t able to install the latest test build (“Can’t initialize pyalpm.”), but the stable build was working.

  • Today I managed to install Antergos with UEFI. I don’t know which issue I had, but this time the test ISO ([url:3c9pp666]http://repo.antergos.info/iso/testing/uefi/antergos-2014.03.31-x86_64.iso[/url:3c9pp666] worked well.
    But now I have another problem: Antergos was installed without any Error with the newest testing script, but I cannot boot. Every time I try to boot, I get to a root shell named “emergency mode”. Does anybody know, what I can do? I have already reinstalled Antergos, but without success.

  • I’m getting of newest 32-Bit ISO MATE as GUI at the beginning the error [b:3ma00stf]“Can’t initialize pyalpm”[/b:3ma00stf]: the installation breaks. Any suggections?

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • @Freecaster,

    Hi - there’s many of us waiting upon a solution to your “Can’t initialize pyalpm” problem. Keep an eye on the most recent posts in & around this thread - hopefully not too long now

  • @“plenty”:g2tn0tgb said:

    @Freecaster,

    Hi - there’s many of us waiting upon a solution to your “Can’t initialize pyalpm” problem. Keep an eye on the most recent posts in & around this thread - hopefully not too long now[/quote:g2tn0tgb]

    Oh!

    You’re right, I was not the first, who is waiting for the solution of this big issue!

    I hope the problem will be solved fast.

    [img:37xo6dtq]http://antergos.com/wp-content/uploads/2013/04/logo.gif[/img:37xo6dtq]

  • @“der13teFreitag”:14ejx740 said:

    Today I managed to install Antergos with UEFI. I don’t know which issue I had, but this time the test ISO ([url:14ejx740]http://repo.antergos.info/iso/testing/uefi/antergos-2014.03.31-x86_64.iso[/url:14ejx740] worked well.
    But now I have another problem: Antergos was installed without any Error with the newest testing script, but I cannot boot. Every time I try to boot, I get to a root shell named “emergency mode”. Does anybody know, what I can do? I have already reinstalled Antergos, but without success.[/quote:14ejx740]

    Now I looked trough the log, which the “emergency mode” provides and I think I have found the relevant section:

      
    > Apr 16 13:47:47 ThinkPad systemd[1]: Mounting /boot...  
    > -- Subject: Unit boot.mount has begun with start-up  
    > -- Defined-By: systemd  
    > --  
    > --Unit boot.mount has begun starting up.  
    > Apr 16 13:47:47 ThinkPad kernel: FAT-fs (sda1): Unrecognized mount option "data=ordered" or missing value  
    > Apr 16 13:47:47 ThinkPad mount[206]: mount: wrong fs type, bad option, bad superblock on /dev/sda1,  
    > Apr 16 13:47:47 ThinkPad mount[206]: missing codepage or helper program, or other error  
    > Apr 16 13:47:47 ThinkPad mount[206]: In some cases useful info is found in syslog - try  
    > Apr 16 13:47:47 ThinkPad mount[206]: dmesg | tail or so.  
    > Apr 16 13:47:47 ThinkPad systemd[1]: boot.mount mount process exited, code=exited status=32  
    > Apr 16 13:47:47 ThinkPad systemd[1]: Failed to mount /boot.  
    > 
    
  • @“der13teFreitag”:25n3ezjr said:

    Now I looked trough the log, which the “emergency mode” provides and I think I have found the relevant section:[/quote:25n3ezjr]This should have been corrected. There must have been a regression somewhere. I will track it down. In the meantime you can fix this by logging in at the emergency shell and running:

    sudo nano /etc/fstab
    

    Find the line for your /boot mount point and then remove this:[code:25n3ezjr]data=ordered[/code:25n3ezjr]SOrry about that. Thanks for reporting the issue. Let me know if everything works okay after you make the above change.

    Best Regards,
    Dustin

  • Because I depend on my notebook I installed the newes testing build in BIOS mode and this works fine. If it helps I can install Antergos in UEFI on anoter partion and test your suggestion. Just tell me.
    Btw: In my working Antergos in BIOS mode I also have “data=ordered” in “/etc/fstab”, but the “discard”-flag was missing, altough it is an SSD.

  • Hi,

    Thanks for the report. If you don’t mind, post the contents of /etc/fstab here. Thanks.

    Cheers!

  • Yes, of course.
    Here it is (Antergos in BIOS mode):

    \# /etc/fstab: static file system information.  
    \#  
    \# Use 'blkid' to print the universally unique identifier for a  
    \# device; this may be used with UUID= as a more robust way to name devices  
    \# that works even if disks are added and removed. See fstab(5).  
    \#  
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    UUID=26e7835c-a748-4c18-8b3e-822bafbdc221 /boot ext2 rw,relatime 0 0  
    UUID=9269a850-6084-4694-a618-1d74ac02f3df / ext4 rw,relatime,data=ordered,discard 0 1  
    UUID=52029787-42cc-486a-b5ba-e8f8e13dd1c9 swap swap defaults,discard 0 0  
    tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0  
    
    

    The both discard-flags weren’t here in default installation, so I had written them there.

Posts 24Views 6494
Log in to reply