• Like 0

    Gstreamer, error al actualizar.


    Hola, el punto es que al actualizar gstreamer me tiene mas de 2 horas y siempre al compilar Pamac me tira error o la ventana diciendo “objetivo duplicado”

    Ya hace tiempo que estoy con este problema ya que se mete gstreamer en todas las actualizaciones que salen casi a disrio y es muy molesto. Una captura:

    0_1489097124163_GSTREAMER.png

    Gracias por adelantado.-

    Mis respetos.-

  • Like 0

    @judd (Sacado del Foro):
    En el anuncio oficial se decía esto: You also find the latest Upstream updates up till Fri Jan 27 18:42:25 CET 2017. gstreamer v0.10 and some depending packages on the other hand got removed. Please check your systems, as most of these packages got moved to the AUR, as support was put on hold for these applications and libraries.

    Pero en los comentarios del foro en ingles decían que los paquetes de Gstreamer quedaron “huérfanos” en la penúltima actualización y se recomendaba desinstalarlos (aunque no existe un método fiable para identificarlos a todos), checando primero las dependencias para que no fueras a eliminar algún programa que necesites, y asi te evitas estar con esas actualizaciones que tardan una eternidad. Actualiza sólo a gstreamer 1

    Aprendiendo que no es poco

  • Like 0

    @Velkerk said in Gstreamer, error al actualizar.:

    @judd (Sacado del Foro):
    En el anuncio oficial se decía esto: You also find the latest Upstream updates up till Fri Jan 27 18:42:25 CET 2017. gstreamer v0.10 and some depending packages on the other hand got removed. Please check your systems, as most of these packages got moved to the AUR, as support was put on hold for these applications and libraries.

    Pero en los comentarios del foro en ingles decían que los paquetes de Gstreamer quedaron “huérfanos” en la penúltima actualización y se recomendaba desinstalarlos (aunque no existe un método fiable para identificarlos a todos), checando primero las dependencias para que no fueras a eliminar algún programa que necesites, y asi te evitas estar con esas actualizaciones que tardan una eternidad. Actualiza sólo a gstreamer 1

    Hola @Velkerk !
    Si leí lo que tu dices, también busqué info en la red y no consigo dar en la tecla de como eliminarlos sin romper otros paquetes, por ejemplo gnome-shell…pues no se esperare a ver que pasa uotro que tenga más info.
    Igualmente gracias por tu tiempo @Velkerk !

    Mis respetos.-

  • Like 0

    Sí, otra persona con más conocimientos te puede ayudar. Pero este error es bastante común en el mundo ArchLinux, no quiero abrir una vieja polémica pero en la penúltima versión de Manjaro (16.10.3) me daba muchos problemas la instalación de gstreamer0.10 (después de instalar Manjaro me tiraba horas con más de 500 actualizaciones y el rollo de los gstreamer), acaban de sacar otra versión igual ahora va mejor. Pero en mis instalaciones de Antergos, de momento, no he tenido este problema, que no digo que no lo haya, pues las dos parten de ArchLinux, pero yo no lo he tenido.

    Aprendiendo que no es poco

  • Like 1

    Hola!

    Han eliminado todos paquetes de gstreamer versión 0.10, que es la versión antigua. Se considera que si un programa no se ha actualizado hasta ahora a la 1.0 es que nunca lo hará.

    Total, que ahora los gstreamer 0.10 están en AUR y ya no en los repos oficiales.

    Si teneís instalado algún programa de éstos que todavía no ha actualizado a gstreamer 1.0, cada vez que se actualiza gstreamer 0.10 o el programita en cuestión, yaourt (o pamac) compilará la nueva versión (operación muy costosa en tiempo).

    Mi recomendación es eliminar los paquetes gstreamer 0.10 y las aplicaciones que dependan de ellos y buscar otras alternativas más modernas que utilizen gstreamer 1.0

    Para ver los paquetes gstreamer0.10 que tengaís instalados, podeís utilizar pamac o directamente con pacman:

    sudo pacman -Qs gstreamer0.10
    

    Saludos!

  • Like 1

    sudo pacman -Qs gstreamer0.10
    Yo en Antergos: 0
    En Manjaro KDE 16.10.3: 9
    En Manjaro KDE 17: 0
    En la última versión de Manjaro parecen ser eliminados y no se solicita su instalación desde AUR una vez instalado Manjaro.
    Muy buena actualización lo han dejado de lujo.

    Aprendiendo que no es poco

  • Like 0

    Hola @karasu

    Gracias por tu respuesta y esto es lo que tengo de gstreamer 0.1

    $ sudo pacman -Qs gstreamer0.10
    [sudo] password for judd: 
    local/gstreamer0.10 0.10.36-16
        GStreamer Multimedia Framework
    local/gstreamer0.10-bad 0.10.23-26
        GStreamer Multimedia Framework Bad Plugin libraries (gst-plugins-bad)
    local/gstreamer0.10-bad-plugins 0.10.23-26 (gstreamer0.10-plugins)
        GStreamer Multimedia Framework Bad Plugins (gst-plugins-bad)
    local/gstreamer0.10-base 0.10.36-9
        GStreamer Multimedia Framework Base plugin libraries
    local/gstreamer0.10-base-plugins 0.10.36-9 (gstreamer0.10-plugins)
        GStreamer Multimedia Framework Base Plugins (gst-plugins-base)
    local/gstreamer0.10-ffmpeg 0.10.13-9 (gstreamer0.10-plugins)
        Gstreamer FFMpeg Plugin
    local/gstreamer0.10-good 0.10.31-17
        GStreamer Multimedia Framework Good plugin libraries
    local/gstreamer0.10-good-plugins 0.10.31-17 (gstreamer0.10-plugins)
        GStreamer Multimedia Framework Good Plugins (gst-plugins-good)
    local/gstreamer0.10-ugly 0.10.19-21
        GStreamer Multimedia Framework Ugly plugin libraries
    local/gstreamer0.10-ugly-plugins 0.10.19-21 (gstreamer0.10-plugins)
        GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)
    
    

    Luego al querer borrarlos todos me tira esto la consola (seguro ahi algo mal)

    $ sudo pacman -Rns gstreamer
    comprobando dependencias…
    error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
    :: cheese: quitando «gstreamer» se rompe la dependencia con «gstreamer»
    :: gnome-shell: quitando «gstreamer» se rompe la dependencia con «gstreamer»
    :: gst-plugins-base-libs: quitando «gstreamer» se rompe la dependencia con «gstreamer»
    
    

    Mis respetos.-

  • Like 1

    Hola,

    El comando está equivocado (es gstreamer0.10 y no gstreamer a secas, gstreamer a secas se refiere a la 1.0).

    Prueba borrarlos así:

    sudo pacman -Rsnc gstreamer0.10 gstreamer0.10-plugins
    

    Saludos!

  • Like 1

    @karasu said in Gstreamer, error al actualizar.:

    Hola,

    El comando está equivocado (es gstreamer0.10 y no gstreamer a secas, gstreamer a secas se refiere a la 1.0).

    Prueba borrarlos así:

    sudo pacman -Rsnc gstreamer0.10 gstreamer0.10-plugins
    

    Saludos!

    Tienes razón @karasu, ahora si funcionó

    $ sudo pacman -Rsnc gstreamer0.10 gstreamer0.10-plugins
    [sudo] password for judd: 
    comprobando dependencias…
    :: ffmpeg requiere opcionalmente ladspa: LADSPA filters
    :: xine-lib requiere opcionalmente libmpcdec: for using the musepack plugin
    
    Paquetes (21) faac-1.28-5  gstreamer0.10-bad-0.10.23-26
                  gstreamer0.10-base-0.10.36-9  gstreamer0.10-good-0.10.31-17
                  gstreamer0.10-ugly-0.10.19-21  ladspa-1.13-6
                  libcdaudio-0.99.12.p2-1  liblrdf-0.5.0-2  libmp4v2-2.0.0-4
                  libmpcdec-1:0.1+r475-1  libmusicbrainz5-5.1.0-2  raptor-2.0.15-5
                  soundtouch-1.9.2-1  spandsp-0.0.6-1  wildmidi-0.4.0-1
                  gstreamer0.10-0.10.36-16  gstreamer0.10-bad-plugins-0.10.23-26
                  gstreamer0.10-base-plugins-0.10.36-9
                  gstreamer0.10-ffmpeg-0.10.13-9
                  gstreamer0.10-good-plugins-0.10.31-17
                  gstreamer0.10-ugly-plugins-0.10.19-21
    
    Tamaño total quitado:  38,33 MiB
    
    :: ¿Desea quitar estos paquetes? [S/n] 
    :: Ejecutando los «hooks» de preinstalación...
    (1/1) Uninstalling GConf schemas...
    :: Procesando los cambios de los paquetes...
    ( 1/21) quitando gstreamer0.10-ugly-plugins        [----------------------] 100%
    ( 2/21) quitando gstreamer0.10-ugly                [----------------------] 100%
    ( 3/21) quitando gstreamer0.10-good-plugins        [----------------------] 100%
    ( 4/21) quitando gstreamer0.10-good                [----------------------] 100%
    ( 5/21) quitando gstreamer0.10-ffmpeg              [----------------------] 100%
    ( 6/21) quitando gstreamer0.10-base-plugins        [----------------------] 100%
    ( 7/21) quitando gstreamer0.10-bad-plugins         [----------------------] 100%
    ( 8/21) quitando wildmidi                          [----------------------] 100%
    ( 9/21) quitando spandsp                           [----------------------] 100%
    (10/21) quitando soundtouch                        [----------------------] 100%
    (11/21) quitando libmusicbrainz5                   [----------------------] 100%
    (12/21) quitando libmpcdec                         [----------------------] 100%
    (13/21) quitando liblrdf                           [----------------------] 100%
    (14/21) quitando raptor                            [----------------------] 100%
    (15/21) quitando ladspa                            [----------------------] 100%
    (16/21) quitando libcdaudio                        [----------------------] 100%
    (17/21) quitando faac                              [----------------------] 100%
    (18/21) quitando libmp4v2                          [----------------------] 100%
    (19/21) quitando gstreamer0.10-bad                 [----------------------] 100%
    (20/21) quitando gstreamer0.10-base                [----------------------] 100%
    (21/21) quitando gstreamer0.10                     [----------------------] 100%
    :: Ejecutando los «hooks» de posinstalación...
    (1/2) Compiling GSettings XML schema files...
    (2/2) Arming ConditionNeedsUpdate...
    
    

    Gracias como siempre !!!

    Mis respetos.-

gstreamer4 actualizar7 error125 Posts 9Views 202
Log in to reply