• Configuring touchpad settings (libinput) on Wayland


    I have scoured Google for the past 24 hours trying to figure out how to configure libinput on Wayland, to no avail. I have found lots of forum posts and articles detailing how to configure the /etc/X11/xorg.conf.d/40-libinput.conf file, but it seems this only affects XOrg and does not change anything for me. I’ve also played around with xinput set-prop device-number option-number setting commands, but again it looks like this only applies to XOrg because when I make changes nothing happens, and when I reboot it is all reset. All I really want to do is enable palm detection on my touchpad and enable natural scrolling, as well as tap-to-click, none of which are enabled by default with the libinput package. For the life of me I cannot figure out how to configure libinput on Wayland. There are no touchpad options in Settings > Mouse & Touchpad, or in Tweak Tool > Keyboard and Mouse. I would really appreciate any help with this, as again I have been Googling for the past 24 hours and have gotten nowhere.

  • Hi!
    I use pc here, but i found libinput-git on AUR that “handle input devices under wayland”. I guess it’s worth if you check it.

  • @fernandomaroto said in Configuring touchpad settings (libinput) on Wayland:

    Hi!
    I use pc here, but i found libinput-git on AUR that “handle input devices under wayland”. I guess it’s worth if you check it.

    Wow, that worked like a charm! The touchpad options showed up in Settings > Mouse & Touchpad and everything, it seems like palm detection is working now too. Can’t believe it was that easy… I wonder why libinput-git works but not libinput from the official Pacman repository?

  • @mwillis i have no idea, probably was modified for that job.
    I’m glad my guess helped you hehehe 👍
    Cheers!

touchpad55 wayland51 libinput5 configuring4 Posts 4Views 5054
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.