• Like 0

    Problem with sound (headphones ok, speakers only noise)


    Hello, good morning
    Well, i have a little problem with sound card, or output.
    When I try to play a sound I only hear any similar a noise (like if digital output over front speakers), i have tried diferent options to try to solve:
    -Using pavucontrol change analog duplex output (i don’t know if is right, i got it in spanish) to Stereo analog output. With hdmi turned off.
    -Changed the alsa order with a alsa-conf on /etc/modprobe.d/alsa-conf.conf:

    [[email protected] ~]$ cat /etc/modprobe.d/alsa-conf.conf 
    # Intel PCH
    options snd-hda-intel index=0  model=laptop vid=8086 pid=9c20 snoop=0
    # Intel HDMI 
    options snd-hda-intel index=1  model=auto vid=8086 pid=0a0c snoop=0
    

    -Changed /etc/libao.conf, from default driver alsa to pulse:

    [[email protected] ~]$ cat /etc/libao.conf 
    default_driver=pulse
    dev=default
    

    -I have tried do a fresh install and didn’t work.

    I will try to add all information that people ask to can try to find a solution, I’ll try to be organized, list of outputs:
    -lpci -nn:

    [[email protected] ~]$ lspci -nn
    00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 09)
    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
    00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 09)
    00:14.0 USB controller [0c03]: Intel Corporation 8 Series USB xHCI HC [8086:9c31] (rev 04)
    00:16.0 Communication controller [0780]: Intel Corporation 8 Series HECI #0 [8086:9c3a] (rev 04)
    00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
    00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 3 [8086:9c14] (rev e4)
    00:1c.3 PCI bridge [0604]: Intel Corporation 8 Series PCI Express Root Port 4 [8086:9c16] (rev e4)
    00:1d.0 USB controller [0c03]: Intel Corporation 8 Series USB EHCI #1 [8086:9c26] (rev 04)
    00:1f.0 ISA bridge [0601]: Intel Corporation 8 Series LPC Controller [8086:9c43] (rev 04)
    00:1f.2 SATA controller [0106]: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] [8086:9c03] (rev 04)
    00:1f.3 SMBus [0c05]: Intel Corporation 8 Series SMBus Controller [8086:9c22] (rev 04)
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
    02:00.0 Network controller [0280]: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
    

    -cat /proc/asound/modules:

    [[email protected] ~]$ cat /proc/asound/modules 
     0 snd_hda_intel
     1 snd_hda_intel
    

    -aplay -l

    [[email protected] ~]$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC3223 Analog [ALC3223 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
    

    The option about amixer sset Master unmute is did. All channels in alsamixer are unmuted
    When i test speaker-test -c 2, when is playing on 0 (front left) i don’t hear any but when is playing 1 (front right) i can hear noise, not a clear sound.
    If I do a systemctl --failed i obtain the next:

    [[email protected] ~]$ modprobe snd_hda_intel
    [[email protected] ~]$ systemctl --failed
    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
    

    And… i don’t know what else to try. All help and ideas are welcome, thanks a lot for read.

  • Like 0

    why alsa? and not pulseaudio?
    pavucontrol should be the right tool

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad tried, with output selected as speakers:
    alt text
    and in config:
    alt text
    I tried both options, analog duplex and analog output with same effect (nothing). For that trying with alsa.

  • Like 0

    what speakers do you use?

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad is a laptop, internal speakers. To be a bit more specific, is a Dell inspiron 3737, if needed i could do a inxi to post all output.

  • Like 0

    00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
    00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 09)

    Do you have alsa-utils installed and:

    pacman -Qs alsa
    

    So now i see… two audio-devices recognized.

    http://alsa.opensrc.org/MultipleCards

    https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad said in Problem with sound (headphones ok, speakers only noise):

    00:1b.0 Audio device [0403]: Intel Corporation 8 Series HD Audio Controller [8086:9c20] (rev 04)
    00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 09)

    Do you have alsa-utils installed and:

    pacman -Qs alsa
    

    So now i see… two audio-devices recognized.

    http://alsa.opensrc.org/MultipleCards

    https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

    [[email protected] ~]$ pacman -Qs alsa
    local/alsa-lib 1.1.3-1
        An alternative implementation of Linux sound support
    local/alsa-plugins 1.1.1-1
        Extra alsa plugins
    local/alsa-utils 1.1.3-2
        An alternative implementation of Linux sound support
    local/alsaequal 0.6-16
        Real-time adjustable equalizer plugin for ALSA sound server
    local/alsaequal-mgr 2013.7.10-1
        Save and restore named alsaequal states.
    local/pulseaudio-alsa 2-3
        ALSA Configuration for PulseAudio
    local/zita-alsa-pcmi 0.2.0-3
        The successor of clalsadrv, provides easy access to ALSA PCM devices.
    

    I’ve added alsa-conf, as i wrote in first post, those two lines to fix the default sound card, only that i don’t tried any extra flags because i don’t find any documentation about the sound card (alc3223), seems a dell rebranded sound card.

  • Like 0

    Alsawiki say you need a .asoundrc with some like this:

    If you have more that one sound cards which use the same modules, you may want to define the card order. This can be done by specifying index and ID options to the module being loaded. For example

    options snd-usb-audio index=1,2 vid=0x0ccd,0x0d8c pid=0x0028,0x000c
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad as i wrote, i don’t have problems with default sound card, it is set fine, analog sound card as default. My problem appears with noise, like if digital sound was sended to analog speakers.

  • Like 0

    Yes caused by a conflict on having two Soundcards using the same module.?
    Or simple a problem with microphone-feedback?
    Do you play around already with alsamixer?
    Bild Text
    may it is only the mic. giving this noise?
    You can choose soundcard with [F6]

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad well, adding screenshots about alsamixers:
    pulse:
    alt text
    default: pch
    alt text
    options on alsamixer
    alt text

    alsaconf edited to fit order, same effect:

    [[email protected] ~]$ cat /etc/modprobe.d/alsa-conf.conf 
    options snd_hda_intel id=PCH,HDMI index=1,0
    

    and, no is a problem with mic, it works… i tested it. It’s only when playing any, that directly obtain that kind on “noise”, is like when you choose dialog output on analog speakers.

  • Like 0

    if you mute mic or disable boost of mic you still get this noise? and capture is also on full volume in you pictures or do you only get capture? and no mic inside alsa mixer?

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    @joekamprad

    • without micboost no effect
    • muted all mics (i don’t know why i have soo many) same

    changes on capture is no change, is last try, i always try after every update, and last one is try with all on max…
    And in pulseaudio choose, in alsamixer yes, i only have 1 capture, and 1 master.

sound29 headphones4 noise1 speakers4 Posts 13Views 204
Log in to reply