• Very bad Performance - Dirt Rally


    Hey guys,

    I’m new to Antergos, though I’ve used Kubuntu for quite some time, as well as Linux i general.
    Now I’ve decided to give Antergos a try. First on my Laptop, what was quite a good choice and now with my Gaming Machine. Sadly I had to experience a huge difference in gaming performance. Antergos doesn’t even give me half of the FPS I’ve had with Kubuntu. Can someone help?
    I’ve installed XF86-video-ati, mesa (almost everything, except demos) and running on Gnome with Wayland (testet with XOrg, didn’t helped as well).

    My setup:
    AMD FX6150
    AMD 7970 GHZ Edition
    8GB DDR3

    FPS in Kubuntu with integrated benchmark at lowest setting: ~65FPS
    FPS in Antergos with integrated benchmark at lowest setting: ~25FPS

    Hope you can help. Maybe I only forgot to install some driver or dependencies.

  • mesa-libgl is installed?

    Southern Islands HD7970 (R9 270, R9-280, R7 240, R7 250)
    

    XF86-video-ati should be right but may you want take a look here:
    https://wiki.archlinux.org/index.php/AMDGPU#Enable_amdgpu_for_Sea_Islands_or_Southern_Islands_cards

    [updates once a week] = [90% less problems]
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    help development: donate antergos

  • @joekamprad said in Very bad Performance - Dirt Rally:

    mesa-libgl is installed?

    Southern Islands HD7970 (R9 270, R9-280, R7 240, R7 250)
    

    XF86-video-ati should be right but may you want take a look here:
    https://wiki.archlinux.org/index.php/AMDGPU#Enable_amdgpu_for_Sea_Islands_or_Southern_Islands_cards

    Thank you very much, that doubled the performance!
    Still, this was not the complete solution, there was still something missing. As I found out here, there are more packages for Hardware acceleration. And libva-mesa wasn’t installed initially. Now I’m back on around 60FPS. Almost where I ended in Kubuntu. Enough for me.

performance9 gaming6 issue5 dirt rally1 Posts 3Views 818
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.