• Brother DCP-J132W not recognized as scanner

    Guys, I am having a problem: I cant get the scanner of my brother dcp-j132w to work. I have installled brscan4, sane, xsane, restarted, scaniage -L only gives me a “No scanners were identified.”.
    An attempt to add the printer via brsaneconfig4 -a name=MyScanner model=dcp-j132w ip=my.scanners.ip.address gives me “Invalid IP address or NODENAME”.
    I am out of ideas now. Can someone point me in the right direction?
    I had that device working as scanner on an older system that died some time ago, so I know the device works.

  • is avahi-daemon running?

    systemctl status avahi-daemon
  • @joekamprad
    The avahi-demon is loaded and running, yes.

  • A firewall can also cause the problem.

    You do all in the right way…
    -brscan4 should include the right driver for DCP-J132W

    So may the problem is network related?


    Printing is work over network?

  • No firewall here. On my older system (which died some time ago) the damned scanner simpy worked.
    I have checked the /etc/sane.d/net.conf file, everything is commented outthere and I have no idea where to enter the scanner’s ip adress there.

  • Wiki say only like this:

    # static IP address

    in /etc/sane.d/net.conf

  • @Jeannie____
    If you’re in a hurry, may i suggest a weird workaround?..
    Try to use it from a virtual machine with other OS, (Linux Mint or a different distro)… Set the network in bridge mode and try to use it from the VM…
    If you’re not in a hurry: then i have not enough knowledge to help you… hehehehe
    Good luck 👍

  • @ fernandomaroto:
    Uhm, I don’t have virtualbox installed and set up here and have no plans to do so.
    Setting my scanners ip in /etc/sane.d/net.conf has no effect, the scanner is still not being identified.

  • So, I removed sane, xsane, brscan4 and reinstalled them.
    Now the scanner is being recognized but I get an Invalid argument error.
    I ran brsaneconfig4 -d to track own the problem , this is the output:
    Any ideas?

  • shure it is the right ip of the printer/scanner ?

    For me looking unusual XXX.XXX.XXX.031 also because it is doing:

    ping -w 10

    PING ( 56(84) bytes of data.

    looks like changing to a wrong ip…

    ping -w 10                                                          1 ↵
    PING ( 56(84) bytes of data.

    is what it do here if i put 099 it changes to 99

  • @joekamprad is shown in my router’s web interface as well as on the device’s panel.
    So I guess it must be the correct ip address.
    I can ping the device as superuser. Runing scanimage -L as superuser also identifies the scanner.
    Maybe a permissions/group issue?

  • Interresting.
    Unfortunately my scanner is not connected via usb so I neither am able to find out the vendorID nor the productID.

  • yea i see … Aber … not seems to be a group permission problem… Wiki say that this is done by systemd now:
    After systemd, the scanner and lp groups are deprecated. No need to add your user to those groups.
    And Ping works as root only is something i never heart about … may problem is on side of the server aka scanner /printer

  • I can use scanner and printer via WiFi from another of my operating systems (also arch based) without problems, so the problem certainly is not on the side of the device, but on the side of the OS. Or maybe 40 cms away from the monitor.

  • Hi Jeannie,

    as pointed out from Joe, please add the scanner IP inside /etc/sane.d/net.conf ; just be sure to put it in a new line without the # in front. EX:

    #This is a comment
    #Another one

    As you can see, for the sake of testing, do not include the 0 on the last part of your ip (as opposite of what’s suggested by your router).

    I have a MFC-L8650CDW from Brother and to make it working successfully I first installed the linux printer driver from their website (http://support.brother.com/g/b/downloadtop.aspx?c=gb&lang=en&prod=mfcl8650cdw_eu_cn) by selecting IP address when asked for the device URI. Then I added my device IP to the sane configuration file mentioned above and restarted my antergos box. If the scanner was still not recognized, I did re-installed it manually using the brsaneconfig4 command.

    Please note that before being able to run the printer driver installer, you need the rpm package, which you can find on the AUR as rpm-org (yaourt rpm-org).

    My device IP is and I wouldn’t add the 0 before the 30 (

    Good luck!

  • So basically you’re saying that I need to setup the device as printer before I can set it up as scanner?

  • Hi,

    not really, but it would ease the setup: it will install some required packages and at the end, it will add the device as scanner as well.


brother21 recognized11 scanner6 dcp-j132w1 Posts 18Views 2517
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.