• AMDGPU Driver Talk


    this thread is for AMDGPU Pro and opensource driver questions and feedback.

    here is a link to the Arch wiki on AMDGPU
    https://wiki.archlinux.org/index.php/AMDGPU

    also some good reading at the The AMD/ATI Bar & Grill
    https://bbs.archlinux.org/viewtopic.php?id=57084&p=302

    alt text

    alt text

  • @megaman

    Hi,

    I’m using amdgpu on a HD7850 graphics.

                   `.-/::/-``
                .-/osssssssso/.               [email protected]
               :osyysssssssyyys+-             OS: Antergos  Minimal-ISO-Rolling
            `.+yyyysssssssssyyyyy+.           Kernel: x86_64 Linux 4.9.11-1-ARCH
           `/syyyyyssssssssssyyyyys-`         Uptime: 21m
          `/yhyyyyysss++ssosyyyyhhy/`         Packages: 988
         .ohhhyyyyso++/+oso+syy+shhhho.       Shell: bash 4.4.12
        .shhhhysoo++//+sss+++yyy+shhhhs.      Resolution: 1920x1080
       -yhhhhs+++++++ossso+++yyys+ohhddy:     DE: KDE5
      -yddhhyo+++++osyyss++++yyyyooyhdddy-    WM: KWin
     .yddddhso++osyyyyys+++++yyhhsoshddddy`   GTK Theme: Breeze [GTK2/3]
    `odddddhyosyhyyyyyy++++++yhhhyosddddddo   Icon Theme: breeze
    .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh.  Font: Ubuntu Italic
    ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy  CPU: AMD FX-8150 Eight-Core @ 4GHz
    dmmmdddddddhhhyso++++++shhhhhddddddmmmmh  GPU: AMD/ATI Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]
    -dmmmdddddddhhyso++++oshhhhdddddddmmmmd-  RAM: 1337MiB / 16033MiB
     .smmmmddddddddhhhhhhhhhdddddddddmmmms. 
       `+ydmmmdddddddddddddddddddmmmmdy/.     
          `.:+ooyyddddddddddddyyso+:.`
    [[email protected] ~]$ lsmod |grep amd
    edac_mce_amd           28672  0
    kvm_amd              2179072  0
    kvm                   524288  1 kvm_amd
    amdgpu               1499136  24
    i2c_algo_bit           16384  1 amdgpu
    drm_kms_helper        126976  1 amdgpu
    ttm                    86016  1 amdgpu
    drm                   294912  11 amdgpu,ttm,drm_kms_helper
    [[email protected] ~]$ 
    
    

    And fine…

    I hope the next installation image brings it by default, on a laptop (my daughter) I had to install archlinux on the “archway”.

    Regards

  • @Archrysler im also using the amdgpu open source drivers on a RX480 for a couple of months now and its been working smooth :+1:

    cant wait to see the progress they make with these drivers in the future. lots of work to do.

  • @megaman

    I also use them in an APU a10-7850k, tomorrow I’ll capture, the APU I’ve in the office.
    Work fine too.

    In the case of HD7850 I had to put the radeon module in blacklist (Arch wiki tip).

    Regards

  • My promise:

                   `.-/::/-``
                .-/osssssssso/.               [email protected]
               :osyysssssssyyys+-             OS: Antergos 
            `.+yyyysssssssssyyyyy+.           Kernel: x86_64 Linux 4.9.11-1-ARCH
           `/syyyyyssssssssssyyyyys-`         Uptime: 16m
          `/yhyyyyysss++ssosyyyyhhy/`         Packages: 991
         .ohhhyyyyso++/+oso+syy+shhhho.       Shell: bash 4.4.12
        .shhhhysoo++//+sss+++yyy+shhhhs.      Resolution: 1920x1080
       -yhhhhs+++++++ossso+++yyys+ohhddy:     DE: KDE5
      -yddhhyo+++++osyyss++++yyyyooyhdddy-    WM: KWin
     .yddddhso++osyyyyys+++++yyhhsoshddddy`   GTK Theme: Breeze [GTK2/3]
    `odddddhyosyhyyyyyy++++++yhhhyosddddddo   Icon Theme: breeze
    .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh.  Font: Ubuntu Medium Italic
    ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy  CPU: AMD A10-7850K Radeon R7, 12 Compute Cores 4C+8G @ 4GHz
    dmmmdddddddhhhyso++++++shhhhhddddddmmmmh  GPU: Gallium 0.4 on AMD KAVERI (DRM 3.8.0 / 4.9.11-1-ARCH, LLVM 3.9.1)
    -dmmmdddddddhhyso++++oshhhhdddddddmmmmd-  RAM: 1451MiB / 13981MiB
     .smmmmddddddddhhhhhhhhhdddddddddmmmms. 
       `+ydmmmdddddddddddddddddddmmmmdy/.     
          `.:+ooyyddddddddddddyyso+:.`
    [[email protected] ~]$ lsmod |grep amd
    edac_mce_amd           28672  0
    kvm_amd              2179072  0
    kvm                   524288  1 kvm_amd
    amdgpu               1499136  22
    i2c_algo_bit           16384  1 amdgpu
    drm_kms_helper        126976  1 amdgpu
    ttm                    86016  1 amdgpu
    drm                   294912  11 amdgpu,ttm,drm_kms_helper
    [[email protected] ~]$ 
    
    

    Regards

  • When i first installed Antergos i didn’t manage to install the AMD drivers, at some point i gave up. For now mesa drivers do the job, even with steam games.
    When someone make a good tutorial i can try to install AMD again…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto ya im not sure amdgpu drivers are really that amazing at this point. you probably not losing much sticking with mesa.

  • I’m wondering if this would potentially fix the wmv HWA issue in vlc. I talked with one of you in irc and was convinced that the install wasn’t worth the trouble…now I’m thinking otherwise. However, I would HATE to lose option TearFree in radeon since that’s been most excellent so far with my dual-monitor setup…it’s even better than running Compton from my experience so far. As far as gaming, I’m nothing more than a filthy casual playing the occasional zombie CS:S game:trollface:

  • @d_K i havent noticed any tearing myself with amdgpu. sounds like you are pretty happy with your current setup but cant hurt to try out the new drivers. also on that wmv error is it the same with other players like smplayer?

  • @megaman smplayer doesn’t have HW decoding selected by default but it does also produce breakage sporadically when selected on “auto” and “vdpau.” At first I was fooled because videos were playing fine (and with the lower cpu) on “auto,” but after playing several HD mp4s and coming back to the wmvs, the issue appeared. I believe “vaapi” doesn’t do anything as it doesn’t produce breakage but plays at the same cpu usage as “none.” Probably an openGL thing yet to be resolved in mesa. I also tried mpv but that’s such a simple player that (I don’t believe) supports HWA.

  • @d_K when you say HD are we talking 4K or 1080 videos? its been years since ive had video playback problems. between using smplayer and VLC always great playback. i typically use vdpau in smplayer. also in smplayer you can use either mplayer or mpv as the playback engine. so something you could play it. mpv looks simple but i think its a solid player.

    i do remember having some weird playback issues with WMV last year. to where i was using VLC as the default player for WMV and used smplayer for the rest.

    these days i use smplayer for everything and no issues. i do switch between mplayer and mpv as the engine just to play with things. both seem to do a good job.

    for more detailed support you could try the smplayer or vlc forums.

    0_1489167194534_2017-03-10--1489167143_632x197_scrot.png

  • @megaman 720p+. And to be clear, the issue only affects wmv files for me.

  • I use smplayer for some time, no issues, and i have mesa driver opengl installed (no AMD drivers so far)…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Um, I attempted this and may be regretting it…I seem to be running into a “jurassic park” boot with a blinking cursor that sits there forever. Can someone hop on IRC right now to help diagnose or undo the blacklisting of radeon??

  • Ok guys I seriously dodged a bullet there and was able to boot into non-graphical mode and revert the changes to radeon.conf and then uninstall amdgpu via pacman for good measure. I don’t have an explanation for what happened, apparently X failed to load – even with nomodeset – which was pretty worrying. The next thing I would have tried was possibly lowering the resolution to get vesa drivers to boot into the desktop, but I doubt even that would have worked. The non-graphical solution was perfect – and no sudo needed for reboot:smiley:

    There is 1 existing entry in /etc/modprobe.d/radeon.conf (which I indeed commented out while also blacklisting radeon before my problems):
    options radeon modeset=1
    Some people in the Arch IRC were confused about this line and why it even exists – I have no idea if this related to my non-booting situation or not, but I tried many combos of radeon.modeset=0, radeon.modeset=1,amdgpu.modeset:laughing:, etc – I don’t think it would have mattered if was uncommented or not. During my non-graphical session, I uncommented it just the way it was (while also removing blacklist radeon.)

    Thanks for @Namarrgon for some help on Arch IRC (yes I know we’re not supposed to ask for help there, but gosh it’s 3:30AM on a Monday!:sweat_smile:)

  • I know i’m noob, but what is the tool that shows the nice system info and terminal graphics?

  • @antergosfgm screenfetch

  • $ screenfetch
                   `.-/::/-``                
                .-/osssssssso/.               [email protected]
               :osyysssssssyyys+-             OS: Antergos 
            `.+yyyysssssssssyyyyy+.           Kernel: x86_64 Linux 4.9.21-1-lts
           `/syyyyyssssssssssyyyyys-`         Uptime: 28m
          `/yhyyyyysss++ssosyyyyhhy/`         Packages: 1025
         .ohhhyyyyso++/+oso+syy+shhhho.       Shell: bash
        .shhhhysoo++//+sss+++yyy+shhhhs.      Resolution: 1366x768
       -yhhhhs+++++++ossso+++yyys+ohhddy:     DE: GNOME 
      -yddhhyo+++++osyyss++++yyyyooyhdddy-    WM: GNOME Shell
     .yddddhso++osyyyyys+++++yyhhsoshddddy`   WM Theme: 
    `odddddhyosyhyyyyyy++++++yhhhyosddddddo   GTK Theme: Numix-Frost-Light [GTK2/3]
    .dmdddddhhhhhhhyyyo+++++shhhhhohddddmmh.  Icon Theme: Numix-Square
    ddmmdddddhhhhhhhso++++++yhhhhhhdddddmmdy  Font: Cantarell 11
    dmmmdddddddhhhyso++++++shhhhhddddddmmmmh  CPU: Intel Core i7-3517U @ 4x 3GHz [51.5°C]
    -dmmmdddddddhhyso++++oshhhhdddddddmmmmd-  GPU: Mesa DRI Intel(R) Ivybridge Mobile 
     .smmmmddddddddhhhhhhhhhdddddddddmmmms.   RAM: 1218MiB / 7855MiB
       `+ydmmmdddddddddddddddddddmmmmdy/.    
          `.:+ooyyddddddddddddyyso+:.`       
    
    
    $ lspci
    02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M] (rev ff)
    
    
    $ yaourt -Ss Radeon HD
    aur/catalyst 15.9-15 (338) (0,07)
        AMD/ATI Catalyst drivers for linux. fglrx kernel module only. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
    aur/catalyst-total 15.9-18 (130) (0,61)
        AMD/ATI Catalyst drivers for linux. catalyst-dkms + catalyst-utils + lib32-catalyst-utils + experimental powerXpress suppport. Radeons HD 2 3 4 
        xxx ARE NOT SUPPORTED
    aur/catalyst-total-pxp 15.5-1 (Out of Date) (21) (0,00)
        AMD/ATI drivers with powerXpress support. catalyst-hook + catalyst-utils + lib32-catalyst-utils. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
    aur/catalyst-utils 15.9-8 (60) (1,33)
        AMD/ATI drivers. Utilities and libraries. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
    
    

    Total = not supported…

    Mis respetos.-

  • I’m getting my first amd GPU soon (Rx 570). Would anyone be willing to answer a few questions for me?

    1. I removed all the nvidia packages. I assume that’s enough for cleaning up my previous hardware’s footprint? I don’t want there to be any conflicts.

    2. can someone explain the difference between using Mesa drivers and xf86-video-amdgpu? Some say I need xf86-video-amdgpu installed, and some say I don’t need xf86-video-amdgpu and am fine with just Mesa installed. A more detailed explanation would be most helpful.

    Thank you kindly!

  • Well the adventure for me continues. After spending more hours with some new hardware and the stupid 280, I figured out why X wouldn’t load – turns out having leftover driver config files (presumably for TearFree options) in /etc/X11/xorg.conf.d/ chokes X for some reason. For example, if you have a leftover 20-radeon.conf and want to load amdgpu (or if you have 20-amdgpu.conf and want to revert back to radeon) – X chokes and refuses to load. Nevermind “blacklisting radeon” as the wiki says, simply having these leftover config files in that directory will result in a failed boot – try it yourself! :confused:

    Now, amdgpu finally loads on my 280. Turns out HWA is gimped again, VLC is at 20% cpu under all HWA options. Even tried installing libva-vdpau-driver to no avail. (And yes, mesa-vdpau is installed.) I’m reverting back to mesa (again), not even bothering to test with Steam.

    I’ll probably complete my new build forgoing an NVMe drive and getting something like a discounted RX-470 instead.

driver36 amdgpu3 talk1 Posts 20Views 1231
Log in to reply