• XScreensaver and Caffeine? (Xscreensaver not being disabled)


    Hey Guys,

    As the subject states, I am running Arch with Caffeine and Xscreensaver. When I activate Caffeine, by clicking on the coffee mug icon, I get the prompt that says my screensaver is disabled. I am currently using Xscreensaver, for my screensaver purposes currently. However, it is still being activated even after caffeine has already been activated (screensaver still comes up).

    Does anyone know how I can get XScreensaver to play nice with Caffeine…and not come up when Caffeine is
    activated?

    Thanks.

  • @a4orce84 hi, i guess you can add some programs in “Preferences” and see if it works…

  • Which preferences? Not sure I understand…

  • @a4orce84 Do you have caffeine in your system tray? If so, right click it, go to preferences and add some program/service wich will always be running, that way caffeine should work…

  • alt text

    Screenshot above.

    The problem is, I don’t want Caffeine to always be enabled when Xscreensaver is run (sometimes I actually want it to use Xscreensaver and show it).

    I believe what you are saying is to add Xscreensaver so caffeine would never allow it to run (display the screensaver).

  • @a4orce84 Ah, you’re using gnome’s caffeine extension, i’m using the one from AUR wich is a different program (and i set for never use screensaver).
    I don’t know about the one you’re using, let’s wait for someone else to appear and help you…

  • @a4orce84 said in XScreensaver and Caffeine? (Xscreensaver not being disabled):

    Screenshot above.

    what gtk-theme is this what u are using ???

    My question is for what Xscreensaver is good for ? it does not save anything on today LCD/LED Display …

    And there is a fork of this app called caffeine-ng
    may this what @fernandomaroto is using?

  • The theme is the following:
    https://github.com/horst3180/arc-theme

    Glad you liked it! =)

    To answer your question, I guess it doesn’t really add any value. However, I like it and it’s a personal preference thing. I like having a screensaver vs. just a blank / locked screen to give a pop of color or just bit of animation to make it interesting.

    However this is on an XPS 13 laptop…not a desktop, or something that would be ‘on’ all the time and never going into standby.

  • aha: arc-theme is what i already using ;) but on your screenshot it looks darker then mine… may i play with display settings…

    And o.k. for using xscreensaver for putting some colour on your desktop !

    caffeine is made for disable screensaver, and if it doesn’t, it is naybe a bug?
    https://github.com/eonpatapon/gnome-shell-extension-caffeine/issues

    I find also this one: https://github.com/jenspfahl/KeepAwake

disabled5 xscreensaver4 caffeine1 Posts 9Views 1551
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.