• Gnome boots into black screen after Wayland package update


    Yesterday AUR updated the Wayland package and today Gnome boots into a black screen. I’m pretty sure the two are related. I thought maybe removing my nvidia drivers would help in case it’s an Nvidia compatibility thing, however I’m not sure I removed the drivers properly and the problem is not resolved. Also I tried booting an X11 session but that only results in an error. Any tips for a newbie?

  • can you get to erminal with [Strg + Alt + F2] after booting?
    then you can grant root access and install nvidia-installer:

    pacman -S nvidia-installer
    
    nvidia-installer -f
    

    This will install properitary nvidia drivers instead of nouveau.
    but only if it is a nvidia graphic card and not a hybrid notebook card intel/nvidia
    check with:

    lspci -k | grep -A 2 -E "(VGA|3D)"
    

    Make shure to start gnome-xorg Session after rebooting.

    It is also possible that your problem is not related to driver but on lightdm, so also changing DM to GDM may solve your blackscreen issue:

    pacman -S gdm
    systemctl -f  disable lightdm
    systemctl enable gdm
    reboot
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Gnome boots into black screen after Wayland package update:

    Make shure to start gnome-xorg Session after rebooting.

    How do I do this? I have Gnome setup to auto login so I can’t make that choice.

    I reinstalled the nvidia drivers successfully as you instructed. I’m on a desktop so no mobile graphics.

    By the way, when I press control + alt + f2 after booting, a terminal shows up for a few seconds but then the screen goes dark again. So I boot straight into terminal by editing the boot options with grub.

  • So you can boot up to Desktop? or still black screen?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Oh sorry didn’t make that clear, no reinstalling the drivers did not help, still a black screen.

  • And “I reinstalled the nvidia drivers successfully” means you already used the properitary nvidia drivers before?
    You can also modify the lightdm config manually in terminal output:

    nano /etc/lightdm/lightdm.conf
    

    search for autologin-user= and exclude this lines with a #

    But if lightdm does not show up the only solution i know working is install gdm and do what i discribed before for this:

    pacman -S gdm
    systemctl -f  disable lightdm
    systemctl enable gdm
    reboot
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Yes I was using the nvidia drivers but after the black screen issue I tried removing them to see if it helped. I was under the impression that nouveau drivers would take over after I removed to nvidia drivers so I was hoping that would solve the problem. I’ll try your other suggestions now.

  • @Vandaahl this nice nvidia-installer can do both installing nvidia and installing nouveau and it will do any changes that are need for this…

    nvidia-installer -n will restore nouveau (open) nvidia driver

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @joekamprad said in Gnome boots into black screen after Wayland package update:

    And “I reinstalled the nvidia drivers successfully” means you already used the properitary nvidia drivers before?
    You can also modify the lightdm config manually in terminal output:

    nano /etc/lightdm/lightdm.conf
    

    search for autologin-user= and exclude this lines with a #

    But if lightdm does not show up the only solution i know working is install gdm and do what i discribed before for this:

    pacman -S gdm
    systemctl -f  disable lightdm
    systemctl enable gdm
    reboot
    

    I tried both suggestions: after removing the autologin I was still getting a black screen, and after switching to gdm it now boots into a blinking cursor.

    I also tried nvidia-installer -n, which complains about this:

    All logs will be stored in /tmp/nvidia-installer.log
    Installing nouveau driver...
    Removing conflicting packages...
    Cannot remove conflicting package lib32-nvidia-utils: error: target not found: lib32-nvidia-utils
    
  • @Vandaahl do you modify xorg config files?

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • No I’ve never needed to edit xorg files so they should be untouched.

  • so we need to take a look to logfiles…

    first should be:

    systemctl status gdm
    

    problematic as you can not pastebin but if you are smart:

    pacman -S pastebinit
    
    cat /var/log/Xorg.1.log  | pastebinit
    

    will output you a url (autopost to pastebin.com 😉

    dmesg | pastebinit
    

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • Sorry about the long silence, I decided to give up on this installation for now. Thank you very much for your time and help.

gnome301 black61 wayland44 boots8 Posts 13Views 2707
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.