• Any tips on getting wifi "8192cu-dkms" working?


    The stock driver is buggy and dc’s often. I first installed linux-headers and then:

    yaourt -S 8192cu-dkms
    

    Rebooted, and now it’s not pulling in a dhcp address for some reason. Any hints?

  • lol wth, I tried doing this and it worked. Something is seriously is messed up with the latest kernel.

  • @d_K Exact same problem/ghetto “solution” for me.

  • it’s not pulling in a dhcp address

    I should probably clarify this…it’s not connecting to my network at all and no SSIDs are visible.

    I did a little bit of auditing…found this on a loop (x = arbritary number):

    NetworkManager[x]: <info>  [x] device ([device name]): supplicant interface state: inactive -> disabled
    NetworkManager[x]: <info>  [x] device ([device name]): supplicant interface state: disabled -> inactive
    NetworkManager[x]: <warn>  [x] device ([device name]): set-hw-addr: new MAC address [mac filter] not successfully set (scanning)
    kernel: IPv6: ADDRCONF(NETDEV_UP): [device name]: link is not ready
    

    Connecting to “hidden network” works for now. Disabling ipv6 at the grub2 level is something I always do (vpn leaks) but haven’t done this yet as I’m still customizing my install…I’ll report back later if anything changes.

  • I have a dumb question maybe, is the option to boot into the LTS kernel well-displayed in the grub menu? Even though I have it installed, I can’t seem to find a selection of kernels to boot into – only a “fallback” option that boots into 4.9. Is it supposed to be under “advanced” somewhere?

  • Okay I figured out how to boot into the LTS kernel – I installed “grub customizer” and that allowed me to select the LTS kernel as the “default selection” – it’s very strange because it’s not labeled anywhere on the grub menu itself. Anyway, turns out I have the same problems and doesn’t even connect on “connecting to hidden ssid.” I also disabled ipv6 and no change. I still think I messed up the grub file because using gksu with gedit gave me a bunch of permission errors. Other than that, I have no idea. Thankfully it’s still booting, lol.:grinning:

  • @d_K if i’m not mistaken the LTS option appears in something like "Advanced options for Antergos"
    I don’t believe messing the GRUB file would make your wifi not work (but i have not enough knowledge to help you on that)

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • I know that some users say that they can not connect with the standard tool but can watch and connect with one of the alternative wifi-tools… wifi-radar, wicd e.t.c.

    Do you have a:

    /etc/modprobe.d/blacklist-8192cu-dkms.conf ?

    cat /etc/modprobe.d/blacklist-8192cu-dkms.conf
    

    try to change what is inside to a simple:

    blacklist rtl8192cu

    If you are still using 8192cu-dkms

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I noticed that from the aur comments but the file did have:

    blacklist rtlwifi
    blacklist rtl8192c_common
    blacklist rtl8192cu
    blacklist rtl8xxxu
    

    So anyway I tried just doing “blacklist rtl8192cu” and now it’s using rtl8xxxu…the startup is fine but I’ll have to wait and see if this bundled driver is also buggy…btw what is the “preferred” way of editing root files? I’m so used to using gksu but using gksu with gedit in my installation produces glib and dconf errors in the terminal…although it seems to save ok, there are preferences that don’t work in gedit while in gksu mode. Should I just learn to use nano from now on?

  • It is not a good idea to use x-apps with root privilege… better is to use Terminal-apps like nano for edit this files.
    open a terminal and:

    sudo nano /etc/modprobe.d/blacklist-8192cu-dkms.conf
    

    Nano is easy to use for beginners … [Strg+X] to save file … for handling nano manual
    Simple https://www.howtogeek.com/howto/42980/the-beginners-guide-to-nano-the-linux-command-line-text-editor/

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad I was under the impression that that’s what gksu is for…maybe that’s just a debian thing and editing via terminal is cleaner?

  • I would say it is saver, without a graphical app in the middle…and cleaner also as you realy see what you are doing…
    Also you are faster… as you are inside the terminal you can check where you are, you can put commands e.t.c. {you can do what you want! play a video music… rise volume…install libs… doing updates…}

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • You know this rtl8xxxu driver is actually pretty decent…the only downside is that its tx power is capped at 20dBm. I could have sworn the dkms patch provided a higher power. 30dBm is allowed here but some of the hacks online to change the TX power has been disallowed by recent kernel updates. And yeah, I know getting a higher gain antenna is more cost-effective than simply upping the TX power. It’s just that right now (from what I’ve observed so far), rtl8xxxu is providing ~15-20% less signal strength than the dkms.

    Anyone have insight on this?

  • @fernandomaroto I have an update on the grub screen, apparently I can now see the additional LTS entries…I have no idea how or why, but after playing around with “grub customizer” and changing around some of the menus and then deleting them, the LTS entries have now appeared. My best guess is breakage via “gksu gedit” on the grub file (and subsequently doing a “update-grub”. ) I’m probably lucky that I didn’t unintentionally ruin the grub file entirely.

  • editing config files with gedit can caus a wrong wordwrap…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @d_K ok, that’s good, although i never used “grub customizer”
    @joekamprad even using gksu/gksudo/ksudo?
    When i was starting my linux experience, someone told me not to use sudo… Since then i usually open files on graphical interface with gksudo, i’l try to remember to open with nano next time.

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto not related on auth. mode… wordwrap is caused by editor… you can get this also with a terminal editor if it is badly configurated… i would allways use su to login as root and use nano or vim so you have full control and safety on filechanges…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • @joekamprad there’s an additional complication within gedit when saving a file: line endings. Unix is selected by default (which is good) but migrating old windows config files with the embedded windows carriage return characters can choke some terminal emulators. I had a vpn provider once that served me automated .ovpn config files…the problem was they contained the windows line endings by default and either the xfce terminal emulator or openvpn itself apparently couldn’t handle the windows-style carriage returns and failed with an obfuscated error. Thankfully the solution in that case was simply selecting the Unix line ending when saving the config file.

8192cu-dkms1 wifi79 tips4 Posts 18Views 1003
Log in to reply