• Running Gnome with Wayland

    Hello, I’m running Antergos on a Macbook pro with Gnome (latest version, fresh install). When I choose the Wayland session (labelled gnome) in Lightdm (after having installed Xwayland), it doesn’t work, I get a black screen with a blinking cursor.
    I’ve tried to use gdm, it freezes when I try to launch the Wayland session.

    How could I use Gnome with Wayland ?

  • @usaginomimiu Don’t know if you are still struggling with this. But I had the same issue on a MBP (mid 2010) and the first thing to do is to use gdm instead of lightdm but then I also had to remove xf86-intel-video. After that Wayland worked.

  • hi, on my machine (AMD APU A10 7850k - graphics driver: xf86-video-ati) i had first to install and activate gdm.
    after that i follow the instructions from the arch wiki - chapter: Enable early KMS:
    after adding the radeon module to MODULES, wayland worked for me.
    maybe it helps

gnome361 lightdm137 wayland51 macbook pro10 Posts 3Views 1661
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.