• Can't get into antergos live install environment (x.org fatal error)


    Hey guys,
    I’m pretty new to arch linux distributions and since I ran into some serious installation problems and couldn’t find any solutions in the internet, I figured it would be cool to ask the community.

    So what I want to do is dual-boot antergos with windows 10. I installed windows 10 first and everything worked fine. Then I booted from the antergos live iso usb-stick and chose the “start antergos live” option from the menu. Then I got this screen:

    Screen 1

    and shortly after this screen I got a “black screen of death” with a blinking cursor in the top left corner, but I couldn’t type anything or use any kind of command.

    Then I read in a different forum that some people have issues with newer GPUs from nVidia and since I have a GTX 1060 I thought it might be good to use their advice and instead of the full live iso use the minimal iso.

    When using the minimal iso, I got the same screen as above but I also got this error:

    Screen 2

    After the error appeared, nothing worked as was the case with the live iso. I would love to give you more logs but I don’t know if or where they are saved on the stick and I also wouldn’t know how to access them since I cant put in commands after the error message appears.

    I would be glad if you guys had some ideas what to do next :)

    Ah and here are my system’s specs just in case:
    CPU: Intel i7 860 @2.80 GHz
    RAM: 8 GB
    GPU: nVidia GTX 1060

    Thanks in advance ;)

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • also if you can not start graphical environment you still an get to terminal input:
    pressing [Strg+Alt+F2] here you can access info by typing:

    dmesg | grep nouveau
    

    You can still try to put nouveau.modeset=0 before booting to the kernel parameters on bootup… together with exact your screens resolution, it may help to get to installer.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • as i can see here: https://groups.google.com/forum/#!topic/linux.kernel/Ovx-VxOEHgU
    It is possible to get a screen with vga resolution… so may better to do not choose a resolution and let the system choose…
    AND MAY TRY A DIFFERENT USB-PORT…+ CLEAN THE USB DRIVE AND PUT ANTERGOS ISO AGAIN…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Hey! Thank you for helping me out!

    Unfortunately, I’m still not able to get into the live environment. This is what I have done so far:

    I tried to install Antergos with both live iso and minimal iso on USB and DVD and also tried different USB slots. Nothing changed.

    I also put the following commands in the boot line in different combinations, but the same as before happened:

    modprobe.blacklist=nouveau
    nouveau.modeset=0
    nomodeset
    systemd.unit=multi-user.target
    modprobe.blacklist=nvidia-current

    I read these commands in a different forum, where people with nvidia cards experienced similar problems (mostly GTX970 users).

    Also when the error message appears and I do [Ctrl + Alt+F2] the system wants me to log into “ant-17” and I don’t know which username/password to put in :D
    However I was lucky: one time I tried to install antergos and when the error message appeared I randomly spammed [Ctrl+C] on my keyboard and got to an actual command line so I was able to navigate to the log file. Unfortunately I didn’t know how to save it on a different drive so I had to take snapshots with my phone again. Here is the error log file:

    Screen 1

    Screen 2

    Screen 3

    Any further ideas? :)

    EDIT: I found out I can just type “root” to login to ant-17 :D I took a picture from the grep output as well:

    Screen 4

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • problem is there is no alternative driver for nouveau, so the only command can help is nouveau.modeset=0
    blacklisting nouveau result in the situation that no working driver is existent…

    For now i ot no more idea… there is a problem with actual installer on this new nvidia cards and nouveau, and properitery nvidia drivers are not includet in the installmedia…

    May anyone else have an idea?

    I would wait for next updated installer…
    Or you try to use the one before: antergos-minimal-17.1-x86_64.iso

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Thank you for your fast reply :)

    I actually got the installation to work with an old iso, but not the simple 17.1 but a forked version of this iso where the nouveau drivers are replaced with proprietary nvidia drivers. If anyone else has the same issue, the iso can be found here or on Github.

    It seems that it is also important to put “nomodeset” in the boot options before starting the live environment.

    Also when I first booted the live iso, I couldn’t run Cnchi from the shortcut. I had to open a terminal and start Cnchi there and then it worked. Installation is at 95% now so I hope everything works :D.

    Thanks again for the help @joekamprad :)

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • Okay so I will mark this thread as solved since it worked with the above mentioned iso. For any noobs like me reading this in the future: after installing antergos (as mentioned in the post before) you have to boot in non-graphical mode and uninstall nouveau drivers and replace them with proprietary nvidia drivers (otherwise you’ll get a blinking cursor in the top left corner).

    To do so, in GRUB menu highlight your favoured antergos entry (do NOT press enter just navigate to it so it’s highlighted) and then press “e”. Then a terminal-like screen will come up. If you scroll down a bit, you will see a line starting with “linux” and then there are some weird parameters behind it. At the end of this line, just put the following parameter: systemd.unit=multi-user.target

    After you did this, press [Ctrl+X], which will boot antergos in non-graphical mode (note: this is just for this single session and not permanent).

    Now you are in non-graphical mode and you can run the following commands:

    pacman -Syy nvidia nvidia-utils nvidia-libgl
    # It will ask you if you want to handle a conflict..you should choose  "Yes"
    systemctl isolate emergency.target
    modprobe -r nouveau
    pacman -Rccn xf86-video-nouveau
    modprobe -a nvidia
    depmod -a
    systemctl isolate graphical.target
    

    After you did this, just type “reboot” and your antergos system should work then. I already set up my system and I have to say up to now I really like the bleeding edge :). Works like a charm!

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • @Meister-Lampe , well done & welcome to Antergos.
    Would you wind posting that in our wiki. It would be such useful information for quite a lot of users.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch thanks xD But I couldn’t have done it without the help of the awesome antergos community! Antergos is really awesome and even easier to use than I thought coming from Ubuntu :)

    Oh of course I would be glad to do a Wiki post! But as I said I’m quite a newbie so is there anything I have to look out for like special rules for wiki article quality, guidelines and stuff like this? I’ve never done this before :)

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • Nice too see such a clever new user ;)
    All the user with nVidia GTX 10XX should follow this to install for now!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad thank you :) I wouldn’t even have come up with the graphics driver issue if it wasn’t for you! So thanks again!

    Yes I think it should work for others running newer nvidia cards too. It really works well, even played some games on steam and everything works fine!

    However, I wonder if the proprietary nvidia drivers will be included in a future live iso…? This would be much easier than the workaround xD

    @anarch concerning the wiki article: I get this error message after logging in at the wiki page: “There was a problem with your log in This account does not have an email associated, as required by your site administrator.” Although I have an email associated and I clicked on the registration link…weird :/

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • Did you register using your email address in the USER field?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hm no I don’t think so. In the registration form I put my E-Mail Address first, then username, then password just as the form says… :/

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • Okay so this is really weird xD : I have created a Github account (wanted to do that for ages anyway) and tried to log in with that one here on antergos. Turns out I can login to the wiki but this time not in the forum :D . When I try to log in at the forum I get a auth0/callback error but whatever.

    So I’ll write the wiki article with the Github-connected account. The username is “MasterLampe” and I used the same profile picture :). I’m going to write the article this evening when I’m finished with stuff I have to do for university. :+1:

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • @lots-0-logs , could you please look into the above described issue with registering/login issue?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • okay now this gets really strange: I posted the wiki article with my github-connected account and under it it shows my profile picture but instead of showing my user name, it shows the private e-mail-adress I put at github. Would really appreciate it if my mail-adress could be removed there by an admin.

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • @lots-0-logs @karasu If anyone of you sees this, it would be really cool if that was fixed since anyone reading my wiki post can now see my private mail address and I can’t even delete the post.

    Thanks in advance!

    EDIT: I can’t post the link here because it gets flagged as Spam… it’s the first article in the "installation section in the wiki, the one about installing antergos with newer nvidia gpu

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • @Meister-Lampe said i

    EDIT: I can’t post the link here because it gets flagged as Spam… it’s the first article in the "installation section in the wiki, the one about installing antergos with newer nvidia gpu

    @developers , that s the article in question

    https://antergos.com/wiki/install/installing-antergos-with-a-newer-nvidia-gpu/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thanks guys! It has been fixed :) I hope the wiki post is okay like this and will help people like me with nvidia cards install this great distro! It really works great!

    Proud Antergos-newbie!
    Specs: intel core i7 860 @ 2.80GHz|| 8 GB RAM||MSI GeForce GTX 1060 Gaming X 6G TwinFrozr VI

  • Is this your google drive? caus if yes, will get problematic for huge amount of downloads ;) I can do correct the german translation later… or do you want?

    Sie sollten diesen Artikel lesen, wenn Sie:
    1. Der Versuch, Antergos auf einer Maschine mit einer neueren nvidia GPU (vor allem GTX 10XX Generation zu installieren, könnte auch mit GTX 9XX Generation Karten Menschen mit Problemen zu helfen)

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

installation175 x.org1 Posts 20Views 1062
Log in to reply