• GTK3 applications use much too small fonts under Plasma5


    I have a problem, all GTK3 applications I use under Plasma 5 use mucht oo small fonts…
    The fonts are approx 50% smaller than the ones in QT5 or GTK2 applications.
    I didn’t worry about that until now, but teh latest thunderbird update applied that problem to my mail client too, so i’s require mgnifying glasses to be able to use Tunderbird now.
    See this example of Palemoon (GTK2) vs Firefox (GTK3) to compare the font sizes:
    alt text
    Any ideas how to get the fonts in GTK3 applications bigger?
    I tried to simply increass the font size in Thunderbird, but that had absolutely no effect on the tinyness.
    J.

  • Never encountered a similar problem, so just guessing - does the system use the same Gtk theme for both Gtk2 and Gtk3 apps?

    0_1487741076248_plasma-gtk-themes.png

  • I checked, both, GTK2 and GTK3 use the same theme, Dark-Breeze.
    It seems the font sizes for GTK3 applications are not controlled by the theme though, I can’t even set it in the firefox appearance setings, changing the font size there does nothing. I even had it set to 72 pt, still it woud not change the much too tiny font size.
    Obviously I haven’t escaped the GTK3 hell yet, not even under Plasma5
    J.

  • Issue solved: I had to change the font size for GTK3 manually in ~/.config/GTK-3.0/settings.ini
    J.

  • Hmm. That’s good, though strange.

    There should be no need to change the file by hand. Its content is changed automagically according to the changes made in System Settings --> Application Style --> GNOME Application Style (GTK) --> Font: (the picture above).

    The changes made here are automagically applied to 2 files:

    • ~/.gtkrc-2
    • ~/.config/gtk-3.0/settings.ini

    Verified it right now, and it works as described.

  • Before I edited the settings.ini ( aren’t *.ini files a windows thing?) , I changed the font size in System Settings --> Application Style --> GNOME Application Style (GTK) --> Font too.
    The changes were applied immediately to GTK2 applications, they had no effect on GTK3 appliations though on my system. Maybe it had no effect on GTK3 applications because I did not log out and back in.
    Seems Roy’s advice from the IT Crowd still is a good advice: "Have you tried turning it off and on again?"
    J.

  • Strangely enough, Thunderbird and Firefox came up in a too smal font again after some reboots.
    I had to instal add-ons in both to scale the whole UI up.
    /me shakes her head about GTK3
    J.

  • Did you check that changing the font in System Settings --> Application Style --> GNOME Application Style (GTK) --> Font: sets it - the same font, of the same size - in both files:

    • ~/.gtkrc-2
    • ~/.config/gtk-3.0/settings.ini

    For example, if Liberation Sans Narrow 18 in System Settings is set as the font for Gtk apps, two files are modified accordingly and contain the same setting:

    • ~/.gtkrc-2

      ...
      style "user-font"
      {
      	font_name="Liberation Sans Narrow Regular"
      }
      widget_class "*" style "user-font"
      gtk-font-name="Liberation Sans Narrow Regular 18"
      ...
      
    • ~/.config/gtk-3.0/settings.ini

      [Settings]
      gtk-font-name=Liberation Sans Narrow Regular 18
      ...
      

    Does it work for you the same way?

  • No, strangely enough, the settings made in the GTK 3 settings.ini have no effect on the font sizes used in Thunderbird or Firefox. The only way to get their ui font sizes right is to use an add on.

applications17 gtk37 fonts8 plasma510 Posts 9Views 627
Log in to reply