• No internet since the last Update.

    Hi, since yesterday I cant connect to my network via Wifi (didnt try wired), this started to happen since the last update which was yesterday(if Im not wrong). I tried many commands trying to reset or turn off but nothing works.

    Tried “ifconfig”, and says that the bash doesnt recognize it; same happened with “rfkill list”(to check if the kernel blocked my card), it doesnt recognize this commands.

    But, I could check the registry with “dmesg -w” and there is a problem pointed out in the Arch wiki "deauthenticating from MAC by local choice (reason=3) " I typed the command which might fix it, but it doesnt do anything.

    Any way to troubleshoot in Arch or use a Restore Point so I can try to fix this? or any way to reset the whole Network settings and Restart it again in a kinda clean state?

    Thanks for your time.

    Edit: More Info, also wanted to add the fact that I used sudo since in antergos you almost need to use it always to make a change or know something.

    Tried to use “iw dev wlp9s0 link” while Im not connected to any network and shows, Not connected of course, then I try to connect to an available network and this command works since it shows the info, but cant connect to the network after trying for around 30secs.

    I tried to use “ip link set wlp9s0 up” and shows me "RTNETLINK answers: operation not permitted."

    Tried to check if the interface is up but I end getting:

    3: wlp9s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
        link/ether 12:34:56:78:9a:bc brd ff:ff:ff:ff:ff:ff

    It seems that the No-Carrier parameter its ok, since I cant connect to any available network, but just wasnted to add more info just in case.

  • @reib maybe your problem is similar to this?
    Did you try to boot with LTS Kernel?

  • @fernandomaroto I found this steps to do that:

    1)(optional) check if kernel, ramdisk and fallback are available in ls -lsha /boot
    2)remove the standard kernel pacman -R linux
    3)update the grub config grub-mkconfig -o /boot/grub/grub.cfg

    Are this steps the right way to do it? Sorry Im kinda new to linux.

  • @reib Just popped up a new kernel update here, you can try to update using livecd.
    Well i thought you had LTS kernell installed already, if you have you just need to select it on GRUB while booting.
    If you don’t have installed you can type sudo pacman -S linux-lts and you don’t need to unisntall the “standard” kernel…

    Ok, first of all:
    boot the livecd
    if you know which partition you have Antergos installed jump to step 2

    1. open a normal terminal and type sudo fdisk -l look which partition you have antergos (for example, sda3)
    2. sudo mkdir /mnt/linux
    3. sudo mount -t ext4 /dev/sdaX /mnt/linux
    • sdaX put the number of your partition in the X above
    1. sudo arch-chroot /mnt/linux
    2. type sudo pacman -Syyuu and sudo pacman -S linux-lts

    Reboot your pc and boot normally to see if the update fixed your issue, if not, reboot and select linux LTS at GRUB menu.

  • @fernandomaroto the boot with LTS Kernel solves my issue, what might be wrong with the main boot?
    I have anohter question, if I make updated while booting with LTS Kernel, all updates keeps being saved too as the normal boot?

    Thanks for your time.

  • @reib I don’t know why these updates crashes something from time to time, but happens… Maybe the next update fixes the issue.
    Yes, all packages/programs will be updated. You will be using the LTS kernel, but all the rest remain the same.

  • @fernandomaroto All right, thanks!

  • @reib You’re welcome; don’t forget to mark the thread as solved then 👍

update57 internet31 Posts 8Views 1391
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.