• Incorrect installation path for feedreader 2.0.1-1


    feedreader 2.0.1-1 is installed to /pkg/pkg/feedreader/usr/bin instead of to /usr/bin making the application un-runnable, this needs to be corrected.

  • Just tried to install it and I can confirm the problem.

  • I confirm the error too. Feedreader 2.0.1 is installed from [antergos] repo with wrong paths and is unusable.

    The package with the same name exists also in the AUR - feedreader 2.0. This one, if installed, works correctly. It is installed into /bin, /lib64, /usr/share folders.

    Pamac gets confused because of identical package names in AUR and [antergos]. It proposes to upgrade AUR-feedreader with [antergos]-feedreader. If upgrade is accepted, it immediately breaks AUR-feedreader. Feedreader stops working.

    Personally, I prefer to use Ice-SSB, a site specific browser, to get a standalone web applications in any DE. Any web site | page may be transformed in a regular application - like Distrowatch, Antergos Home, Antergos Forum, Inoreader, Feedly, everything. They are much faster and more reliable than feedreader.

  • Antergos devs have noticed this topic, and have promptly fixed the issue. Feedreader package from [antergos] repo is installed in correct folders and works as it should now.

    ┌──[just]@[alexasc]:~$
    └─> pacman -Qi feedreader
    Name            : feedreader
    Version         : 2.0.1-2
    Description     : A simple feedreader desktop client for web services like Tiny
                      Tiny RSS.
    Architecture    : x86_64
    URL             : https://github.com/jangernert/FeedReader
    Licenses        : GPL3
    Groups          : rss
    Provides        : None
    Depends On      : sqlite3  libnotify  html2text  libsoup  gnome-online-accounts
                      libgee  libpeas
    Optional Deps   : None
    Required By     : None
    Optional For    : None
    Conflicts With  : None
    Replaces        : None
    Installed Size  : 4.16 MiB
    Packager        : Antergos Build Server <[email protected]>
    Build Date      : Wed 22 Feb 2017 22:38:46 MSK
    Install Date    : Thu 23 Feb 2017 09:25:38 MSK
    Install Reason  : Explicitly installed
    Install Script  : No
    Validated By    : Signature
    
    ┌──[just]@[alexasc]:~$
    └─>
    

    Well done. Thanks.

  • Almost, seems to have some conflict issues requiring force to override.

    [[email protected] ~]$ sudo pacman -S feedreader
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) feedreader-2.0.1-2
    
    Total Installed Size:  4.16 MiB
    
    :: Proceed with installation? [Y/n] y
    (1/1) checking keys in keyring                                     [####################################] 100%
    (1/1) checking package integrity                                   [####################################] 100%
    (1/1) loading package files                                        [####################################] 100%
    (1/1) checking for file conflicts                                  [####################################] 100%
    error: failed to commit transaction (conflicting files)
    feedreader: /usr/lib64 exists in filesystem
    feedreader: /usr/share/glib-2.0/schemas/gschemas.compiled exists in filesystem
    feedreader: /usr/share/icons/hicolor/icon-theme.cache exists in filesystem
    Errors occurred, no packages were upgraded.
    
    
  • Most probably it’s a conflict with residues from previous unsuccessful attempts to install the package.

    Solution:

    sudo pacman -S feedreader --force
    

    It will overwrite already existing unneeded feedreader files.

  • I mentioned that it was conflicting, the fliepath /usr/lib64 should not come up as a conflict. It would not surprise me a force install broke something. I ended installing it from a git package instead.

path3 feedreader1 package fail2 installing51 Posts 8Views 424
Log in to reply