• Cannot change language even after uncommenting


    Hi!
    I want to switch my system’s language but in Settings/Regions and Language there are no other options apart from the current one.
    I uncommented the language I need from locale-gen but it didn’t help.
    Please help me change the language.
    Thank you!

    PS Antergos is so well thought in other regards so such a petulant bug was a shock for me

  • @osomfinch said in Cannot change language even after uncommenting:


    I uncommented the language I need from locale-gen but it didn’t help.

    It’s not enough just to uncomment a locale(s) in /etc/locale.gen. Locales must also be re-generated to have an effect:

    sudo locale-gen
    

    The above command may be executed at any time. It is harmless.

    Once locales have been re-generated, could you share the full output of the command:

    locale -a
    
  • @just
    Thank you a lot! That worked! Putting SOLVED mark.

    The output of the command locale -a is:
    C
    en_GB.utf8
    en_US.utf8
    POSIX
    uk_UA.utf8

  • Very good.

    Just a note. Changing a topic’s Subject by adding [Solved] to it is not a good practice, as it breaks the thread in various email clients and feed readers. It is done this way:

    0_1487673682900_antergos-forum-mark-as-solved-01.png

    0_1487673701732_antergos-forum-mark-as-solved-02.png

  • @just Thank you. Will do that in the future.

language26 locale7 uncommenting2 Posts 5Views 876
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.