• Touchpad in GNOME


    Hello

    I installed Antergos with GNOME and do not have the touchpad settings.

    I installed “libinput” and ran sudo libinput-list-devices

    That’s what I got:

    //Device:           ETPS/2 Elantech Touchpad
    Kernel:           /dev/input/event11
    Group:            7
    Seat:             seat0, default
    Size:             101.88x66.22mm
    Capabilities:     pointer 
    Tap-to-click:     disabled
    Tap-and-drag:     enabled
    Tap drag lock:    disabled
    Left-handed:      disabled
    Nat.scrolling:    disabled
    Middle emulation: disabled
    Calibration:      n/a
    Scroll methods:   *two-finger edge 
    Click methods:    *button-areas clickfinger 
    Disable-w-typing: enabled
    Accel profiles:   none
    Rotation:         n/a
    

    I cant disable the touchpad while typing and manage right clicks and two finger scrolling…

  • I booted with LTS Kernel but that didn’t change anything.

  • you can try this shell extension: Touchpad Indicator
    And read/think/understand here https://wiki.archlinux.org/index.php/Laptop#Touchpad

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Thank you.

    And read/think/understand here https://wiki.archlinux.org/index.php/Laptop#Touchpad

    That’s what I have to do. I just would love to have it in the GNOME settings as before in Fedora by default.
    The indicator doesn’t seem to fix my problem as I still have no settings in GNOME.

  • @amilopowers I had the same problem and I found this solution:

    • Install all libinput packages (libinput5, libinput10, xserver-xorg-input- libinput)
    • Remove the synaptics driver → xserver-xorg-input-synpatics
    • Remove all synaptics related files in /etc/X11/xorg.conf.d/ (Like 50-synaptics.conf)
    • Reboot

    see: http://unix.stackexchange.com/questions/292350/debian-gnome-touchpad-settings-missing-use-libinput-instead-of-synaptics

  • I find this at Archwiki, may a less “radical” solution:
    https://wiki.archlinux.org/index.php/Libinput#Touchpad_not_working_in_GNOME

    But it seems that Wayland works better with libinput

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Weird enough but when I booted today the settings where there.

    @Gerhard

    • Install all libinput packages (libinput5, libinput10, xserver-xorg-input- libinput)
    • Remove the synaptics driver → xserver-xorg-input-synpatics
    • Remove all synaptics related files in /etc/X11/xorg.conf.d/ (Like 50-synaptics.conf)
    • Reboot
      That’s what I basically did without knowledge of the process unless the second step. I now deleted all the remaining files and hope that I stays like that.

    Thanks to everyone for the help!

gnome220 touchpad31 Posts 7Views 891
Log in to reply