• ZFS Option Greyed Out During Installation


    I booted up from a Live ISO USB, connected to the internet, and updated/started cnchi. Everything was going smoothly until I got to the Installation Type menu, where the ZFS option was greyed out. My two NVME drives with PCI adapters are recognized, if I try to manually edit the partition table. So I don’t think it’s an issue with the drives.

    Is my Live ISO missing packages? Or is there another method to install ZFS other than with the Live ISO? I haven’t been able to find any instructions or instructional videos, so any help would be greatly appreciated.

    Screenshot of Cnchi: http://imgur.com/TCJrUi7
    Here is a copy of my logs: http://pastebin.com/Jsz6G4VU
    Hardware list: https://pcpartpicker.com/user/LinuxHTPC/saved/9GrD3C

    Version: Antergos Live ISO: antergos-17.2-x86_64.iso
    Cnchi version: 0.14.240

  • @guttermonk That is one hell of a machine! Seeing the same thing here with ZFS and with totally different hardware - and old Core2 box. Might have to download and earlier or later version of the installer.

    Edit: OK, I tried predefining the zfs zvol, and restarted the installer - still grayed out.
    Tried the minimal install too - same result.

    Edit#2. So for some reason restarting the installation after using the first attempt to setup zfs zvol shows the zfs option as available. Something is either flaky, or misunderstood in the installation procedure.

    Edit #3: Nope, its gone again - cnchi crashed, and when I restarted it was greyed out again. Gees!

    Edit #:4 It seems that as soon as cnchi is updated, the zfs option is greyed out…looks like a bug to me.

  • Hi all,

    It’s not a bug but a temporary removal, because we wanted to fix zfs installation. If you install spl and zfs modules sometimes dkms hooks are run in incorrect order, so dkms tries to build/install zfs BEFORE spl. That means that zfs building fails and if you reboot… puf! no zfs and no root system.

    I think we managed to write a workaround that instructs dkms to first build spl and then build zfs… so it should work now.

    We disabled the option meanwhile we were modifying Cnchi, to stop bug reports about zfs… and people pissed off because their system didn’t boot after installation when using zfs.

    We need to do some more tests before activating that option, sorry.

  • @karasu is there somewhere that I can follow the revisions, or is there an email list that I can sign up for to get version updates? I really appreciate your work on this. After using Ubuntu for the last 4 years, I’m excited to switch to a Antergos.

  • @karasu Thanks karasu - I filed a bug so I’ll see what I can do to take it out of existence.

  • @kostas.mitropoulos Could you provide a link to that issue on here? I couldn’t find the issue on the forum or the github repo for antergos-packages or Cnchi. I am looking forward to a distro that is good for end users and has ZFS on root filesystem during install.

  • FYI for anyone still looking to get ZFS going, option is still disabled in the new antergos-17.3-x86_64.iso

    How can I volunteer to test the new fix? Or are there instructions to install w/ZFS from terminal? Any help is greatly appreciated.

  • @guttermonk said in ZFS Option Greyed Out During Installation:

    FYI for anyone still looking to get ZFS going, option is still disabled in the new antergos-17.3-x86_64.iso

    @guttermonk said in ZFS Option Greyed Out During Installation:

    FYI for anyone still looking to get ZFS going, option is still disabled in the new antergos-17.3-x86_64.iso

    I 'd like to know if u people gave up with ZFS installation …

  • @guttermonk

    NICE question !

    are there instructions to install w/ZFS from terminal?

  • Hi,

    In Cnchi 0.14.254+ the zfs option is enabled again. Tell us if any of you are using a newer version and the option is not showing, please.

    Or are there instructions to install w/ZFS from terminal? Any help is greatly appreciated.

    The best you will find is this: https://wiki.archlinux.org/index.php/Installing_Arch_Linux_on_ZFS

    But be warned, it’s not an easy task (at least it wasn’t for me the first time :laughing: )

    Cheers!

  • When I install with two NVMe drives and four SSD drives, the ZFS installer works great. It creates one pool with three mirrors.

    When I install with just two NVMe drives, I get the following error:
    Imgur

    Ideally, in order to take advantage of the read/write speeds of the NVMe drives, I would like the OS to be on the mirrored NVMe drives and the SSDs to be on a separate mirrored pool.

  • Hi,

    That’s a bug for sure. I think it should try to zap /dev/nvme1 and not /dev/nvme1n1, am I right?

    Please, could you fill a bug (issue) in https://github.com/Antergos/Cnchi?

    Thanks!

  • @karasu I’m not sure. When I install with two NVMe drives and four SSD drives and I get one pool with three mirrors, the NVMe drives are mounted as follows:
    /dev/nvme0n1
    /dev/nvme1n1

    And “zpool status” gives me:

    $ zpool status
    pool: pool1
    state: ONLINE
    scan: none requested
    config:

    NAME                              STATE     READ WRITE CKSUM
    pool1                             ONLINE       0     0     0
      mirror-0                        ONLINE       0     0     0
        wwn-0x500a0751157e9608-part3  ONLINE       0     0     0
        wwn-0x500a0751157e8ee3        ONLINE       0     0     0
      mirror-1                        ONLINE       0     0     0
        wwn-0x500a075115b9e7bb        ONLINE       0     0     0
        wwn-0x500a075115b9d457        ONLINE       0     0     0
      mirror-2                        ONLINE       0     0     0
        nvme-eui.0025385c615012b8     ONLINE       0     0     0
        nvme0n1                       ONLINE       0     0     0
    

    errors: No known data errors

during12 installation175 zfs23 greyed1 Posts 14Views 1027
Log in to reply