• Trying to install Django but cant even install PIP.


    Hi, Im trying to setup Antergos just to work on web development. Im gonna work with Django but I cant even make pip works which is a basic step to do in the installation.

    According to the wiki of pip on github pip info, It says that its already there since I have Python 3.6; but for some reason it doesnt, cant even install it using: “pacman -S python3-pip” or “pacman -S python (which works but is updated already)” which are the command I saw on few posts. PIP doesnt come with antergos by default it seems, it comes with Python3.6 but not PIP as says in the github page of PIP.

    Tried to look on the usr/bin and usr/local/bin folders but unable to find the files related to pip.

    Edit: someone solved my problem in another place, you need to install this package python-pip. Its was weird since in the pip github page said it came with python already.

    ReiB

  • python-django ? https://www.archlinux.org/packages/extra/any/python-django/

    yaourt -S python-django
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad Someone solved my problem few minutes ago, now pip works. But Im concerned since Im kinda new to Arch actually and so Antergos, your command installs Django and all dependencies too at the same time? Im wondering for future reference or in case following the steps from Django webpage doesnt work at the end.

    Edit: bad typo.

    ReiB

  • Pacman as the packagemanager (yaourt is using also) is handling this caused by what the maintainer of the package providing inside PKGBUILD

    Here you can see all Packages by a search for “django” https://www.archlinux.org/packages/?sort=&q=django&maintainer=&flagged= on details of each package you can see dependencies:

    https://www.archlinux.org/packages/extra/any/python-django/

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

pip2 django1 python32 Posts 4Views 421
Log in to reply