• Like 0

    Is volume control (PulseAudio Plugin) on XFCE use that much cpu?


    excuse me, I was using XFCE for 3 days until now. Today my laptop suddenly getting hot, the volume control eat so many cpu.

    Here is the screenshoot:
    http://pasteboard.co/zILr2owiq.png
    and below is screenshoot on load:
    http://pasteboard.co/zINuompyu.png

    Is that normal?
    Thank you.

    I’m using Intel Core i5 6200U, asus laptop.

  • Like 1

    this can not be normal, something seems to went wrong, ake a look to the journal:

    journalctl -f
    

    from WIKI
    When PulseAudio needs to pass audio from one module to another using incompatible sample-rate (for example, playback at 96kHz to a card that only supports a maximum of 48kHz), specifies which resampler to use. You can use the command

    pulseaudio --dump-resample-methods
    

    to list all available resamplers and choose the best tradeoff between CPU usage and audio quality for your taste.
    Tip: One of the major complaint about PulseAudio is its high CPU usage in some use cases. A lot of these cases happens when pulse needs to resample multiple streams (individually). If you intend to mix multiple sample rates often, consider creating an additional sink at the correct sample rate which you can then feed back to your main sink, resampling only once.

    …but from me here only half of help, solution will be needed toooo…

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Like 0

    hmm, when I re-enable the volume control and reboot. There are no more error. I don’t really understand how the error happened.
    I guess it’s only happened on some unfortunate time.
    I’ll mark as solved for now.

  • Like 0

    excuse me, I hope this wasn’t necrobumping. If yes, I’m sorry.
    I think I found the problem. This isn’t related to pulseaudio. This also happen in ‘Mount Device’ and ‘Clipman’ wrapper.

    It’s caused by XFCE theme that I used called Vimix. I was using this theme since in gnome shell.
    here is the video: https://youtu.be/qZVeIBsla14

    changing theme or use solid color as anel background solved it.

  • Like 1

    you can not necrobumping your own post … and it is only 21 days old it is not dead ;)

    maybe interesting for xfce developers? > https://bugzilla.xfce.org/

    and if it caused by the theme:
    vimix-xfce-look.org

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

xfce41 pulseaudio7 xfce417 Posts 5Views 254
Log in to reply