• Screen recording issues in Gnome 2.22.2

    Hello everybody,

    I’m having troubles trying to record screen in Gnome. I’ve tried Vokoscreen, SimpleScreenRecorder and EasyScreenCast.

    When I install the EasyScreenCast extension for Gnome, the screen gets frozen and I can’t login again due to the login process stucks after username/password input. To login again, I need to remove the extension directory from console.

    With Vokoscreen and SimpleScreenRecorder, the record process seems to work, but after the video is recorded, it only shows the mouse cursor and a black background.

    When I use the “GNOME classic” mode the recorders work fine.

    I installed the “screenfetch” command to check what is different related to Windows Manager and Desktop Environment and here is part of each outputs:

    GNOME mode

    OS: Antergos
    Kernel: x86_64 Linux 4.9.8-1-ARCH
    Shell: bash 4.4.12
    DE: Gnome
    WM: GNOME Shell
    WM Theme: Numix-Frost-Light
    GTK-Theme: Numix-Frost [GTK2/3]
    CPU: Intel Core i5-4210U CPU @ 2.7GHz
    GPU: Mesa DRI Intel® Haswell Mobile

    GNOME classic mode

    OS: Antergos
    Kernel: x86_64 Linux 4.9.8-1-ARCH
    Shell: bash 4.4.12
    WM: GNOME Shell
    WM Theme: Numix-Frost-Light
    CPU: Intel Core i5-4210U CPU @ 2.7GHz
    GPU: Mesa DRI Intel® Haswell Mobile

    I really want to use the recorders in default GNOME mode.

    I hope you can help me to fix this issue. Thanks for your help

  • Gnome Version 3.22.2…
    Seems to be a problem with wayland?
    Do you try to start gnome-Xorg Session?

  • @joekamprad said in Screen recording issues in Gnome 2.22.2:


    Yes, I tried gnome-Xorg session and I got the same result. Only the GNOME classic session works.

  • https://help.gnome.org/users/gnome-help/stable/screen-shot-record.html.en

    No need to install a program, use
    Ctrl+Alt+Shift+R to start and stop recording, creates a file inside your users /Video folder
    it creates a .wbm video.

    As you can see for uploading to youtube converting should be good… wbm > mp4

  • @joekamprad Yes, I tried that too and the screen got frozen.

    I tried replacing wayland with wayland-git, but login screen stop working and I was unable to get it working back.

    So, I had to reinstall the system and tested the EasyScreenCast extension, Vokoscreen and Ctrl + Alt + Shift + R and all is working.

    I think that another application install may caused the issues, but I’m not sure which one. Anyway, I can record the screen or window now.

    BTW: The Ctrl + Alt + Shift + R combination records the whole screen but not a specific window.

  • I think that I found the problem. I installed and enabled GDM. I’ve tested changing between lightdm and gdm and I can confirm that using GDM is causing the problem.

  • Finally I found the cause and fixed this issue.

    As @joekamprad mentioned, it’s a wayland related issue. I enabled GDM again and the session got stuck when try to login. Then I disabled Wayland from GDM custom settings and now, seems to be working fine.

    sudo nano /etc/gdm/custom.conf

    Uncomment the following line:


    That solved this problem in my case. I hope this information can help to somebody else having the same issue.

  • I do not use wayland neither nouveau at the moment… it put a lot of problems since nouveau is inside kernel…

gnome361 issues100 recording5 2.22.21 Posts 8Views 1523
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.