• Font rendering in GTK apps under KDE


    I’ve been a happy user of Antergos for a few months now, using GNOME. But as a human is a curious creature, I wanted to try out a KDE desktop. So I installed it a separate partition. My SDD is divided into 4 partitions:
    1 - Antergos/GNOME
    2 - Antergos/KDE
    3 - /home (shared by Gnome and KDE
    4 - swap

    I’ve polished and tweaked my Gnome system, where font rendering used to be managed by the infinity bundle, but since it has no longer been maintained I took some steps to get rid of it and got a satisfactory font rendering without it.

    About a week ago I installed a new Antergos/KDE system to another partition and I have been struggling with font rendering again. I mean, fonts in QT apps are just fine, but as I use a few GTK apps as well (SW manager in KDE is a GTK app!) the look of the fonts is just horrible.
    alt text
    My /etc/fonts/conf.d lists:

    README                                            37-repl-global-ms.conf
    00kde.conf                                        40-nonlatin.conf
    10-enhanced-defaults.conf                         45-gelasio.conf
    10_fontconfig-enhanced-defaults.gschema.override  45-latin.conf
    10-hinting-medium.conf                            49-sansserif.conf
    10-scale-bitmap-fonts.conf                        50-user.conf
    10-sub-pixel-rgb.conf                             51-local.conf
    11-lcdfilter-default.conf                         57-dejavu-sans.conf
    20-unhint-small-dejavu-sans.conf                  57-dejavu-sans-mono.conf
    20-unhint-small-dejavu-sans-mono.conf             57-dejavu-serif.conf
    20-unhint-small-dejavu-serif.conf                 60-latin.conf
    20-unhint-small-vera.conf                         60-latin-ms.conf
    30-carlito.conf                                   65-fonts-persian.conf
    30-infinality-aliases.conf                        65-nonlatin.conf
    30-metric-aliases.conf                            65-non-latin-ms.conf
    30-metric-aliases-ms.conf                         66-aliases-wine-combi.conf
    30-ttf-liberation-mono.conf                       66-aliases-wine-ms.conf
    30-ttf-liberation-sans.conf                       69-unifont.conf
    30-urw-aliases.conf                               80-delicious.conf
    30-win32-aliases.conf                             90-synthetic.conf
    31-cantarell.conf                                 99pdftoopvp.conf
    

    which is pretty the same as in my GNOME session. My Xresource file reads:

    Xft.antialias: 1
    Xft.hinting: 1
    Xft.hintstyle: hintslight
    Xft.rgba: rgb
    Xft.lcdfilter: lcddefault
    !Xft.autohint: 0
    

    Any hints how to improve renderring in GTK apps?

  • @vlad.kuzba Unsure, I’d also expect this to work by default. However, I did tinker with the font settings, so no idea about the original experience. You could try to configure fonts in System Settings → Application Style → GNOME Application style (GTK). If it is any help.

  • All Kde fonts, including Gtk apps but excluding Chromium, are usually rendered beautifully in two simple steps.

    1. Forcing font information cache files rebuild
      fc-cache -fv
      
      Logout-login after that.

    2 Enabling anti-aliasing and setting it to specific values:

    System settings --> Fonts --> and then

    • Use anti-aliasing: Enabled
      • Sub-pixel rendering type: RGB
      • Hinting style: Slight

    0_1487341264094_plasma-font-rendering.png

  • Thank both of you, guys. Enabling anti-aliasing in System settings solved the issue. I don’t know why, but I supposed once you’ve linked your preferred setting to /etc/fonts/conf.d you are not expected to “touch” the preferences in System settings.

  • That’s good. Just remember, these settings | improvements don’t affect font rendering in Chromium under Kde. They’re controlled in another way.

    Thanks for marking the topic as [Solved].

font27 apps17 gtk17 rendering5 Posts 5Views 2552
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.