• nm-applet: WiFi password prompt not appearing in Openbox

    Noticed a problem with the nm-applet in the Antergos Openbox version, both in the live minimal and the fully installed environment.

    When I click on a WiFi AP, it just tries to connect, and fails, and doesn’t prompt for a WPA password. Trying to edit the entry in Network Connections applet doesn’t help, because the WiFi Security tab isn’t there. Only way I was able to connect was to select “Connect to Hidden WiFi Network” and manually enter SSID and WPA password. After that it connects fine and I can see the entry with WiFi Security tab and password in Network Connections.

    I also tried the full Antergos Gnome Live version, and that works properly, every time I tried it. I’ve never noticed any problem with other Linux distros not prompting for Wifi password with this laptop with RAL RT5390 chipset.

    Any others noticed this issue?

  • Just searching around and found a fix:

    Installed gnome-keyring and now the WiFi password prompt comes up as it should.

  • @jondo220

    Yes this is an old thread, however I spent the past few days scratching my head and thinking that something was wrong with my hardware. Until I found this post.

    In a nutshell this problem can still exist with some installs so leaving you a thumbs up.

wifi152 password38 prompt8 nm-applet2 Posts 3Views 1073
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.