• Wifi PCI card drivers


    I recently installed*** Antergos as a dual boot option on a Windows 10 machine. I have an ASUS PCI Wireless Card, the AC3100. I’m new-ish to installing Linux and finding working drivers (I’ve mostly just played around with virtual boxes until now) and a couple google searches have not helped me solve my problem. It is currently not practical to run an Ethernet cable from my router to my desktop.

    Is there not just some kind of generic ASUS Wireless driver that will get the wifi working on Antergos with my hardware?

    Thanks in advance!

    ***Edit: Sorry, I forgot that I didn’t actually install Antergos as an internet connection is required. I played around in the live environment and couldn’t get my wifi to work. I’ve tried installing both Ubuntu (and its derivatives) as well as Manjaro and now Antergos, and I’ve yet to find a way to get my wifi working properly.

  • Driver/Firmware is never /generic/ it depending on the exact chip/set

    Kernel Modul seems to be: brcmfmac
    Chip: BCM4366



    Seems to need a firmware…

  • @joekamprad Thank you for the quick response. Since this is all new to me, please let me know if I’m misunderstanding the situation:

    The AC3100 operates on the brcmfmac kernel, specifically the BCM4366 chipset. According to the link you provided (from wiki.kernel.org), support for the BCM4366 wifi chipset is scheduled to be included in the 4.6 Antergos release (or later, if that’s what 4.6+ means). So, there’s nothing really I can do until Antergos 4.6 is released.

    Is that correct? When 4.6 is released and support for BCM4366 is included, does that mean that the Antergos live ISO will have out-of-the-box support for my wifi card, and I’ll be able to install Antergos with a working internet connection?

    I guess what I meant what I said “generic” drivers was probably “third-party” or “unofficial” drivers. I mean, is it just the case that if you have the same wifi card as me, you simply can’t access the internet using Antergos? And that I’m completely at the mercy of Antergos’ update release schedule to be able to start using it?

  • What is Linux?

    The number means the Kernel version Antergos is a rolling release Distro so not like Ubuntu e.t.c.
    The Kernel Version now is 4.9.8-1-ARCH

    The side say that up from Kernel 4.4+ BCM4366 is supported by the Kernel. So what i can see it is possible to enable wifi for you.

    More info about Broadcom Wifi: https://wiki.archlinux.org/index.php/broadcom_wireless

    As far as i can see your Wifi Card is not aviable from Network Menue inside the Antergos-Installer ?
    This is maybe because the Wifi-Card try to load a firmware and do not get this, or it is wrongly detectet and uses a wrong driver…

    To help you here we need to get some more Info outside a running Linux from you.
    but first inform you about Linux/Antergos and Archlinux too.

  • @joekamprad I see, so the brcmfmac kernel is tied to the Linux distribution, not the chipset like I thought. And hence, the support for the BCM4366 chipset is limited to version 4.6 or later of the linux kernel, which is not the same as the Antergos distribution version.

    I’ll take a look at the page you just linked a bit later, and I’ll try installing Antergos again after configuring the live ISO to recognize my wifi card.

  • @matthew.brunetti28 would be good to see output from:


    may you can pastebin the links here… may it is simple add some kernel parameters while booting the installer…

  • @joekamprad

    Here are the pastebin links for the output of lspci and dmesg :

    Hope this helps…

  • As of 18 Oct 2016 there is still no Linux-compatible firmware for this device
    But some people seems to get it working:

    From LSPCI:
    06:00.0 Network controller: Broadcom Limited Device 43c3 (rev 04)

    But there is no detection, nothing no Module loaded and no firmware load error from dmesg…
    Is it the full output? may you can post systemdlogs as discribed here:

  • brcmfmac4366c-pcie.bin i can give you i have the firmware here extracted…
    So may putting the firmware to the right place and do :

    sudo modprobe brcmfmac

    will enable your wifi

  • @joekamprad Here’s the output for journalctl -b -0: link. As for lspci and dmesg, I pasted the full output of those functions into the pastebin links.

    I should maybe also add that I created the bootable Antergos USB by downloading the full ISO from the website, and then using Rufus, I made a bootable USB using the DD method (not the live ISO method). Could that have something to do with my problems?

  • Feb 14 15:11:11 ant-17.2 kernel: brcmfmac 0000:06:00.0: Direct firmware load for brcm/brcmfmac4366c-pcie.bin failed with error -2

    download brcmfmac4366c-pcie.zip

    unzip 2017/02/brcmfmac4366c-pcie.zip
    sudo cp brcmfmac4366c-pcie.bin /usr/lib/firmware/brcmfmac4366c-pcie.bin


    sudo modprobe brcmfmac
  • @joekamprad Little slow coming back around to update, but let me try to recap what I did. TL:DR; My wifi still doesn’t work.

    So I found from one of your links that some users were having problems with their network drivers being auto-blacklisted by the live environment. Indeed, I found a file titled broadcom-wl-dkms.conf (or something like that) which was blacklisting what seemed to be important drivers.

    For a more detailed version of lspci, here’s the output of lspci -vnn: here. The output for the network controller is at the very bottom, but I included the whole thing just in case there’s something else in there that can help.

    Here’s the weirdest problem I had: As @joekamprad suggested, I unzipped the driver and copied it to the specified directory, /usr/lib/firmware/brcm. Then I did suo modprobe brcmfmac and as you can see from my terminal output, nothing happened. Like, nothing. No error message, nothing. So, I did sudo modprobe brcmfmac4366c-pcie.bin, e.g. using the name of the actual file. THEN I got an error message stating that the module is not in the appropriate directory, even though ls'ing the directory clearly shows the file there.

    Some final miscellaneous information: here’s my system log output (I think this is the system log from when the live environment is booting? I don’t know, I just hope this helps.)
    Lastly, here’s a message from systemctl which I found weird, don’t know if it’s meaningful or helpful in any way…

  • sudo modprobe

    is for modules, brcmfmac4366c-pcie.bin is a firmware file that used to be loaded into the device for making use of it… this is proceeded automaticly…

    sudo modprobe brcmfmac

    is right to load the module for your card

    place for the firmware you did right i think but i am not 100% shure (/usr/lib/firmware/brcm) would be helpfull to have a sys-log-journal after putting the firmware to the folder an modprobe the module…

  • @joekamprad I see. So, if I do everything the same as last time - .bin file in the /usr/lib/ folder, sudo modprobe brcmfmac, you’re saying it should work? So then after I do that, if it still doesn’t work, if type sys-log-journal into the terminal, will that give me output that will be useful for you?

  • sys-log-journal is not a command…
    Logs are helpfull in this way :


    and the folder should be the one you choose before.

  • @joekamprad So I did the first set of commands, but it looks like you want the output from the last set of commands on the link you posted?

  • journalctl -b -0

installation309 wifi142 drivers53 wireless35 Posts 17Views 5382
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.