• \[SOLVED\] Volume Control issue


    I don’t think the aur package will help so let’s skip it. Try adding the following string to the kernel boot command. First, when Grub starts, immediately press “e”. Find the line that looks like this:

    linux /vmlinuz-linux root=UUID=... rw quiet resume=UUID=...
    

    and add this to the end of the line:

     Check to see if your brightness control works, if not repeat the same process with the following strings (one at a time)
    

    acpi_osi="!Windows 2012"[/code:1nt64uun] If none of those fix the issue then you should edit /etc/X11/xorg.conf.d/20-intel.conf to say this:

    Section "Device"  
    Identifier "card0"  
    Driver "intel"  
    Option "AccelMethod" "sna"  
    Option "Backlight" "intel\_backlight"  
    BusID "PCI:0:2:0"  
      
    EndSection
    

    Good luck

  • I don’t think the aur package will help so let’s skip it. Try adding the following string to the kernel boot command. First, when Grub starts, immediately press “e”. Find the line that looks like this:

    linux /vmlinuz-linux root=UUID=... rw quiet resume=UUID=...
    

    and add this to the end of the line:

     Check to see if your brightness control works, if not repeat the same process with the following strings (one at a time)
    

    acpi_osi="!Windows 2012"[/code:1nt64uun] If none of those fix the issue then you should edit /etc/X11/xorg.conf.d/20-intel.conf to say this:

    Section "Device"  
    Identifier "card0"  
    Driver "intel"  
    Option "AccelMethod" "sna"  
    Option "Backlight" "intel\_backlight"  
    BusID "PCI:0:2:0"  
      
    EndSection
    

    Good luck

  • I will try these techniques out. Thank you so much!

  • I typed in video.use_native_backlight=1 booted antergos, and my brightness controls work now! Thanks again for all the help. I appreciate it a lot.

  • You’re welcome! Glad its working for you. Let us know if you have any other questions

    Cheers!

  • So funny story. I typed in video.use_native_backlight=1, and it was working, booted up my computer, keys worked fine. I shutdown my computer, and tried the keys again. It didn’t respond. I rebooted my computer, pressed e as soon as grub boot up, and the line I had typed in was gone. I typed in acpi_backlight=vendor, so hopefully it will take this time. But if it doesn’t, is there a way to save the line in the grub edit for next time?

  • So here is a funny story to go along with your funny story…I forgot to mention that setting kernel boot options in the grub menu is not persistant.

  • Forgive my noobish question, but how do I edit the grub config file? Like what do I type in the terminal to edit it?

  • Try this from the terminal:

    # This will open a Terminal-Text-Editor
    sudo nano /etc/default/grub

    There you can add your kernel option and then CTRL+X to exit. It will ask you to save, you press Y for yes and then ENTER.
    Back in the Terminal you do this:

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Good Luck!

    Please give a feedback after you get help so the thread can be set to solved.

  • @b1n0ry I typed sudo nano /etc/default/grub and there are two lines in there already. One says acpi_osi=Linux, and the other one says acpi_backlight=vendor. Do I add my line after that one or do I replace one of the acpi lines?

  • Can you please copy the content of your /etc/default/grub here?

    You can

    cat /etc/default/grub > grub.txt

    Then you can upload grub.txt as attachment.

    Please give a feedback after you get help so the thread can be set to solved.

  • Hi,

    Do you have other distros installed on this system? Are you sure you checked /etc/default/grub from your ANTERGOS installation? We do not place those options into the file automatically so I am not sure how they would be there already?

    Best Regards,
    Dustin

  • I do not have any other distros installed other than Windows 8.1, but that’s on a different partition. I did have some other distros installed earlier, but removed them to install Antergos. Would that interfere with the grub at all?

  • How do I copy the contents of my grub? I did the cat command, and looked for the grub file to upload but could not find it.

  • I am sorry for the confusion. I didn’t notice until now that another user also provided a suggestion. Just navigate to /etc/default with the file manager and double click the “grub” file to open it. Post the contents here. Thanks.

    Cheers!

  • Well thats another way to do it. I thought i can show you an effective way to do it by the way.

    cat /etc/default/grub > grub.txt

    This command outputs (cat) the content of grub, directs it (>) into the file grub.txt or any other filename of your choice. You can find the output file in the current directory where you are with the Terminal at the moment.

    Please give a feedback after you get help so the thread can be set to solved.

  • GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=Antergos
    GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=ef2a8b1d-b9c7-4b7d-8968-68a0b61aa6e6 quiet"
    GRUB_CMDLINE_LINUX=“acpi_­osi=Linux acpi_backlight=vendor”

    # Preload both GPT and MBR modules so that they are not missed
    GRUB_PRELOAD_MODULES=“part_gpt part_msdos”

    # Uncomment to enable Hidden Menu, and optionally hide the timeout count
    #GRUB_HIDDEN_TIMEOUT=5
    #GRUB_HIDDEN_TIMEOUT_QUIET=true

    # Uncomment to use basic console
    GRUB_TERMINAL_INPUT=console

    # Uncomment to disable graphical terminal
    #GRUB_TERMINAL_OUTPUT=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo’
    GRUB_GFXMODE=auto

    # Uncomment to allow the kernel use the same resolution used by grub
    GRUB_GFXPAYLOAD_LINUX=keep

    # Uncomment if you want GRUB to pass to the Linux kernel the old parameter
    # format “root=/dev/xxx” instead of “root=/dev/disk/by-uuid/xxx”
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    GRUB_DISABLE_RECOVERY=true

    # Uncomment and set to the desired menu colors. Used by normal and wallpaper
    # modes only. Entries specified as foreground/background.
    #GRUB_COLOR_NORMAL=“light-blue/black”
    #GRUB_COLOR_HIGHLIGHT=“light-cyan/blue”

    # Uncomment one of them for the gfx desired, a image background or a gfxtheme
    #GRUB_BACKGROUND="/path/to/wallpaper"
    GRUB_THEME="/boot/grub/themes/Antergos-Default/theme.txt"

    # Uncomment to get a beep at GRUB start
    #GRUB_INIT_TUNE=“480 440 1”

    #GRUB_SAVEDEFAULT=“true”

  • I did the sudo nano command again, entered the text, and now I can use the brightness keys again. I’m gonna restart it though, to make sure it took.

  • Did you run the grub-mkconfig command after nano’ing the file?

    Please give a feedback after you get help so the thread can be set to solved.

  • Yes I did. What should I do next?

Posts 26Views 5535
Log in to reply