• \[Solved\] KDE & Partial Sound


    I know KDE is known for having quirks with sound. I thought I was good as notification chimes work, however youtube videos have no audio. I reviewed the wikis and there is a lot to say on this topic. I’m not looking to switch to pulse audio. I think I just need to change where the “default” points to.

    For example, under System Settings > Multimedia if I select “Default” and click Test, I get nothing. However, if I select “HDA Intel PCH (ALC282 Analog)” and click Test, I hear the test sound from the laptop speakers.

    Not sure which of the following is useful:

    [email protected] ~]$ lsmod | grep '^snd' | column -t  
    snd\_hda\_codec\_hdmi 36379 1  
    snd\_hda\_codec\_realtek 45293 1  
    snd\_hda\_intel 37352 4  
    snd\_hda\_codec 150017 3 snd\_hda\_codec\_realtek,snd\_hda\_codec\_hdmi,snd\_hda\_intel  
    snd\_hwdep 6332 1 snd\_hda\_codec  
    snd\_pcm 77822 3 snd\_hda\_codec\_hdmi,snd\_hda\_codec,snd\_hda\_intel  
    snd\_page\_alloc 7330 2 snd\_pcm,snd\_hda\_intel  
    snd\_timer 18718 1 snd\_pcm  
    snd 59029 15 snd\_hda\_codec\_realtek,snd\_hwdep,snd\_timer,snd\_hda\_codec\_hdmi,snd\_pcm,snd\_hda\_codec,snd\_hda\_intel  
    
    
      
    [[email protected] ~]$ aplay -l  
    \*\*\*\* List of PLAYBACK Hardware Devices \*\*\*\*  
    card 0: PCH [HDA Intel PCH], device 0: ALC282 Analog [ALC282 Analog]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    card 0: PCH [HDA Intel PCH], device 1: ALC282 Digital [ALC282 Digital]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    
    

    This runs, but I get no sound:

    [[email protected] ~]$ speaker-test -c 2  
      
    speaker-test 1.0.27.2  
      
    Playback device is default  
    Stream parameters are 48000Hz, S16\_LE, 2 channels  
    Using 16 octaves of pink noise  
    Rate set to 48000Hz (requested 48000Hz)  
    Buffer size range from 2048 to 16384  
    Period size range from 1024 to 1024  
    Using max buffer size 16384  
    Periods = 4  
    was set period\_size = 1024  
    was set buffer\_size = 16384  
    0 - Front Left  
    1 - Front Right  
    Time per period = 5.652501  
    0 - Front Left  
    1 - Front Right  
    
    

    The alsamixer does not indicate anything is muted.

  • I know KDE is known for having quirks with sound. I thought I was good as notification chimes work, however youtube videos have no audio. I reviewed the wikis and there is a lot to say on this topic. I’m not looking to switch to pulse audio. I think I just need to change where the “default” points to.

    For example, under System Settings > Multimedia if I select “Default” and click Test, I get nothing. However, if I select “HDA Intel PCH (ALC282 Analog)” and click Test, I hear the test sound from the laptop speakers.

    Not sure which of the following is useful:

    [email protected] ~]$ lsmod | grep '^snd' | column -t  
    snd\_hda\_codec\_hdmi 36379 1  
    snd\_hda\_codec\_realtek 45293 1  
    snd\_hda\_intel 37352 4  
    snd\_hda\_codec 150017 3 snd\_hda\_codec\_realtek,snd\_hda\_codec\_hdmi,snd\_hda\_intel  
    snd\_hwdep 6332 1 snd\_hda\_codec  
    snd\_pcm 77822 3 snd\_hda\_codec\_hdmi,snd\_hda\_codec,snd\_hda\_intel  
    snd\_page\_alloc 7330 2 snd\_pcm,snd\_hda\_intel  
    snd\_timer 18718 1 snd\_pcm  
    snd 59029 15 snd\_hda\_codec\_realtek,snd\_hwdep,snd\_timer,snd\_hda\_codec\_hdmi,snd\_pcm,snd\_hda\_codec,snd\_hda\_intel  
    
    
      
    [[email protected] ~]$ aplay -l  
    \*\*\*\* List of PLAYBACK Hardware Devices \*\*\*\*  
    card 0: PCH [HDA Intel PCH], device 0: ALC282 Analog [ALC282 Analog]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    card 0: PCH [HDA Intel PCH], device 1: ALC282 Digital [ALC282 Digital]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]  
    Subdevices: 1/1  
    Subdevice \#0: subdevice \#0  
    
    

    This runs, but I get no sound:

    [[email protected] ~]$ speaker-test -c 2  
      
    speaker-test 1.0.27.2  
      
    Playback device is default  
    Stream parameters are 48000Hz, S16\_LE, 2 channels  
    Using 16 octaves of pink noise  
    Rate set to 48000Hz (requested 48000Hz)  
    Buffer size range from 2048 to 16384  
    Period size range from 1024 to 1024  
    Using max buffer size 16384  
    Periods = 4  
    was set period\_size = 1024  
    was set buffer\_size = 16384  
    0 - Front Left  
    1 - Front Right  
    Time per period = 5.652501  
    0 - Front Left  
    1 - Front Right  
    
    

    The alsamixer does not indicate anything is muted.

  • Hmmm… this might need to be moved to “Multimedia and Games”.

  • Hi,

    Does this only happen when your HDMI monitor is connected? Check your volume settings on the monitor itself. Whether I run GNOME or KDE my system always sets the HDMI connection as default. It hasn’t bothered me enough to try to change it hehe.

    Best Regards,
    Dustin

  • @“lots.0.logs”:63xgksm3 said:

    Does this only happen when your HDMI monitor is connected? Check your volume settings on the monitor itself. Whether I run GNOME or KDE my system always sets the HDMI connection as default. It hasn’t bothered me enough to try to change it hehe. [/quote:63xgksm3]

    No external monitor… this is just using laptop as is. Just trying to use internal JBL speakers.

    When I tried to start KMIX from the menu, I get the bouncy icon but nothing opens up. Then I finally noticed you can start KMIX from the sound icon in status tray. From within KMIX I played around and finally got sound working. Seems like I have to put the sliders up to 80% before I start to hear anything, but at least I hear something now.

Posts 5Views 1433
Log in to reply