• Turn screen off after inactivity


    I noticed that my screen doesn’t turn off after inactivity. I looked at the Light Locker settings and made some changes, but it didn’t work. Thanks for the help.

  • @maxbraday said

    I looked at the Light Locker settings and made some changes, but it didn’t work.

    I suppose you re using Gnome DF, right? If so, are Gnome native power settings disabled?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • How do I check if the Gnome native power settings are disabled?

  • In its SYSTEM SETTINGS. I dont exactly remember its layout but it should be something like BRIGHTNESS AND LOCK.
    Sorry, I haven t been using Gnome for quite some time, so someone else could be more helpful.
    Also: Gnome now uses WAYLAND by default. I remember that under Wayland power settings were working and didn t have to use LIGHT LOCKER at all. Check this option out, too, in case you re on Wayland session.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I am new to Antergos, so I really appreciate your help. I just saw the Light Locker settings, but how do I access the Wayland power settings? How do I find out if I use Wayland?

  • @maxbraday

    How do I find out if I use Wayland?

    Run and check its output." Wayland" or “X11”?:
    echo $XDG_SESSION_TYPE

    @maxbraday said

    how do I access the Wayland power settings?

    Wayland is a compositor protocol and library implementation of that protocol. For more info look here
    So, in fact all you have to do is go to Gnome System Settings and adjust your power settings as I have described in my previous post.
    PLEASE NOTE
    And at the same time to correct myself. To do the above (to disable light locker settings and use the native Gnome Settings, that is) you need to to disable the default Antergos lightdm (the page that opens up to type your password) and use gdm (the natine gnome one). There have been reports for systems that had to use gdm instead of the default lightdm to operate correctly. To do that run these commands one after the other:
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    sudo reboot
    *I suggest you do that only if no one else can provide you with a better solution than mine.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Thank you. I am amazed at the quick responses. I am very happy that I switched to Antergos.

  • @maxbraday , you re welcome. Let us know what you did and what the result was.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I used echo $XDG_SESSION_TYPE to determine that I run X11. I have not tried your other suggestion yet, but I will try it soon.

turn4 inactivity1 Posts 9Views 592
Log in to reply