• Battery not detected.


    Hello, I hate to ask for help with this, but I’ve tried pretty much every solution I’ve seen so far.

    My machine is a Dell Inspiron 7737, and I’m running Antergos Linux w/ Cinnamon 3.2.8 on kernel version 4.9.7-1-ARCH.

    The most common solution I’ve seen is setting acpi_osi=Linux in GRUB, but that still did not work.

    This is what “acpi -V” and “dmesg | grep BAT” return respectively.

    acpi -V

    Adapter 0: off-line
    Thermal 0: ok, 41.5 degrees C
    Thermal 0: trip point 0 switches to mode critical at temperature 84.0 degrees C
    Cooling 0: Processor 0 of 10
    Cooling 1: Processor 0 of 10
    Cooling 2: intel_powerclamp no state information available
    Cooling 3: Processor 0 of 10
    Cooling 4: Processor 0 of 10
    Cooling 5: x86_pkg_temp no state information available
    
    

    dmesg | grep BAT

    ACPI: Battery Slot [BAT0] (battery absent)
    
    

    This is not restricted to Arch distros alone. I’ve noticed

    I would really appreciate help.
    Thanks.

  • you mean:

    acpi_osi=Linux acpi_rev_override
    

    ?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • My bad. That is what I meant. Forgot the latter part.

  • what gives you:

    upower -d
    

    But " but I’ve tried pretty much every solution I’ve seen so far" means you want us to repeat everything you already try?:crystal_ball:

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • upower -d

    Device: /org/freedesktop/UPower/devices/line_power_AC
      native-path:          AC
      power supply:         yes
      updated:              Wed 08 Feb 2017 01:36:29 PM CST (2061 seconds ago)
      has history:          no
      has statistics:       no
      line-power
        warning-level:       none
        online:              no
        icon-name:          'ac-adapter-symbolic'
    
    Device: /org/freedesktop/UPower/devices/DisplayDevice
      power supply:         no
      updated:              Wed 08 Feb 2017 01:36:29 PM CST (2061 seconds ago)
      has history:          no
      has statistics:       no
      unknown
        warning-level:       none
        icon-name:          ''
    
    Daemon:
      daemon-version:  0.99.5
      on-battery:      no
      lid-is-closed:   no
      lid-is-present:  yes
      critical-action: PowerOff
    
    

    Well, I was just wondering if this was a common problem, or if it was just my computer. I believe it is the latter because this problem only occurs on this laptop, and it is persistent regardless of Linux distro whether it be Debian, Fedora, Gentoo, or Arch based. Also, it only seems to happen with Gnome based DE’s. KDE did not that this problem.

    EDIT: Oh, I forgot to mention. The icon and battery status updates upon power actions such as the power cord being plugged/unplugged, but it will only update for that instance. It will not update as the battery charges or drains.

  • very strange… As i see it is special with exact your Computer.
    So as i understand Battery is working and will charge also? It is only not showing up inside Gnome?

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    howto-install-antergos
    how to add system logs
    i3-wm#gnome-shell

  • Basically. I’m really unsure as to why. It’s not just the installation either. It’s the same with live disks as well, or completely different installs.

  • @Devin-Neal is conky-manager able to show you the battery info? If so you can use it as a temporary solution for monitoring batery status…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • It is not able to display battery info either.

  • Install:

    $ sudo pacman -S tlp
    
    $ sudo tlp-stat
    --- TLP 0.9 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=powersave
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC=max_performance
    SATA_LINKPWR_ON_BAT=min_power
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=1
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    RUNTIME_PM_ALL=1
    RUNTIME_PM_DRIVER_BLACKLIST="radeon nouveau"
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    
    +++ System Info
    System         = Dell Inc. Not Specified Inspiron 5423
    BIOS           = A08
    Kernel         = 4.9.8-1-ARCH #1 SMP PREEMPT Mon Feb 6 12:59:40 CET 2017 x86_64
    /proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=2b262f90-4ce8-4d01-bb2a-ec7bb0e45e55 rw quiet
    Init system    = systemd 
    Boot mode      = UEFI
    
    +++ TLP Status
    State          = enabled
    Last run       = 09:32:17,   1199 sec(s) ago
    Mode           = battery
    Power source   = battery
    
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    
    +++ Processor
    CPU model      = Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
    
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  3000000 [kHz]
    
    /sys/devices/system/cpu/intel_pstate/min_perf_pct      = 26
    /sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100
    /sys/devices/system/cpu/intel_pstate/no_turbo          = 0
    /sys/devices/system/cpu/intel_pstate/turbo_pct         = 49
    /sys/devices/system/cpu/intel_pstate/num_pstates       = 23
    
    x86_energy_perf_policy: program not installed.
    
    /proc/sys/kernel/nmi_watchdog                          = 0
    
    +++ Undervolting
    PHC kernel not available.
    
    +++ Temperatures
    CPU temp               =    50 [°C]
    Fan speed (fan1)       =  2967 [/min]
    
    +++ File System
    /proc/sys/vm/laptop_mode               =     2
    /proc/sys/vm/dirty_writeback_centisecs =  6000
    /proc/sys/vm/dirty_expire_centisecs    =  6000
    /proc/sys/vm/dirty_ratio               =    20
    /proc/sys/vm/dirty_background_ratio    =    10
    /proc/sys/fs/xfs/age_buffer_centisecs  = (not available)
    /proc/sys/fs/xfs/xfssyncd_centisecs    = (not available)
    /proc/sys/fs/xfs/xfsbufd_centisecs     = (not available)
    
    +++ Storage Devices
    /dev/sda:
      Model     = WDC WD5000LPVT-75G33T0                  
      Firmware  = 01.01A01
      APM Level = 128
      Status    = active/idle
      Scheduler = cfq
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
      SMART info:
          4 Start_Stop_Count          =     3789 
          5 Reallocated_Sector_Ct     =        0 
          9 Power_On_Hours            =     1632 [h]
         12 Power_Cycle_Count         =     2739 
        193 Load_Cycle_Count          =    87046 
        194 Temperature_Celsius       =       31    [°C]
        241 Total_LBAs_Written        =    1.477 [TB]
    
    /dev/sdb:
      Model     = Micron C400 RealSSD mSATA 32GB          
      Firmware  = 01MG    
      APM Level = 128
      Status    = active/idle
      TRIM      = supported
      Scheduler = deadline
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
      SMART info:
          5 Reallocated_Sector_Ct     =        0 
         12 Power_Cycle_Count         =     2740 
        177 Wear_Leveling_Count       =      100 [%]
        178 Used_Rsvd_Blk_Cnt_Chip    =        4 
        179 Used_Rsvd_Blk_Cnt_Tot     =        0 
        180 Unused_Rsvd_Blk_Cnt_Tot   =     2157 
        241 Total_LBAs_Written        =    0.488 [TB]
    
    
    +++ SATA Aggressive Link Power Management
    /sys/class/scsi_host/host0/link_power_management_policy  = min_power
    /sys/class/scsi_host/host1/link_power_management_policy  = min_power
    /sys/class/scsi_host/host2/link_power_management_policy  = min_power
    /sys/class/scsi_host/host3/link_power_management_policy  = min_power
    /sys/class/scsi_host/host4/link_power_management_policy  = min_power
    /sys/class/scsi_host/host5/link_power_management_policy  = min_power
    
    +++ AHCI Host Controller Runtime Power Management
    /sys/bus/pci/devices/0000:00:1f.2/ata1/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata2/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata3/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata4/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata5/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata6/power/control = on
    
    +++ PCIe Active State Power Management
    /sys/module/pcie_aspm/parameters/policy = default (using bios preferences)
    
    +++ Intel Graphics
    /sys/module/i915/parameters/powersave        = (not available)
    /sys/module/i915/parameters/enable_rc6       =  3 (enabled + deep)
    /sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
    /sys/module/i915/parameters/enable_fbc       =  0 (disabled)
    /sys/module/i915/parameters/enable_psr       =  0 (disabled)
    /sys/module/i915/parameters/lvds_downclock   = (not available)
    /sys/module/i915/parameters/modeset          =  1 (enabled)
    /sys/module/i915/parameters/semaphores       =  1 (enabled)
    
    +++ Radeon Graphics
    /sys/class/drm/card1/device/power_dpm_state = balanced
    /sys/class/drm/card1/device/power_dpm_force_performance_level = off
    
    +++ Wireless
    bluetooth = on
    wifi      = on
    wwan      = none (no device)
    
    hci0(btusb)                   : bluetooth, not connected
    wlp7s0(wl)                    : wifi, connected, power management = on
    
    +++ Audio
    /sys/module/snd_hda_intel/parameters/power_save            = 1
    /sys/module/snd_hda_intel/parameters/power_save_controller = Y
    
    +++ Runtime Power Management
    Device classes   = all
    Device blacklist = (not configured)
    Driver blacklist = radeon nouveau
    
    /sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000, Host bridge, ivb_uncore)
    /sys/bus/pci/devices/0000:00:01.0/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:02.0/power/control = auto (0x030000, VGA compatible controller, i915)
    /sys/bus/pci/devices/0000:00:14.0/power/control = auto (0x0c0330, USB controller, xhci_hcd)
    /sys/bus/pci/devices/0000:00:16.0/power/control = auto (0x078000, Communication controller, mei_me)
    /sys/bus/pci/devices/0000:00:1a.0/power/control = auto (0x0c0320, USB controller, ehci-pci)
    /sys/bus/pci/devices/0000:00:1b.0/power/control = auto (0x040300, Audio device, snd_hda_intel)
    /sys/bus/pci/devices/0000:00:1c.0/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.3/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.5/power/control = auto (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1d.0/power/control = auto (0x0c0320, USB controller, ehci-pci)
    /sys/bus/pci/devices/0000:00:1f.0/power/control = auto (0x060100, ISA bridge, lpc_ich)
    /sys/bus/pci/devices/0000:00:1f.2/power/control = auto (0x010400, RAID bus controller, ahci)
    /sys/bus/pci/devices/0000:00:1f.3/power/control = auto (0x0c0500, SMBus, i801_smbus)
    /sys/bus/pci/devices/0000:02:00.0/power/control = auto (0x030000, VGA compatible controller, radeon)
    /sys/bus/pci/devices/0000:07:00.0/power/control = auto (0x028000, Network controller, wl)
    /sys/bus/pci/devices/0000:09:00.0/power/control = auto (0x020000, Ethernet controller, alx)
    
    +++ USB
    Autosuspend        = enabled
    Device whitelist   = (not configured)
    Device blacklist   = (not configured)
    WWAN blacklist     = enabled
    
    Bus 002 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =     0 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    Bus 001 Device 005 ID 1bcf:2982 control = auto, autosuspend_delay_ms =  2000 -- Sunplus Innovation Technology Inc.  (uvcvideo)
    Bus 001 Device 004 ID 0a5c:21d7 control = auto, autosuspend_delay_ms =  2000 -- Broadcom Corp. BCM43142 Bluetooth 4.0 (btusb)
    Bus 001 Device 003 ID 0bda:0129 control = auto, autosuspend_delay_ms =  2000 -- Realtek Semiconductor Corp. RTS5129 Card Reader Controller (rtsx_usb)
    Bus 001 Device 002 ID 8087:0024 control = auto, autosuspend_delay_ms =     0 -- Intel Corp. Integrated Rate Matching Hub (hub)
    Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    Bus 004 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
    Bus 003 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    
    +++ Battery Status
    /sys/class/power_supply/BAT0/manufacturer                   = SMP-SDI2.0
    /sys/class/power_supply/BAT0/model_name                     = DELL 8JVDG27
    /sys/class/power_supply/BAT0/cycle_count                    = (not supported)
    /sys/class/power_supply/BAT0/charge_full_design             =   4000 [mAh]
    /sys/class/power_supply/BAT0/charge_full                    =   3248 [mAh]
    /sys/class/power_supply/BAT0/charge_now                     =   1745 [mAh]
    /sys/class/power_supply/BAT0/current_now                    =    886 [mA]
    /sys/class/power_supply/BAT0/status                         = Discharging
    
    Charge                                                      =   53.7 [%]
    Capacity                                                    =   81.2 [%]
    
    
    

    Autodidacta en la VIDA …y en Linux, también.

  • I installed tlp. It still does not detect battery on start up.

    Here is the output it gave me.

    --- TLP 0.9 --------------------------------------------
    
    +++ Configured Settings: /etc/default/tlp
    TLP_ENABLE=1
    TLP_DEFAULT_MODE=AC
    DISK_IDLE_SECS_ON_AC=0
    DISK_IDLE_SECS_ON_BAT=2
    MAX_LOST_WORK_SECS_ON_AC=15
    MAX_LOST_WORK_SECS_ON_BAT=60
    SCHED_POWERSAVE_ON_AC=0
    SCHED_POWERSAVE_ON_BAT=1
    NMI_WATCHDOG=0
    ENERGY_PERF_POLICY_ON_AC=performance
    ENERGY_PERF_POLICY_ON_BAT=powersave
    DISK_DEVICES="sda sdb"
    DISK_APM_LEVEL_ON_AC="254 254"
    DISK_APM_LEVEL_ON_BAT="128 128"
    SATA_LINKPWR_ON_AC=max_performance
    SATA_LINKPWR_ON_BAT=min_power
    AHCI_RUNTIME_PM_TIMEOUT=15
    PCIE_ASPM_ON_AC=performance
    PCIE_ASPM_ON_BAT=powersave
    RADEON_POWER_PROFILE_ON_AC=high
    RADEON_POWER_PROFILE_ON_BAT=low
    RADEON_DPM_STATE_ON_AC=performance
    RADEON_DPM_STATE_ON_BAT=battery
    RADEON_DPM_PERF_LEVEL_ON_AC=auto
    RADEON_DPM_PERF_LEVEL_ON_BAT=auto
    WIFI_PWR_ON_AC=off
    WIFI_PWR_ON_BAT=on
    WOL_DISABLE=Y
    SOUND_POWER_SAVE_ON_AC=0
    SOUND_POWER_SAVE_ON_BAT=1
    SOUND_POWER_SAVE_CONTROLLER=Y
    BAY_POWEROFF_ON_BAT=0
    BAY_DEVICE="sr0"
    RUNTIME_PM_ON_AC=on
    RUNTIME_PM_ON_BAT=auto
    RUNTIME_PM_ALL=1
    RUNTIME_PM_DRIVER_BLACKLIST="radeon nouveau"
    USB_AUTOSUSPEND=1
    USB_BLACKLIST_WWAN=1
    RESTORE_DEVICE_STATE_ON_STARTUP=0
    
    +++ System Info
    System         = Dell Inc.          Inspiron 7737
    BIOS           = A08
    Release        = "Arch Linux"
    Kernel         = 4.9.8-1-ARCH #1 SMP PREEMPT Mon Feb 6 12:59:40 CET 2017 x86_64
    /proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=801ac914-5775-411b-ace7-24dce2239c5b rw quiet resume=UUID=73a08416-d0a2-4650-bd7d-189847a7b616 acpi_osi=Linux acpi_rev_override
    Init system    = systemd 
    Boot mode      = UEFI
    
    +++ TLP Status
    State          = enabled
    Last run       = 03:46:49 PM,    124 sec(s) ago
    Mode           = AC
    Power source   = unknown
    
    Notice: tlp.service is not enabled -- invoke "systemctl enable tlp.service" to correct this!
    Notice: tlp-sleep.service is not enabled -- invoke "systemctl enable tlp-sleep.service" to correct this!
    Notice: systemd-rfkill.service is not masked -- invoke "systemctl mask systemd-rfkill.service" to correct this!
    
    +++ Processor
    CPU model      = Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz
    
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  3100000 [kHz]
    
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  3100000 [kHz]
    
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  3100000 [kHz]
    
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   800000 [kHz]
    /sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  3100000 [kHz]
    
    /sys/devices/system/cpu/intel_pstate/min_perf_pct      = 25
    /sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100
    /sys/devices/system/cpu/intel_pstate/no_turbo          = 0
    /sys/devices/system/cpu/intel_pstate/turbo_pct         = 50
    /sys/devices/system/cpu/intel_pstate/num_pstates       = 24
    
    x86_energy_perf_policy: program not installed.
    
    /proc/sys/kernel/nmi_watchdog                          = 0
    
    +++ Undervolting
    PHC kernel not available.
    
    +++ Temperatures
    CPU temp               =    47 [°C]
    Fan speed (fan1)       =  2527 [/min]
    
    +++ File System
    /proc/sys/vm/laptop_mode               =     0
    /proc/sys/vm/dirty_writeback_centisecs =  1500
    /proc/sys/vm/dirty_expire_centisecs    =  1500
    /proc/sys/vm/dirty_ratio               =    20
    /proc/sys/vm/dirty_background_ratio    =    10
    /proc/sys/fs/xfs/age_buffer_centisecs  = (not available)
    /proc/sys/fs/xfs/xfssyncd_centisecs    = (not available)
    /proc/sys/fs/xfs/xfsbufd_centisecs     = (not available)
    
    +++ Storage Devices
    /dev/sda:
      Model     = ST1000LM014-1EJ164                      
      Firmware  = DEM8    
      APM Level = 254
      Status    = active/idle
      Scheduler = cfq
    
      Runtime PM: control = on, autosuspend_delay =   -1
    
    
    +++ SATA Aggressive Link Power Management
    /sys/class/scsi_host/host0/link_power_management_policy  = max_performance
    /sys/class/scsi_host/host1/link_power_management_policy  = max_performance
    /sys/class/scsi_host/host2/link_power_management_policy  = max_performance
    /sys/class/scsi_host/host3/link_power_management_policy  = max_performance
    
    +++ AHCI Host Controller Runtime Power Management
    /sys/bus/pci/devices/0000:00:1f.2/ata1/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata2/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata3/power/control = on
    /sys/bus/pci/devices/0000:00:1f.2/ata4/power/control = on
    
    +++ PCIe Active State Power Management
    /sys/module/pcie_aspm/parameters/policy = default (using bios preferences)
    
    +++ Intel Graphics
    /sys/module/i915/parameters/powersave        = (not available)
    /sys/module/i915/parameters/enable_rc6       =  1 (enabled)
    /sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
    /sys/module/i915/parameters/enable_fbc       =  0 (disabled)
    /sys/module/i915/parameters/enable_psr       =  0 (disabled)
    /sys/module/i915/parameters/lvds_downclock   = (not available)
    /sys/module/i915/parameters/modeset          =  1 (enabled)
    /sys/module/i915/parameters/semaphores       =  1 (enabled)
    
    +++ Wireless
    bluetooth = on
    wifi      = on
    wwan      = none (no device)
    
    hci0(btusb)                   : bluetooth, not connected
    wlp2s0(iwlwifi)               : wifi, connected, power management = off
    
    +++ Audio
    /sys/module/snd_hda_intel/parameters/power_save            = 0
    /sys/module/snd_hda_intel/parameters/power_save_controller = N
    
    +++ Runtime Power Management
    Device classes   = all
    Device blacklist = (not configured)
    Driver blacklist = radeon nouveau
    
    /sys/bus/pci/devices/0000:00:00.0/power/control = on   (0x060000, Host bridge, hsw_uncore)
    /sys/bus/pci/devices/0000:00:02.0/power/control = on   (0x030000, VGA compatible controller, i915)
    /sys/bus/pci/devices/0000:00:03.0/power/control = on   (0x040300, Audio device, snd_hda_intel)
    /sys/bus/pci/devices/0000:00:14.0/power/control = on   (0x0c0330, USB controller, xhci_hcd)
    /sys/bus/pci/devices/0000:00:16.0/power/control = on   (0x078000, Communication controller, mei_me)
    /sys/bus/pci/devices/0000:00:1b.0/power/control = on   (0x040300, Audio device, snd_hda_intel)
    /sys/bus/pci/devices/0000:00:1c.0/power/control = on   (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.2/power/control = on   (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.3/power/control = on   (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1c.4/power/control = on   (0x060400, PCI bridge, pcieport)
    /sys/bus/pci/devices/0000:00:1d.0/power/control = on   (0x0c0320, USB controller, ehci-pci)
    /sys/bus/pci/devices/0000:00:1f.0/power/control = on   (0x060100, ISA bridge, lpc_ich)
    /sys/bus/pci/devices/0000:00:1f.2/power/control = on   (0x010601, SATA controller, ahci)
    /sys/bus/pci/devices/0000:00:1f.3/power/control = on   (0x0c0500, SMBus, i801_smbus)
    /sys/bus/pci/devices/0000:02:00.0/power/control = on   (0x028000, Network controller, iwlwifi)
    /sys/bus/pci/devices/0000:03:00.0/power/control = on   (0xff0000, Unassigned class [ff00], rtsx_pci)
    /sys/bus/pci/devices/0000:03:00.1/power/control = on   (0x020000, Ethernet controller, r8169)
    /sys/bus/pci/devices/0000:04:00.0/power/control = auto (0x030200, 3D controller, nouveau)
    
    +++ USB
    Autosuspend        = enabled
    Device whitelist   = (not configured)
    Device blacklist   = (not configured)
    WWAN blacklist     = enabled
    
    Bus 001 Device 002 ID 8087:8000 control = auto, autosuspend_delay_ms =     0 -- Intel Corp.  (hub)
    Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    Bus 003 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
    Bus 002 Device 004 ID 04f3:020b control = on,   autosuspend_delay_ms =  2000 -- Elan Microelectronics Corp.  (usbhid)
    Bus 002 Device 003 ID 8087:07dc control = auto, autosuspend_delay_ms =  2000 -- Intel Corp.  (btusb)
    Bus 002 Device 002 ID 0c45:6a00 control = auto, autosuspend_delay_ms =  2000 -- Microdia  (uvcvideo)
    Bus 002 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)
    
    +++ Battery Status
    No batteries detected.
    
    +++ Suggestions
    * Install ethtool to disable Wake On LAN (WOL)
    * Install smartmontools for disk drive health info
    
    
  • Here are the results for those commands.

    acpi -ib

    Nothing. It returns nothing.

    acpitool -B

      Battery status : <not available>
    
    

    upower -i /org/freedesktop/UPower.devices/battery_BAT1

    failed to set path: Object path invalid: /org/freedesktop/UPower.devices/battery_BAT1
    
    

    Same goes for BAT0.

  • You executed the commands as root ?

    Installed acpitool?

    Autodidacta en la VIDA …y en Linux, también.

  • I did all of that.

    Here’s this if it helps any.

    upower -e

    /org/freedesktop/UPower/devices/line_power_AC
    /org/freedesktop/UPower/devices/DisplayDevice
    
    
  • https://ubuntuforums.org/showthread.php?t=2308941

    Autodidacta en la VIDA …y en Linux, también.

  • https://bugzilla.kernel.org/show_bug.cgi?id=105721

    Autodidacta en la VIDA …y en Linux, también.

  • So, I believe that last one should work, but I just want to make sure of something before I go much further in depth with this.

    Is it asking me to recompile my kernel with CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y as a parameter? If yes, is https://wiki.archlinux.org/index.php/Kernels/Traditional_compilation a good source for learning how to do that?

detected7 battery15 Posts 18Views 1032
Log in to reply