• Like 0

    Problem with cifs transfers


    Hi all.
    I have antergos installed with two DE, Xfce and Gnome.
    The thing is… when I mount a samba share with sudo mount -t cifs… the connection is made ok, and I can rename, read or delete files from my nas, but if I try to copy something from my nas to my pc over thunar or nautilus, the progress bar doesn’t… progress. CPU usage and cooling fan speed starts to increase but the copy is not done.

    If I copy files using terminal, there is no problem, works, they fail only using file managers.
    And if I use gvfs (smb:// from thunar) works too.
    In another partition on my pc with xubuntu installed, cifs connections works like a charm over terminal or thunar using the same mounting parameters.

    Can someone help me? It’s a very strange issue and i don’t know where to start…

  • Like 0

    @allsts

    Which options do you use when mounting the shared folder?

    You can try to run thunar from a terminal and see if any messages are shown when you try to do the copy.

    It’s really strange that it is working when using the terminal but not when using the file manager… ¿?

  • Like 0

    I have new information…
    I restored an image from one week ago and everything works fine using the same mounting script.
    BUT! After install all antergos updates… now fails again!
    So, something is wrong with a package.
    During update a warning message came up saying something about a different permission settings between the system and one package (still dont know witch one), system was 755 and package 700.

    Will try to identify the problematic package and change permissions values.
    Finger cross…

    Thanks for replying!

  • Like 1

    Problem found (more or less), is the last kernel update.
    After install all updates as I said, the problem appears again, but if I boot with the kernel-lts, everything works fine.
    So, I restored again the clonezilla image and update all packages except “linux” and “linux-firmware” packages and can copy without fails.
    Hope this to be solved in future kernel updates.
    Post marked as solved.

thunar6 samba17 cifs3 Posts 4Views 132
Log in to reply