• Video Stuttering


    Hello all,
    I have a weird problem with video playback, ever since i installed Antergos on the current pc.
    My pc consists of AMD FX 6300, nVidia 1050Ti 4GB, 8GB DDR3 RAM, SSD etc.
    Running latest linux kernel, with nvidia drivers, and Gnome DE.

    Every video playback, stutters and skips frames randomly, whether it runs on vlc, smplayer, mpv, mplayer, even in youtube videos. Also at times you can see minor tearing, although that in desktop in general is tear free.
    Under windows os, the same videos playing very smooth.
    In smplayer i have tried all the outputs in video options, (vdpau, xv etc) but the result is all around the same.
    This is very distressing because after a while, with all this stuttering you get a feeling of dizziness.
    Does anyone have an idea of what should be done to improve video playback?

  • @cacciatore

    -Do you have any error message in dmesg or journalctl during playback?
    (Also starting programs from terminal can give some outputs)
    -What screen resolution and do you have any “special” config for xorg?
    -Do you have any temperature monitoring installed?
    (If not you must install lm_sensors then run the sensors setup in a terminal sudo sensors-detect and then install a gnome extension called freon and configure as you wish)
    -And last not least, can you check your cpu load during playback and if playback program is having strange behavior like locking 100% in one core?
    (Gnome System Monitor is probably the easiest one)

  • I have none error messages, during playback.
    My cpu load is 12% max and 7-9% average across all cores.
    Temperatures never exceeds 33C ether cpu or vga
    My screen reolution is at 1920x1200 @ 59Hz
    Forget to mention that i dont have any special config for xorg.

  • @cacciatore

    Well, very strange because our machines is little bit similar… Maybe Xorg default config is not enough… You can try the same as my settings if you wish.

    Run sudo nvidia-xconfig to create a xorg.conf (will be created one in /etc/X11) then according the sections add the options below:

    Section "Device"
        Option         "RegistryDwords" "PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
        Option         "TripleBuffer" "True"
    EndSection
    
    Section "Screen"
        Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    EndSection
    

    On device section the first option line sets to use always “Maximum Performance” and the second sets to always on the openGL triple buffer; On screen section the option line sets to force composition pipeline always on which affects how vsync will refresh.

  • @Edwin Foss
    Ok, i wil try this and report back
    Thank you for your time assisting me.

  • Unfortunatelly this hadn’t worked for me.
    I am confident that this is gnome related somehow, and maybe have to do with its window manager.

    Could you take a test in your system?
    Open up Files file-manager in window mode. Nothing else in the desktop, only Files.
    Now , grub this window an move it in a circular way on your screen.
    Does it jump from time to time from one location to another as you perform this circular movement?
    Mine does it. It begins moving smooth but when you make this movement occasionally jumps from one posotion to another. Thats exactly the sort of thing thats been experienced also in video playback.
    I dont know how to describe it most accurate, maybe a video would help.

  • @cacciatore

    Mine has a very, very, little stuttering but not refresh desynchronization as happening to you, mine is because nvidia driver’s fault, in nouveau with wayland it doesn’t happen but I cannot play games in nouveau because of too low fps, does glxgears have high fps oscillation?
    Can you post the outputs from the commands below?
    glxinfo | grep OpenGL
    lspci -vnn | grep VGA -A 12
    glxinfo | grep 'direct rendering'

  • glxgears
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    303 frames in 5.0 seconds = 60.416 FPS
    299 frames in 5.0 seconds = 59.751 FPS
    299 frames in 5.0 seconds = 59.756 FPS
    298 frames in 5.0 seconds = 59.552 FPS
    300 frames in 5.0 seconds = 59.956 FPS
    299 frames in 5.0 seconds = 59.753 FPS
    300 frames in 5.0 seconds = 59.951 FPS
    
    
    glxinfo | grep OpenGL
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce GTX 1050 Ti/PCIe/SSE2
    OpenGL core profile version string: 4.5.0 NVIDIA 375.26
    OpenGL core profile shading language version string: 4.50 NVIDIA
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    OpenGL core profile extensions:
    OpenGL version string: 4.5.0 NVIDIA 375.26
    OpenGL shading language version string: 4.50 NVIDIA
    OpenGL context flags: (none)
    OpenGL profile mask: (none)
    OpenGL extensions:
    OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 375.26
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
    OpenGL ES profile extensions:
    
    
    lspci -vnn | grep VGA -A 12
    	Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64, NUMA node 0
    	Bus: primary=00, secondary=05, subordinate=05, sec-latency=64
    	I/O behind bridge: 0000c000-0000cfff
    	Memory behind bridge: fe100000-fe1fffff
    
    00:14.5 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller [1002:4399] (prog-if 10 [OHCI])
    	Subsystem: Gigabyte Technology Co., Ltd Device [1458:5004]
    	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18, NUMA node 0
    	Memory at fe406000 (32-bit, non-prefetchable) [size=4K]
    	Kernel driver in use: ohci-pci
    	Kernel modules: ohci_pci
    
    00:16.0 USB controller [0c03]: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller [1002:4397] (prog-if 10 [OHCI])
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82] (rev a1) (prog-if 00 [VGA controller])
    	Subsystem: NVIDIA Corporation GP107 [GeForce GTX 1050 Ti] [10de:1c82]
    	Flags: bus master, fast devsel, latency 0, IRQ 37, NUMA node 0
    	Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
    	Memory at c0000000 (64-bit, prefetchable) [size=256M]
    	Memory at d0000000 (64-bit, prefetchable) [size=32M]
    	I/O ports at e000 [size=128]
    	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    	Capabilities: <access denied>
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia_drm, nvidia
    
    01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:0fb9] (rev a1)
    
    
     glxinfo | grep 'direct rendering'
    direct rendering: Yes
    
    
  • @cacciatore

    Your outputs is totally fine :relieved:

    I did some tests here and I noticed that nouveau run without lag, stutter and tearing, I’m starting to think that is a nvidia’s driver problem, can you test if also happens in installation bootable media? (the easiest way to test nouveau without change your installation :blush: )

    ps: I found something similar here https://devtalk.nvidia.com/default/topic/860367/linux/window-drag-lag-with-geforce-gtx-750-cinnamon-gnome-unity/ and CLUTTER_VBLANK=none in /etc/environment combined with my xorg.conf solves my little lagging.

stuttering1 video16 Posts 9Views 707
Log in to reply