• How to remove driver nouveau?


    Hi, I’ve been reading and looking for information for many hours but I have not found anything.

    I installed bumbleed on my laptop and it works perfect. I have uninstalled the nouveau drivers but when I run inxi they appear to me.

    $ Inxi -Gxx
    Graphics: Card-1: Intel HD Graphics 520 bus-ID: 00: 02.0 chip-ID: 8086: 1916
                      Card-2: NVIDIA GK208M [GeForce 920M]
                      Bus-ID: 01: 00.0 chip-ID: 10de: 1299
                      Display Server: X.Org 1.19.1 drivers: nouveau, intel (unloaded: modesetting, fbdev, vesa)
                     Resolution: [email protected]
                    GLX Renderer: DRI Intel HD Graphics Table 520 (Skylake GT2)
                   GLX Version: 3.0 Table 13.0.4 Direct Rendering: Yes
    

    In the file /etc/mkinitcpio.conf I do not have the module nouvea.

    I have changed in the file /etc/modprobe.d/nouveau.conf and I have set modeset = 0

    I’ve also rerun sudo mkinitcpio -p linux and sudo grub-mkconfig -o /boot/grub/grub.cfg

    The nouveau driver is not loaded but it still appears to me when running inxi -Gxx

    How can I remove it?
    Thanks

  • It looks rather unusual. Without xf86-video-nouveau, inxi doesn’t mention nouveau here.

    Running on Intel GPU:

    ┌──[just]@[alexarm]:~$
    └─> inxi -Gxxc0
    Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:0126
               Card-2: NVIDIA GF106M [GeForce GT 555M] bus-ID: 01:00.0 chip-ID: 10de:0dcd
               Display Server: X.Org 1.19.1 drivers: intel (unloaded: modesetting) Resolution: [email protected]
               GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 13.0.4 Direct Rendering: Yes
    ┌──[just]@[alexarm]:~$
    └─>
    

    Running on Nvidia GPU:

    ┌──[just]@[alexarm]:~$
    └─> optirun inxi -Gxxc0
    Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:0126
               Card-2: NVIDIA GF106M [GeForce GT 555M] bus-ID: 01:00.0 chip-ID: 10de:0dcd
               Display Server: X.Org 1.19.1 drivers: intel (unloaded: modesetting) Resolution: [email protected]
               GLX Renderer: GeForce GT 555M/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
    ┌──[just]@[alexarm]:~$
    └─>
    
  • Thanks for answering.
    I do not understand it either,

    $ pacman -Qi xf86-video-nouveau
    error: el paquete «xf86-video-nouveau» no se ha encontrado
    
  • @trasgo @trasgo Yes, it means that xf86-video-nouveau package is not installed.

    Nevertheless, try to boot with one more parameter, leaving all others unchanged:

    modprobe.blacklist=nouveau
    

    It doesn’t harm in any case, even if nouveau is not present. I always add it to Grub on all Optimus computers, to get rid of nouveau nightmare and forget it forever.

  • @trasgo

    As far as I know the nouveau driver is inside the kernel (Linux) if I recall correctly they merged since 2012, the package xf86-video-nouveau it’s only a “translation layer” to work with Xserver.

    You still can blacklist nouveau if isn’t already done.

    Anyway you can test if it’s really working with inxi -Gxxc0 for your intel chip and optirun inxi -Gxxc0 for your nvidia chip as @just posted above.

  • @just @Edwin-Foss
    I have modified the file /etc/default/grub and added GRUB_CMDLINE_LINUX_DEFAULT = "modprobe.blacklist=nouveau quiet"
    I have regenerated GRUB
    Optirun works but loads the nouveau driver

    [[email protected] ~]$ optirun inxi -Gxxc0 
    Graphics:  Card-1: Intel HD Graphics 520 bus-ID: 00:02.0 chip-ID: 8086:1916
               Card-2: NVIDIA GK208M [GeForce 920M]
               bus-ID: 01:00.0 chip-ID: 10de:1299
               Display Server: X.Org 1.19.1 drivers: nouveau,intel (unloaded: modesetting,fbdev,vesa)
               Resolution: [email protected]
               GLX Renderer: GeForce 920M/PCIe/SSE2
               GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
    
  • @trasgo said in How to remove driver nouveau?:

    @just @Edwin-Foss
    I have modified the file /etc/default/grub and added GRUB_CMDLINE_LINUX_DEFAULT = "modprobe.blacklist = nouveau quiet"

    One or more consecutive space(s) are used by Grub as parameter delimiters. There are two spaces in your command - before and after the equal sign. Grub just silently ignores it.

    The correct command line for Grub 2 may be:

    GRUB_CMDLINE_LINUX_DEFAULT = "modprobe.blacklist=nouveau quiet"
    
  • @just said in How to remove driver nouveau?:

    @trasgo said in How to remove driver nouveau?:

    @just @Edwin-Foss
    I have modified the file /etc/default/grub and added GRUB_CMDLINE_LINUX_DEFAULT = "modprobe.blacklist = nouveau quiet"

    One or more consecutive space(s) are used by Grub as parameter delimiters. There are two spaces in your command - before and after the equal sign. Grub just silently ignores it.

    Sorry, it was a mistake to write it
    In the file is well written

  • @trasgo said in How to remove driver nouveau?:


    Sorry, it was a mistake to write it
    In the file is well written

    Could you show the parameters you’re booting Linux with?

    cat /proc/cmdline
    
  • @just said in How to remove driver nouveau?:

    @trasgo said in How to remove driver nouveau?:


    Sorry, it was a mistake to write it
    In the file is well written

    Could you show the parameters you’re booting Linux with?

    cat /proc/cmdline
    

    At the end I have reinstalled from 0, I have added modprobe.blacklist = nouveau in the livecd and in the first boot.
    Then uninstall the nouveau drivers and re-performed the steps above and now if everything is correct.

    $ optirun inxi -Gxxc0 
    Graphics:  Card-1: Intel HD Graphics 520 bus-ID: 00:02.0 chip-ID: 8086:1916
               Card-2: NVIDIA GK208M [GeForce 920M]
               bus-ID: 01:00.0 chip-ID: 10de:1299
               Display Server: X.Org 1.19.1 drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: [email protected]
               GLX Renderer: GeForce 920M/PCIe/SSE2
               GLX Version: 4.5.0 NVIDIA 375.26 Direct Rendering: Yes
    

    Thank you for your help.

  • @trasgo @just

    I prefer to blacklist nouveau with a file in /usr/lib/modprobe.d/ or /etc/modprobe.d/ called nvidia.conf with the line blacklist nouveau as many distros script does.

    Also there is another way to blacklist in grub cmdline which is nouveau.blacklist=1 or nouveau.blacklist=yes, since when they changed I don’t know but looks better and more direct.

  • @Edwin-Foss said in How to remove driver nouveau?:

    @trasgo @just

    I prefer to blacklist nouveau with a file in /usr/lib/modprobe.d/ or /etc/modprobe.d/ called nvidia.conf with the line blacklist nouveau as many distros script does.

    Yes, this is perfectly correct.

    Also there is another way to blacklist in grub cmdline which is nouveau.blacklist=1 or nouveau.blacklist=yes, since when they changed I don’t know but looks better and more direct.

    This is correct too. Linux allows to get the same result in many different ways.

  • @trasgo said in How to remove driver nouveau?:

    …now if everything is correct…

    That’s really great - I was installing Antergos once more, to make various clean tests.

    I’ll mark the topic as [Solved], if you agree.

  • Guys, always remember to check /etc/mkinitcpio.conf … in case there is a MODULES="nouveau" there. (I don’t know if this was the op problem or not, but it’s always wise to check it).

    Cheers!

  • Thanks for the help and advice, it was already marked as solved, thank you.

driver51 remove20 nouveau15 Posts 15Views 3161
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.