• Windows boot entry disappeared after Antergos installation (Dual Boot)


    Good morning guys,

    I have the following issue:

    i had a working dual boot system with Windows 10 64bit and Ubuntu 16.04 LTS. However I wanted to switch over to an Arch based system and Antergos seemed to be a very pleasant choice. After the Installation I’m not able to boot into my Windows partition anymore, I even can’t see the Windows boot entry in Grub anymore. I am also very new in the Linux world, that was a reason for me to choose Antergos, because it ships with an graphical installer.

    It looks like i have overwritten the windows boot loader section. Is there a way to fix this?

    Here is the output of # fdisk -l /dev/sda:

    0_1486369031387_DeepinScreenshot20170206091654.png

    I hope someone can help me with this issue.

    Best regards,

    Rob

  • try first:

    sudo os-prober
    
  • Hey Joe,

    thanks for your reply, but sadly, sudo os-prober doesn’t fix it.

    There is still no entry in the grub.cfg file. Maybe the partitioning table helps for the troubleshoot:

    0_1486377359953_DeepinScreenshot20170206113354.png

  • What is the output of:

    sudo os-prober
    

    It is not the fix, it only shows info…

  • Sorry, my fault.

    There is no output of the command.

  • Usually Windows entry will be added automaticly… But as os-prober does not find your Windows system…
    I never install to a efi boot system…

    You can get more info here: https://wiki.archlinux.org/index.php/GRUB#Windows_installed_in_UEFI-GPT_Mode_menu_entry

  • This topic is relevant to my interests. I have a similar setup on one of my laptops. It dualboots Elementary OS Loki(based on Ubuntu 16.04) and Win7 and I’m considering replacing eOS with Antergos instead.

    I hope someone helps you out OP then maybe I’ll be able to learn from it and do my installation without a problem.

  • https://forum.antergos.com/topic/5767/second-installation-on-other-partition-kernel-not-loaded

    Is interesting on your problems…

    Seems like efibootmgr is not included in last installation iso…

    so
    @Rob try to install it:

    yaourt -S efibootmgr
    

    then:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    sudo grub-install /dev/sda
    
  • I installed efibootmgr, but grub still doesn’t detect the Windows system.

    Meanwhile I also tried to add the menuentry manually via the /etc/grub.d/40_custom.

    Now I obviously have the boot menu entry for Windows, but it doesn’t boot.

    The entry is:

    menuentry 'Windows 10 64-bit' {
    set root = ’(hd0, msdos3)’
    chainloader +1
    }
    

    referring to the partition table I posted before, where WIndows is on dev/sda3.

  • Foor Uefi Boot you need to use entry like this from the WIKI:

    if [ "${grub_platform}" == "efi" ]; then
    	menuentry "Windows 10 64-bit UEFI-GPT" {
    		insmod part_gpt
    		insmod fat
    		insmod search_fs_uuid
    		insmod chain
    		search --fs-uuid --set=root $hints_string $fs_uuid
    		chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    	}
    fi
    

    Here is a more easy Tip:

    http://unix.stackexchange.com/questions/49165/can-grub2-share-the-efi-system-partition-with-windows

    So Windows Entry do not need the root-dir because /EFI/Microsoft/Boot/bootmgfw.efi have the entry inside…

    He say also you need to use:
    check if this file (bootmgfw.efi) is on this place inside EFI Partition, you will need to

    mount /dev/sda1 /boot
    

    and then

    grub-probe --target=hints_string /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi
    

    to show the needed parameters that should be added inside the grub entry after:

    search --fs-uuid --no-floppy --set=root <**insert ouput from grub-probe here**>
    
  • Okay, I fixed it.

    Because I have a full backup of both systems, I simply reinstalled them because this may was the faster approach.

    I think I mixed up something with MBR and GPT during the partition process from my Windows System and then it somehow broke when I tried to set my /boot/efi to sda1.

    Thanks for the fast reply :)

grub226 dual boot23 windows 1011 boot loader8 Posts 11Views 3499
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.