• Problem installing HP 2540

    Hi, I’m having problems to install my hp 2540 (wireless) , i got this error
    [http://pix.toile-libre.org/upload/original/1486244445.png](link url)
    Now the printer manager ask for user and password (it didn’t before, i guess it was updated), after typing the login the error happen.
    Any Idea how to fixt it? (It was happening before reinstalling the OS and is happening now as well)

    EDIT: i tried the following commands:

    [[email protected] ~]$ sudo systemctl enable cups.service
    Failed to enable unit: File cups.service: No such file or directory
    [[email protected] ~]$ systemctl enable cups.service
    Failed to enable unit: File cups.service: No such file or directory

    systemctl enable org.cups.cupsd.service doesn’t show errors but the system can’t load still…


  • Through http://localhost:631 it’s possible to add the printer, but the printer show as disconnected and doesn’t print.

  • i read that for HP-wireless-Printer you need to plug in USB while installing.

  • @joekamprad but i never needed before…
    BUT i had a malfuntioning printer connected to USB while installing the 2540 printer through wireless. Pretty weird if that made me install properly the other printer. I’ll have to go downstairs to pick it up hehehe.
    I’ll give it a try…

  • @joekamprad don’t you think the problem is cups services looking for the terminal messages above?

  • systemctl start org.cups.cupsd.service
    systemctl status org.cups.cupsd.service

    could give what you need.

    For HP-Printer it is the best to try using

    sudo hp-setup -i
  • And yes your first error inside the posted picture is caus cups is not running…

  • @joekamprad
    Hi! I just tested on my notebook, and i have the very same error!!!
    I searched all files on my pc and cups.service doesn’t exist…
    I guess i’ll need to manually create the cups.service file, just don’t know how to do it exactly…

  • Do you choose cups service inside the cnchi installer?

    pacman -Qs cups

    Cups server systemd is surely


    For network printer you need avahi also:

    sudo systemctl enable avahi-daemon.service
    sudo systemctl start avahi-daemon.service
  • @joekamprad I’m almost giving up…
    Yes, i installed all the packages Antergos offered, here is the output from pacman -Qs cups

    [[email protected] ~]$ pacman -Qs cups`
    local/cups 2.2.2-2`
        The CUPS Printing System - daemon package`
    local/cups-filters 1.13.3-1`
        OpenPrinting CUPS Filters`
    local/cups-pk-helper 0.2.6-1`
        A helper that makes system-config-printer use PolicyKit`
    local/lib32-libcups 2.2.1-1`
        The CUPS Printing System - client libraries (32-bit)`
    local/libcups 2.2.2-2`
        The CUPS Printing System - client libraries and headers`
    local/python-pycups 1.9.73-3`
        Python 3 CUPS Bindings`
    local/splix 2.0.0-13`
        CUPS drivers for SPL (Samsung Printer Language) printers`
    local/system-config-printer 1.5.9-2`
        A CUPS printer configuration tool and status applet

    I typed your other commands but always the same error…

  • ╭─[email protected] ~  
    ╰─➤  locate org.cups.cupsd.service

    may reinstall cups solve the failure?
    what is the output of:

    sudo systemctl status org.cups.cupsd.service


  • Hi,

    As @joekamprad said, cups.service has been renamed to org.cups.cupsd.service , so that’s what you have to use when running systemctl commands.

    Anyways, check that you have installed:

    hplip (for hp printers)
    system-config-printer (gtk)
    print-manager (qt)
    splix (for samsung printers)

    Choose either system-config-printer or print-manager.

    You can check your cups in /var/log/cups (if I recall correctly)

    Try again after installed those packages. Oh, enable and start org.cups.cupsd.service, too!

    P.S. Check that CUPS is started running systemctl status org.cups.cupsd.service

  • @karasu i reinstalled the packages.

    the systemctl status org.cups.cupsd.service log [http://pastebin.com/att9UEwW](link url)

    The /var/log/cups log [http://pastebin.com/8sqTdXfa](link url)

    I’m too newbie… Is it possible that some update changed some file permission?

  • Hi,

    I don’t really know what’s wrong. You could try to change the loglevel to debug in /etc/cups.conf (or it is /etc/cups/cups.conf, I don’t remember it).

  • Cannot connect to remote printer ipp://HPC4346B2ECF07.local:631/ipp/print

    this ipp uri is from system-config-printer or hp-setup?

  • @joekamprad said in Problem installing HP 2540:



  • try to install with:

    sudo hp-setup -i

    seems like uri is not correct for remote printer

  • @joekamprad said in Problem installing HP 2540:

    sudo hp-setup -i

    It gives me the error error: No device selected/specified or that supports this functionality.

    Well, i managed to install linux Mint in a virtual machine and added the printer in 30 seconds (like it was before the bug). It’s a temporary solution for me, sharing the folders betwen real and virtual machine for now…
    I guess it’s a cups bug, not Antergos.
    I’ll leave the thread unsolved and wait for some cups update.

  • to set ‘LogLevel’ to debugging change the line inside /etc/cups/cupsd.conf to:

    LogLevel debug

    and restart cups

  • @joekamprad the log is huge, what should i look for?
    here is the link for google drive, since pastebin can’t manage the size.
    [https://drive.google.com/open?id=0B38Ns2uFCfnEbGlsblFaRHIxd1U](link url)

installing122 25401 Posts 24Views 5837
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.