• Time clock can't be changed


    Hi, i just reinstalled my system and my clock is set with the wrong time.
    I tried to change on different DEs but none of them managed to fix the time clock.
    I tried as well to set the time into the BIOS, but when booting Antergos displayed a message something like “the time is wrong” and when i finally reached the GUI insterface the clock was wrong again.

    Any idea how to fix this?
    Thanks!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • Please post the output of “timedatectl”

  • @pipep
    [[email protected] ~]$ timedatectl
    Local time: sáb 2017-02-04 12:43:51 UTC
    Universal time: sáb 2017-02-04 12:43:51 UTC
    RTC time: sáb 2017-02-04 12:43:51
    Time zone: UTC (UTC, +0000)
    Network time on: yes
    NTP synchronized: yes
    RTC in local TZ: no

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • hwclock is only in the AUR repos?
    EDIT: the message at boot is something like:
    Superblock mount time is in the future

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • you already have iut no need to install…

    sudo hwclock --adjust
    

    may see more here:

    sudo hwclock --debug
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • I too installed Antergos recently and faced this problem, all I did was change my timezone from UTC to my zone by using timedatectl --set-timezone xxx/xxxx and then hwclock --systohc --localtime

    May not be an elegant solution, but will work fine.

  • @joekamprad said in Time clock can't be changed:

    sudo hwclock --adjust

    [[email protected] ~]$ sudo hwclock --adjust
    Needed adjustment is less than one second, so not setting clock.

    But it’s wrong, the system is displaying two hours ahead the normal…
    I’ll check for other options and get back to you…

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @vin_tux said in Time clock can't be changed:

    timedatectl --set-timezone

    [[email protected] ~]$ sudo timedatectl set-time "2017-02-04 17:06:00"
    Failed to set time: Automatic time synchronization is enabled

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto

    No, I meant do

     sudo timedatectl --list-timezone
    

    Now note down your timezone, for example Europe/Berlin

    Now use

    sudo timedatectl --set-timezone Europe/Berlin
    
    

    Now do

    sudo hwclock --systohc --localtime
    
    

    It worked for me. But I dunno what will happen once I go to other timezone.

  • @vin_tux said in Time clock can't be changed:

    sudo timedatectl --list-timezone

    [[email protected] ~]$ sudo timedatectl --list-timezone
    [sudo] password for fernando:
    timedatectl: unrecognized option '--list-timezone'

    Ok, i found the commands, IT TOOK SOME TIME TO UPDATE

    sudo timedatectl list-timezones
    sudo timedatectl set-timezone America/Sao_Paulo
    sudo hwclock --systohc --localtime

    Thank you very much!!!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • sudo timedatectl list-timezones
    

    missing

    s
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @fernandomaroto

    Sorry, command is

    timedatectl list-timezone
    timedatectl set-timezone time_zone
    sudo hwclock --systohc --localtime
    
  • Yeah thanks, i checked on man timedatectl took some time for the system update, finally i fixed one bug hehehehe.
    It’s the first time this happened to me, i’m not sure if the new kernel bug… (i have problem with printer, time, and middle click emulation). Since it’s a fresh installation i’m sure i didn’t messed my pc.

    Thanks again @vin_tux and @joekamprad!!
    Cheers!

    Antergos (default OS) - WIN10 (abandoned)
    I3wm - Mate desktop
    AMD - A4 7300 Radeon graphics
    16 GB ram
    HD 1 TB
    Linux newbie since 06/2016

  • @fernandomaroto

    No problem. Glad that it worked out for you. I didn’t face many problems, may be because I don’t have a printer or use middle mouse button. Well post a new question regarding that, someone might have solution for that too.

    Cheers.

  • @fernandomaroto said in Time clock can't be changed:

    @vin_tux said in Time clock can't be changed:

    sudo timedatectl --list-timezone

    [[email protected] ~]$ sudo timedatectl --list-timezone
    [sudo] password for fernando:
    timedatectl: unrecognized option '--list-timezone'

    Ok, i found the commands, IT TOOK SOME TIME TO UPDATE

    sudo timedatectl list-timezones
    sudo timedatectl set-timezone America/Sao_Paulo
    sudo hwclock --systohc --localtime

    Thank you very much!!!

    There’s an extra step you need to sync the rtc clock with utc – not your local time. Confirm first by reading out

    timedatectl
    

    If you’re affected, the code is

    sudo timedatectl set-local-rtc 0
    

    See here.

clock5 changed2 Posts 16Views 1312
Log in to reply