• Like 0

    Nvidia-installer package broke my whole OS


    After installing and running this command I can’t boot no more. When that green “OK” text finishes on boot it start to flash and even tty when I try to access it it flashes. I can’t boot.

    How do I fix this?

  • Like 0

    @matjaz132 said in Nvidia-installer package broke my whole OS:

    that green “OK” text finishes on boot

    what do you mean by this???

    how do you install and run nvidia-installer package?

    flashing tty means that lightdm/gdm is failing to start i got this also sometimes on playing around…
    You can try to start without x :

    On booting when Grub is showing up press “e” to edit grublines:
    search for rw quiet and put a " 1" after this:
    Bild Text
    system will start in rescue mode without x.
    you need to put in your password.
    then you can install/investigate…
    if you have lightdm installed try:

    pacman -S gdm
    systemctl disable lightdm
    systemctl enable gdm
    systemctl reboot
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    Well you know, that text which show if you don’t run quiet command on grub. After this the cursor on the bottom starts to flash and even if I enter TTY it start to flashes this the same text and the TTY text. TTY is unusable.

    Do you know how do I revert this issue with nvidia-installer package?

  • Like 0

    @matjaz132 i just give possible solution upon our post now…

    You can check also if all wents fine by

    cat /etc/mkinitcpio.conf
    

    and check if:
    MODULES="nouveau"
    is there or not…

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    MODULES=“nouveau” is inside that file.

    I think that something went wrong with that command which I run. But I don’t understand what and what it did even do that command. Can you check it out?

  • Like 0

    you can also reinstall nouveau with nvidia-installer package:
    (-n, --nouveau Restores nouveau (open) nvidia driver)

    nvidia-installer -n
    

    will restore to nouveau driver

    or fix it on your own:

    nano /etc/mkinitcpio.conf
    

    erase the nouveau that this line looks like this:

    MODULES=“”
    

    then save the file by pressing Strg+X — y …

    mkinitcpio -p linux
    

    mkinitcpio is a Bash script used to create an initial ramdisk environment and to rebuild it…

    check if nvidia is installed:

    pacman -Qs nvidia
    

    if not install it:

    pacman -S nvida
    
    systemctl reboot
    

    If you are lucky nvidia driver is working then…

    On question to the package nvidia-installer take a look here:
    https://forum.antergos.com/topic/4227/nvidia-installer-alpha/29

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    Thank you really much! It works now.

    When I run mkinitcpio -p linux it said something about fallback that it couldn’t do but nevertheless everything works now. Thank you really much :)!

  • Like 0

    You are welcome ! may it will be interesting for @developers @karasu because he do this package…

    And if you need nvidia-settings gui?
    simple install it:

    yaourt -S nvidia-settings
    

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

  • Like 0

    and mark as solved if you think it is: https://forum.antergos.com/topic/2862/please-mark-solved-threads-as-solved

    el asesino del sentido común.
    Linux since 1988 - overcoming failure means success
    http://kamprad.net/backgrounds/
    http://kamprad.net/howto-installing-antergos/

whole1 broke10 Posts 9Views 276
Log in to reply