• Removing Qt4


    Would it be possible to remove all Qt4 dependencies without wreaking my system. Have not al Qt dependencies been upped to Qt5?

    When running the remove command in terminal I get the following:

    error: failed to prepare transaction (could not satisfy dependencies)
    :: attica-qt4: removing qt4 breaks dependency 'qt4'
    :: fcitx-qt4: removing qt4 breaks dependency 'qt4'
    :: imagewriter: removing qt4 breaks dependency 'qt4'
    :: lib32-qt4: removing qt4 breaks dependency 'qt4'
    :: libdbusmenu-qt4: removing qt4 breaks dependency 'qt4'
    :: libechonest: removing qt4 breaks dependency 'qt4'
    :: libqzeitgeist: removing qt4 breaks dependency 'qt4'
    :: masterpdfeditor: removing qt4 breaks dependency 'qt4'
    :: polkit-qt4: removing qt4 breaks dependency 'qt4'
    :: poppler-qt4: removing qt4 breaks dependency 'qt4'
    :: pyqt4-common: removing qt4 breaks dependency 'qt4'
    :: pyside-tools-common: removing qt4 breaks dependency 'qt4>=4.5'
    :: python2-pyside: removing qt4 breaks dependency 'qt4>=4.8'
    :: python2-shiboken: removing qt4 breaks dependency 'qt4>=4.8'
    :: qca-qt4: removing qt4 breaks dependency 'qt4'
    :: qjson: removing qt4 breaks dependency 'qt4'
    :: qtcurve-qt4: removing qt4 breaks dependency 'qt4'
    :: qtwebkit: removing qt4 breaks dependency 'qt4'
    :: qwt: removing qt4 breaks dependency 'qt4'
    :: scribus: removing qt4 breaks dependency 'qt4'
    :: shiboken: removing qt4 breaks dependency 'qt4'
    :: skype-call-recorder: removing qt4 breaks dependency 'qt4'
    :: soqt: removing qt4 breaks dependency 'qt4'
    

    Never to old to learn.

  • Probably start by removing the imagewriter, masterpdfeditor, scribus & skype-call-recorder
    masterpdfeditor as a qt5 version in AUR
    imagewriter, scribus & skype-call-recorder unfortunately do not have qt5 versions

  • Thanks. I will have a look at it and experiment a little in Vbox before removing anything. Problem with scribus is that I don’t seem to be able to install the 1.5 version(s). I understand that 1.5 is ported to Qt5. The only version I am able to install is Scribus-indigo. Not sure if that would be the choice to go with.

    Never to old to learn.

removing4 qt42 Posts 3Views 303
Log in to reply