• GDM Issues - Missing Panel


    Hey Guys,

    As the subject states, I switched to GDM after the last update broke some things to lightDM. Switching to GDM (from LightDM) and it appears my gnome desktop environment is slightly different. I am missing the pop-out panel menu on the left-hand side:

    Screenshot: https://i.stack.imgur.com/UK3zg.png

    It also appears there are some other minor differences with my gnome environment. Are there other changes behind the scenes that happen when you go from LightDM to GDM?

    Thanks,
    Asif

  • @a4orce84 maybe take a look to gnome-tweak-tool and reanable extensions… but common all your settings have to stay like before

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Thanks, I’m unsure which extension is tied to this panel though. I think that’s another issue as well.

  • do you use dash-to-dock?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @a4orce84 , to be honest, I didn t understand the problem.Which pop-out panel menu on the left-hand side: are you talking about? The one with favorite/ running apps? What confuses me more is the screenshot. Is this screenshot showing the Gnome Shell environment???
    As to changes of the environment after changing a DM, I think there shouldn t have happened (at least it has never occurred to me).

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hey Everyone,

    @anarch - I found that image on google, so it is not the most accurate and does not represent my exact Gnome desktop environment. I took a screenshot of my desktop (when logged into LightDM) and am attaching it below:

    alt text

    In the above image, it is the the small menu on the lower left hand side (with the lightbulb, caffeine coffee cup, and update manager status icons). I can ONLY access this panel when I am logged into my Gnome DE using LightDM. Under GDM, I do NOT have this panel / menu on the lower left-hand side.

    @joekamprad - I will look at my extensions under the gnome-tweak settings, but it just seems odd to me that this is missing just because I switched to GDM.

    Please let me know if this is not clear or if you have any additional questions. Thanks!

  • legacy tray… you mean this is for showing apps that do not full integrated into the shell…
    but there is no extension to control it, only to put them into the top panel, but i remember this s disapearing some times when i install or enable an extension…
    or changing theme can also caus this…
    ||.legacy-tray support is inside the gnome-shell.css from themes

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @a4orce84 , are you using the “Top Icond” extension, or “Top Icons Plus”? If so, you should see that little panel inergrated in the top panel. I really cannot see how Gnome s native DM (GDN) could harm its own desktop…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I am not using any “Top Icond” or “Top Icons Plus” packages. All I know is when I log in with LightDM enabled it’s there. When I use GSM, it is not.

    Thanks,
    Asif

  • @joekamprad said in GDM Issues - Missing Panel:

    legacy tray… you mean this is for showing apps that do not full integrated into the shell…
    but there is no extension to control it, only to put them into the top panel, but i remember this s disapearing some times when i install or enable an extension…
    or changing theme can also caus this…
    ||.legacy-tray support is inside the gnome-shell.css from themes

    Is it only inside this .css file? It’s not controlled anywhere else?

    Thanks,
    Asif

  • as it is no extension on it self, and no place for do a grafical configuration, i think not.
    It seems to be a part of the shell.
    You can try to create a test user, start gnome and see if it is visible then.

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • Your problem is easy to solve: Edit the file /etc/gdm/custom.conf (need root permisions) and uncomment the line WaylandEnable=false (delete the #), save the file and reboot:

    in terminal: sudo nano /etc/gdm/custom.conf, with cursor go tho the line with # WaylandEnable=false and delete the #
    Press CTRL+X and save the file. Reboot the system.

  • @Simnandez this causes to use the Xorg backend by default, and wayland will be disabled, but i think it do the same like choosing “gnome-xorg” as session inside gdm?
    I repoduce it inside a Gnome-Box and it is like i say solved the problem by simply choos gnome-X-org to login inside gdm.

    Standard gnome (Wayland session) = no legacy-tray
    gnome X-org (x-org session) = legacy-tray visible

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in GDM Issues - Missing Panel:

    @Simnandez this causes to use the Xorg backend by default, and wayland will be disabled, but i think it do the same like choosing “gnome-xorg” as session inside gdm?
    I repoduce it inside a Gnome-Box and it is like i say solved the problem by simply choos gnome-X-org to login inside gdm.

    Standard gnome (Wayland session) = no legacy-tray
    gnome X-org (x-org session) = legacy-tray visible

    @joekamprad - So, you were able to reproduce the issue?

    Thanks,
    Asif

  • Yes… do you try on your system to login with gnome-xorg?

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad yes you are right, with the custom.conf edition we force always the login screen to use Xorg, with you method we can choose.

  • Hey Everyone,

    So, thank you very much! That got the legacy tray back. One final thing before I mark this question as resolved, another difference between gnome X-org and standard gnome:

    It appears I have some additional gestures under standard gnome (I can use 4-finger swipe to switch desktops), however this feature does NOT work in gnome X-org. Is there a way to get my touchpad to function as if I was l logged into the standard gnome session?

    Thanks,
    Asif

  • You can use gpointing-device-settings o configure tuchpad behavior.

    yaourt -S gpointing-device-settings
    

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

  • @joekamprad said in GDM Issues - Missing Panel:

    You can use gpointing-device-settings o configure tuchpad behavior.

    yaourt -S gpointing-device-settings
    

    But again, shouldn’t touchpad settings be something that is consistent between both Gnome DE’s?

    Thanks,
    Asif

  • @a4orce84 Wayland is different to X-org and wayland is the default choice for gnome now, X-Org is kind of a legacy choice.
    I am with you that the touchpad behavior should be consistent but there are some major changes that comes up with wayland…

    As far as i understand gpointing-device-settings should work under both Wayland and X-Org …

    [updates once a week] = [90% less problems]
    http://gofccyourself.com
    my-blog#k
    how to add system logs
    i3 GNOME

issues52 gdm35 panel19 missing28 Posts 23Views 2776
Log in to reply