• Like 1

    Antergos can't start after installing using ZFS as FS


    After the servers were updated with a version of ZFS compatible with the 4.9 kernel; I proceed with the installation of the OS in a 4GB Ram, Intel Core2Duo, 2 Hard drives of 300GB each; using ZFS as a Filesystem in a mirror configuration.
    Everything went apparently smoothly until I reboot the system, when this message came up:
    0_1485807512473_IMG-20170130-WA0010.jpg

    Now, I’m clueless about what to do.
    I 'd like to append the cnchi.log file, but I don’t have the privileges;so this is the link for the file in my dropbox: https://www.dropbox.com/sh/7fyho0376f4m2s5/AAB_SG1PaEYCExg1flavgBOoa?dl=0

    Help is really appreciated.

    Ernesto[0_1485807943315_cnchi.log](Uploading 100%)

  • Like 0

    Micro$oft has it’s finger in ZFS, so you can not expect it to work porpperly.

    Try BTRFS and you won’t change ever for LVM or ZFS.

    For normal OS stuff I use ext4, server I use BTRFS and it is a charm.

  • Like 0

    @ernestodiazmd

    Ok, I have zfs as my root fs as well and I did the upgrade and saw errors. What the upgrade script does is try to install zfs package before the spl package it depends on. What you’ll need to do is boot into your live usb. modprobe zfs and zpool import -R /mnt your pool

    Then arch-chroot to mnt and run dkms install zfs/0.7.0rc2 or whatever the package is called. Then you will need to run mkinitcpio to generate your intramfs. I also found that I needed to add

    FILES="/usr/lib/libgcc_s.so.1"

    to my /etc/mkinitcpio.conf file as zfs depends on pthreads which depends on the above library. Zfs is becoming mature and widely available now. But it is still early in the game and you can expect bumps in the road until the distributions stabilize with it.

    Cheers,

    Randy

  • Like 0

    @rjonasz

    Even after modifying the /etc/mkinitcpio.conf file I still keep getting the message that libgcc_s.so.1 is not found.

    0_1485895054477_IMG-20170131-WA0012.jpg

    I’m close to complete frustation.

  • Like 0

    @ernestodiazmd I wasn’t kidding when I recomended BTRFS.

    I played a long time with LVM and ZFS has the same problem as LVM has.

    Ones you use BTRFs you will see how easy and simplified working is with BTRFs and it does what LVM or ZFS does just much easier.

    Also, if you use BTRFS on different HDDs as your OS, then I would recommend using a script to mount them . At least it works fine with my media / home server setup, running the OS (Antergos minimal) from a USB stick. and with BTRFS you can always pick up your BTRFs volumes (Raid o, Raid 1, or whatever) after a crashed and destroyed OS, with a fresh install, without the hassle of LVMs or ZFS volumes.

  • Like 0

    Well, now that I’m out of options for using a RAID1 for my Antergos (ZFS was supposed to be the one that could do the trick)… What other options do I have if I want to use RAID1 on my system using Antergos.

    I’d really appreciate the help, so pointers to tutorials in order to get Antergos running with Raid1 is well received,

    BTW, this computer have Intel MATRIX RAID, and I tried installing Antergos with the FakeRAID on (RAID MODE) and off (ACHI mode)

  • Like 0

    @ernestodiazmd BTRFS provides all raid function (software raid).

    Try it you will love it.

  • Like 0

    @ernestodiazmd

    Hi, sorry for the delay. Of course you can switch to btrfs if you like, but if you are like me you will not admit defeat!

    Did you run mkinitcpio in your chroot environment after changing mkinitcpio.conf?

    It doesn’t look like it

  • Like 1

    @rjonasz You understand exactly how I feel. I want to see it working; even if 10 minutes later i delete the whole thing and use BTRFS as @dirkme suggest.

    I’ve done so many things that I can’t remember for sure if I ran mkinitcpio after the change in the .conf
    I’ll do it in a hour (I’m in working hours and, belive it or not, IT is not my field, I’m a MD that happpens to enjoy IT and embracing the FOSS)

  • Like 1

    Thank you @rjonasz! Followed your tip with changing the “FILES” row in /etc/mkinitcpio.conf. After running the obligatory mkinitcpio -p linux everything is up and running again!

    For completeness sake:

    Edit /etc/mkinitcpio.conf. Add the filename as such:

    FILES="/usr/lib/libgcc_s.so.1"
    

    Run

    mkinitcpio -p linux
    

    If in a chroot, exit, unmount and reboot.

    Should be up and running!

  • Like 0

    @rjonasz @AfoHT

    Thank you so much guys! Being a newbie in Arch and Antergos I can say that finally did it! To summarize:

    1. Disable the RAID from the BIOS, set the HDD as AHCI
    2. Run Antergos from the Live USB
    3. Install it as usual, selecting ZFS in a mirror configuration
    4. Restart and see the eror message about no ZFS modules
    5. Reboot using the Antergos Live USB
    6. Open terminal and run $ sudo su
    7. Run:
    # modprobe zfs
    # zpool import -R /mnt/ -f yourzfspool_here
    # mount /dev/sad1 /mnt/boot
    # arch-chroot /mnt/
    # pacman -Syu
    # pacman -S zfs
    
    1. Modify /etc/mkinitcpio.conf
      Search for FILES=""; modify that line so you end up with FILES="/usr/lib/libgcc_s.so.1"
    2. Run # mkinitcpio -p linux

    After that you can reboot to your hard drive right into your Antergos installation.

    There are a couple more of problems to resolve, when you startup you will see:
    ERROR: resume: no device specified for hibernation
    ash: 1: unknown operand
    cannot open 'yourzfs_pool
    no pools avalaible to import

    Nonetheless you will still be able to run Antergos; and the other problem is that the volumes show in the Nemo but you can open them; and the system monitor doesn’t report the amount of space of the ZFS pool.
    I have a 300GB Mirror pool using ZFS, but it says only 0.5 Gb.

    Do you think this is for another post? Where should I post it?

    Regards,

    Ernesto

    1_1486069639691_IMG-20170202-WA0008.jpg 0_1486069639688_IMG-20170202-WA0007.jpg

error106 zfs17 installation159 zfs modules1 Posts 11Views 542
Log in to reply