• Like 0

    ZFS on root compatible with kernel 4.9.6


    Hello,

    I was wondering if the zfs package in antergos’ respository is compatible with arch linux kernel? zfsonlinux.org says the most recent kernel supported is 4.8.

    Thanks,

    Randy

  • Like 1

    No but the packages were just updated a few minutes ago. It’ll take a couple hours for the mirrors to sync. Cheers!

  • Like 0

    It’s out, but doesn’t seem to work very well:

    (1/8) Install DKMS modules
    ==> dkms install zfs/0.7.0rc3 -k 4.9.6-1-ARCH
    configure: error:
    *** Please make sure the kmod spl devel <kernel> package for your
    *** distribution is installed then try again. If that fails you
    *** can specify the location of the spl objects with the
    *** ‘–with-spl-obj=PATH’ option. Failed to find spl_config.h in
    *** any of the following:
    /usr/src/spl-0.7.0rc3/4.9.6-1-ARCH
    /usr/src/spl-0.7.0rc3
    Error! Build of zavl.ko failed for: 4.9.6-1-ARCH (x86_64)
    Consult the make.log in the build directory
    /var/lib/dkms/zfs/0.7.0rc3/build/ for more information.

    So when updated initcpio:

    (2/8) Updating linux initcpios
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘default’
    -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    ==> Starting build: 4.9.6-1-ARCH
    -> Running build hook: [base]
    -> Running build hook: [udev]
    -> Running build hook: [autodetect]
    -> Running build hook: [modconf]
    -> Running build hook: [block]
    -> Running build hook: [keyboard]
    -> Running build hook: [keymap]
    -> Running build hook: [resume]
    -> Running build hook: [zfs]
    ==> ERROR: module not found: ‘zavl’
    ==> ERROR: module not found: ‘znvpair’
    ==> ERROR: module not found: ‘zunicode’
    ==> ERROR: module not found: ‘zcommon’
    ==> ERROR: module not found: ‘zfs’
    ==> ERROR: module not found: ‘zpios’
    -> Running build hook: [filesystems]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
    ==> WARNING: errors were encountered during the build. The image may not be complete.

    But I have /usr/src/spl-0.7.0rc3/spl_config.h, and make.log doesn’t seem to show anything interesting (I can’t post it if needed)

    I don’t think it’s safe for me to reboot right now, otherwise I won’t be able to work anymore!

  • Like 0

    No I didn’t at the time of writing, but it helped a lot, thanks for the information (should work but I didn’t reboot yet) and sorry for duplicating the subject!

kernel56 compatible2 zfs19 root7 Posts 5Views 384
Log in to reply