• Kernel update 4.9.6-1 and zfs


    When trying to run a pacman -Syu this morning, I receive the following error.

    error: failed to prepare transaction (could not satisfy dependencies)
    :: zfs: installing linux (4.9.6-1) breaks dependency ‘linux<4.9’

    Any ideas?

    Thanks,
    BHD

  • Hi,

    Yes, I’m afraid zfs module will build only against 4.8 (and older) kernels.

    I’ll check this out. Meanwhile, do not update your kernel (or you won’t be able to boot if you’re using zfs).

    Cheers!

  • Some findings (got same “issue”):

    Seems like ZFS for 4.9 Kernels will be ready with 0.7.0 version.

    https://github.com/zfsonlinux/zfs/milestone/11
    https://github.com/zfsonlinux/zfs/projects/3

    There are some RC’s of ZFS 0.7.0 available, but i’m not going this route for stability reasons (using Antergos for work on laptop).

    I suggest simply wait with upgrade till everything is ironed out.

  • There are some RC’s of ZFS 0.7.0 available, but i’m not going this route for stability reasons

    Well… we had to provide support for 4.9, so we updated those packages.

  • Did the update over weekend :-)

    Laptop not booted due to "libgcc_s.so.1 must be installed for pthread_cancel to work"
    https://github.com/zfsonlinux/zfs/issues/4749

    FILES="/usr/lib/libgcc_s.so.1"
    into /etc/mkinitcpio.conf
    then running mkinicpio -p linux

    So far all good.

4.9.6-11 zfs34 kernel79 Posts 5Views 866
Log in to reply