• Instalar drivers Nvidia Geforce GTX950 para juegos 3D


    Instalar drivers Nvidia Geforce GTX950 GM260 en Antergos-17.1-x86_64 para juegos 3D
    Me he dado cuenta que aparecen rayas, pequeñas vibraciones y otros defectos de visualización en los juegos 3D. En Antergos se instalan los drivers libres nouveau y necesito instalar los privativos de Nvidia. En la web de Nvidia seleccionando mi tarjeta gráfica me dice que instale NVIDIA-Linux-x86_64-340.101.run.
    Un amigo me ha dicho que en Linux Mint son los denominados:
    nvidia-367 v.367.57-0ubuntu0.16.04.1 que trabajan correctamente.
    Antes de mangarla y quedarme con una pantalla en negro al desinstalar los nouveau e instalar otros me podrían informar cuales son los drivers correctos y cuales son los pasos para poner los de Nvidia.
    Gracias :blush:

    Aprendiendo que no es poco

  • lspci -k | grep -A 2 -E "(VGA|3D)"
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad said in Instalar drivers Nvidia Geforce GTX950 para juegos 3D:

    lspci -k | grep -A 2 -E "(VGA|3D)"
    
    01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 950] (rev a1)
            Subsystem: Micro-Star International Co., Ltd. [MSI] Device 3208
            Kernel driver in use: nouveau
    

    lspci -k | grep -A 2 -E VGA
    Ese comando es para identificar tu tarjeta gráfica y el kernel driver que usa, pero para instalar los controladores propietario Nvidia: ¿desinstalo primero los nouveu? ¿cuáles son los correctos que tengo que desinstalar? ¿y luego instalo los Nvidia? ¿cual de ellos? porque en la búsqueda en pamac salen bastantes con la etiqueta Nvidia?

    Aprendiendo que no es poco

  • La salida te da información sobre la tarjeta, entonces puedo ver qué controlador funcionará para ti.

    Hay un paquete, que proporciona la instalación automática:

    yaourt -S nvidia-installer
    

    Para instalar los controladores y el sistema ajustará automáticamente el programa debe llevarse a cabo:

    nvidia-installer --help
    

    Parece funcionar perfectamente, pero primero lea este wiki para saber lo que está haciendo:

    https://wiki.archlinux.org/index.php/NVIDIA_(Español)

    Y después de reiniciar el sistema:
    Si ejecuta Gnome, elija “Gnome con X-Org” cuando llegue al “lightdm-webkit2-greeter” en Opciones.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Muchas gracias por la ayuda. :+1:
    Información útil:

    En Linux Mint 18.1 (Synaptic) yo tengo instalado para esta gráfica:

    • nvidia-opencl-icd-367 Versión instalada: 367.57-0ubuntu0.16.04.1 (NVIDIA OpenCL ICD) OpenCL (Open Computing Language) is a multivendor open standard for general-purpose parallel programming of heterogeneous systems that include
      CPUs, GPUs and other processors.This package provides the NVIDIA installable client driver (ICD) for OpenCL which supports NVIDIA GPUs.
    • nvidia-prime-applet Versión instalada: 1.0.6 (An applet for NVIDIA Prime) Displays the active GPU and lets you switch to the other one on NVIDIA Optimus cards.

    • nvidia-settings Versión instalada: 361.42-0ubuntu1 (Tool for configuring the NVIDIA graphics driver) The nvidia-settings utility is a tool for configuring the NVIDIALinux graphics driver. It operates by communicating with the NVIDIA X driver, querying and updating state as appropriate. This communication is done with the NV-CONTROL X extension.

    • nvidia-367 Versión instalada: 367.57-0ubuntu0.16.04.1 (NVIDIA binary driver - version 367.57) The binary driver provide optimized hardware acceleration of OpenGL applications via a direct-rendering X Server. AGP, PCIe, SLI, TV-out
      and flat panel displays are also supported. This package also includes the source for building the kernel module required by the Xorg driver, and provides NVIDIA’s implementation of the Video Decode and presentation API. The latter enables acceleration for GeForce 8 and later series cards for h264 video. Release Notes and supported GPUs: http://www.nvidia.com/object/linux-display-amd64-367.57-driver.html

    • nvidia-prime Versión instalada: 0.8.2linuxmint1 (Tools to enable NVIDIA’s Prime). This is a set of tools which will enable. NVIDIA’s Prime on MUXless systems. OPCIONAL- Para elegir entre varias tarjetas gráficas instaladas]

    • libcuda1-367 Versión instalada: 367.57-0ubuntu0.16.04.1 (NVIDIA CUDA runtime library). The Compute Unified Device Architecture (CUDA) enables NVIDIA graphics processing units (GPUs) to be used for massively parallel general purpose computation.This package contains the driver specific runtime library. Supported NVIDIA devices include GPUs starting from GeForce 8 and Quadro FX series, as well as the Tesla computing processors.

    • bbswitch-dkms Versión instalada: 0.8-3ubuntu1 (Interface for toggling the power on NVIDIA Optimus video cards) bbswitch is a kernel module which automatically detects the required ACPI calls for two kinds of Optimus laptops. It has been verified to work with “real” Optimus and “legacy” Optimus laptops (at least, that is what the author Lekensteyn calls those). This package uses DKMS to automatically build the bbswitch kernel module. Prioridad: Extra (el resto: opcionales)

    • ubuntu-drivers-common Versión instalada: 1:0.4.17.2linuxmint1 This package aggregates and abstracts Ubuntu specific logic and knowledge
      about third-party driver packages. It provides:
      a Python API for detecting driver packages for a particular piece of hardware or the whole system.
      an “ubuntu-drivers” command line tool to list or install driver packages (mostly for integration in installers).
      a PackageKit plugin for WhatProvides() for types MODALIAS and HARDWARE_DRIVER, to do the same queries as above through the PackageKit API (for using in non-distro specific GUIs). This works with aptdaemon’s PackageKit compatibility layer (python3-aptdaemon.pkcompat) and with PackageKit’s apt backend, but not with the PackageKit aptcc backend.
      some NVidia specific support code to find the most appropriate driver version, as well as setting up the alternatives symlinks that the proprietary NVidia and FGLRX packages use.

    En Antergos en consola:
    sudo nvidia-installer -b
    Y luego configurar correctamente sino pantalla en negro.

    Aprendiendo que no es poco

  • Sólo hablo un poco de español, por lo que también agradecer a Google Translator.

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Por si puede ayudar, para esta tarjeta gráfica en concreto hay que tener “sólo” instalado en Manjaro (Arch):

    • lib32-nvidia-utils NVIDIA drivers utilities (32-bit) Versión 1:375.26-2
    • linux44-nvidia NVIDIA drivers for linux. Versión 1:375.26-5
    • mhwd-nvidia MHWD module-ids for nvidia 375.26 Versión 1:375.26-1
    • mhwd-nvidia-304xx MHWD module-ids for nvidia 304.134 Versión 1:304.134-1
    • mhwd-nvidia-340xx MHWD module-ids for nvidia 340.101 Versión 340.101-1
    • nvidia-utils NVIDIA drivers utilities Versión 1:375.26-2

    Pero también hay que desactivar los drivers “nouveau”.

    Aprendiendo que no es poco

  • desactivar los drivers “nouveau”:

    /etc/modprobe.d/blacklist-nouveau.conf
    blacklist nouveau
    

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • Seguimos esa ruta:
    /etc/modprobe.d/blacklist-nouveau.conf
    Pinchamos en nouveau.conf con el botón derecho del ratón, Opciones de root> Abrir como texto y ponemos:
    blacklist nouveau
    Luego guardamos y cerramos.
    Ahora mismo en Antergos KDE tengo instalados sólo estos archivos de Nvidia para esta tarjeta gráfica:

    nvidia-utils -Versión 381.22-1 ¡108,1 MB! Proporciona: Vulkan-driver, OpenGl-driver y Nvidia-libgl (Instalar con dependencias. Reemplaza nvidia-libgl -Versión 378.13-3 Nvidia drivers libraries symlinks) (Instala: nvidia-settings -Versión 381.22-1 (Nvidia propietario) (Instala: opencl-nvidia -Versión 381.22-1).

    nvidia-dkms 381.22-2 Nvidia driver sources for Linux (Instalar con dependencias: linux-headers, linux-lts-headers). Conflicto con: Nvidia y Nvidia-lts).

    lib32-nvidia-utils -Versión 381.22-1 Proporciona: li32-nvidia-libgl, lib32-vulkan-driver, lib32-opengl-driver. (Reemplaza lib32-nvidia-libgl Versión 378.13-1) (Instalar en Dependencias: lib32-opencl-nvidia Versión 381.22-1 -OpenCL implemention for NVIDIA (32bits)(Nvidia propietario).

    libvdpau -Nvidia VDPAU library 1.1.1-2 Librerias (Ya viene instalado por defecto, no se actualiza mucho)
    libxnvctrl -NVIDIA NV-CONTROL X extension (Nvidia propietario) Versión 381.22-1 (Ya viene instalado por defecto)
    xorg-server-devel v.1.19.3-2 (nvidia-xconfig) Development files for the X.Org X Server (Ya instalado. No se actualiza mucho)
    opencl-headers: headers necessary for OpenCL development (Nvidia propietario) v.2:2.1.20161129-2 (no se actualiza mucho)

    Añadidos posteriormente para Steam (Native):
    lsb-release 1.4-14 (no se actualiza mucho)
    lib32-llvm-libs v.3.9.1-2 (Ya instalado)

    Parece ir bien ¿hay algún error? ¿me sobra o me falta algo?

    Aprendiendo que no es poco

  • Estos también hacen un buen trabajo:

    • lib32-libvdpau
    • lib32-nvidia-libgl
    • libvdpau
    • libxnvctrl
    • nvdock

    Pero, ¿qué quieres preguntar?
    ¿Los gráficos que trabajan para los juegos ahora?

    Para Blacklist nouveau en el arranque también es posible poner “nouveau.blacklist=1” en el grub, Línea de Parámetros del Kernel

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • @joekamprad Yo utilicé el comando: yaourt -S nvidia-installer
    Y yo escribí: blacklist nouveau
    en: /etc/modprobe.d/blacklist-nouveau.conf
    Pero luego entré en Pamac-manager y ví que yo tenía pocos archivos de Nvidia instalados (en comparación en Linux Mint y Manjaro tenía varios más archivos de Nvidia instalados). Por eso yo instalé manualmente esos archivos.
    Mi pregunta es si lo había hecho bien, si esos son los archivos Nvidia que tenía que instalar en Antergos o yo he instalado archivos de más o me falta alguno.

    Aprendiendo que no es poco

  • Esto depende de sus necesidades, y qué paquetes desea ejecutar

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

steam53 nvidia98 drivers29 juegos4 Posts 12Views 942
Log in to reply